Showing 18 open source projects for "smtp--"

View related business solutions
  • $300 Free Credits to Build on Google Cloud Icon
    $300 Free Credits to Build on Google Cloud

    New customers can spin up VMs, build with AI, and query data at no cost.

    Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
    Start Free
  • Demo Series - Small Business Backup By Veeam Icon
    Demo Series - Small Business Backup By Veeam

    Learn how to protect your Microsoft 365 data, with simple, actionable tips today.

    Watch this on-demand demo series and learn how to protect your Microsoft 365 data with clear, simple, actionable steps that are easy to implement for businesses of all sizes.
    Watch Demo Series
  • 1
    MailDev

    MailDev

    Web Interface for viewing and testing emails during development

    MailDev is an SMTP server with a web interface designed for viewing and testing emails during development. It allows developers to inspect and debug emails sent from their applications without delivering them to real inboxes.
    Downloads: 4 This Week
    Last Update:
    See Project
  • 2
    Swaks

    Swaks

    Swaks - Swiss Army Knife for SMTP

    swaks (Swiss Army Knife for SMTP) is a powerful command-line tool for testing and debugging SMTP servers. It allows users to craft custom SMTP sessions with fine-grained control over headers, authentication, TLS, attachments, and more. swaks is commonly used by sysadmins and developers to diagnose mail delivery problems or test SMTP server configurations.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 3
    Origami SMTP

    Origami SMTP

    Fake SMTP server with TLS Support

    Origami is a Fake SMTP server that features TLS support. It is platform independent, can read HTML emails, and can be customized.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4
    MailHog

    MailHog

    Web and API based SMTP testing

    Inspired by MailCatcher, easier to install. Built with Go, MailHog runs without installation on multiple platforms. Run it from Docker Hub or using the provided Dockerfile. The SMTP server starts on port 1025, the HTTP server starts on port 8025, in-memory message storage. ESMTP server implementing RFC5321. Support for SMTP AUTH (RFC4954) and PIPELINING (RFC2920). Web interface to view messages (plain text, HTML or source). Supports RFC2047 encoded headers. Real-time updates using EventSource. Release messages to real SMTP servers. ...
    Downloads: 53 This Week
    Last Update:
    See Project
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • 5
    HTTP Test Tool
    httest is a script based tool for testing and benchmarking web applications, web servers, proxy servers and web browsers. httest can emulate clients and servers in the same test script, very useful for testing proxys.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 6
    BHS Debian (Hades Update)

    BHS Debian (Hades Update)

    BHS debian (testing) jessie/sid

    BHS (Debian) New BHS release Based on Debian jessie/sid Kermel 3.12 KDE 4.11 Debian style and look Custom scripts!! Defcon tools!! New wifi scripts Multiarch support Top tools username: root password: BHS note: Don't forget to run the script located on the desktop to install the missing tools,because without to run it the menu will not be functional,if you not see it just download from here in the file section..sorry for the delay the upload stack for 2...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 7

    sender

    tcp/ip utility for testing network connections/ports

    Sender is a windows tcp/ip client/host that lets you send and recieve text to and from tcp/ip ports. It now has a hex mode so that you can send any 8bit byte combinations. It can be used for testing simple pop and smtp connections (original project reason) or for any other protocols for which you may want to test by hand from windows.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 8

    PyLoris

    A protocol agnostic application layer denial of service attack.

    PyLoris is a scriptable tool for testing a server's vulnerability to connection exhaustion denial of service (DoS) attacks. PyLoris can utilize SOCKS proxies and SSL connections, and can target protocols such as HTTP, FTP, SMTP, IMAP, and Telnet.
    Leader badge
    Downloads: 30 This Week
    Last Update:
    See Project
  • 9
    Jmeter Enhancements

    Jmeter Enhancements

    This project contains some useful enhancements implemented in Jmeter.

    ...Bandwidth Throttling: More enhancements such as follows are also implemented. -Bandwidth throttling -Dynamic bandwidth throttling -IP Spoofing -TPC-C Sampler -Smtp config element -Filterd Results Plugin please refer description.pdf in files.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 10
    SPIZD stands for Stress Probing Invasive Zap Destructor; it's a command-line stress test tool used to determine how many simultaneous (concurrent) connections servers can handle. Protocols: http, pop3, pop3s, imap, imaps, smtp, smtps, ssh, radius.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    xstress is a SMTP mail server stress testing tool. xstress creates multiple connections (using threads) to the (configured) mail server and sends mails with varying subject, body, attachment and TO/FROM addresses.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    Mstone is a mail performance measurement system. It can simultaneously test SMTP, POP, IMAP, and some HTML based systems. It measures transaction latency in multiple stages, and graphs the combined results from multiple clients.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    Bannergrab is a next generation network service banner grabbing tool. In addition to simple banner grabbing it can send triggers to various services such as FTP, SMTP and HTTP to enumerate additional information, including support for SSL services.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    FakeSMTPServer is a solution for testing web-based products that require a "unique" email address. Instead of being a "real" smtp server, this server forwards all email to a single email address, or can output them to the console instead.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    Mock objects for JUnitTests for common network services: http(s), SMTP and POP3. The focus was to easily have the services return defined errors or predefined documents independent of application level security and sophisticated data-store.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    Fake SMTP provides an easy way of testing email enabled application during development. This is a pltaform independent software written in Java, and based on the Dumbster project.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    The goal of the project is to port the dumbster project to C#. It is a simple SMTP server that responds to SMTP requests and stores the messages to be queried in a manner suitable for .Net based automated test frameworks such as nMock.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    The goal of this project is to develop a very simple SMTP server that responds to SMTP requests and makes received messages available for query at a later time. All useful features for a SMTP server that can be used in an automated testing suite.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • Next