Showing 19 open source projects for "mail server script"

View related business solutions
  • Ship Agents Faster Icon
    Ship Agents Faster

    Transform your applications and workflows into powerful agentic systems at global scale.

    Gemini Enterprise Agent Platform lets you rapidly build, scale, govern and optimize production-ready agents grounded in your organization's data. The platform enables developers to build custom or pre-built agents for virtually any use case. New customers get $300 in free credits.
    Start Free
  • $300 Free Credits to Build on Google Cloud Icon
    $300 Free Credits to Build on Google Cloud

    New customers can spin up VMs, build with AI, and query data at no cost.

    Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
    Start Free
  • 1
    Swaks

    Swaks

    Swaks - Swiss Army Knife for SMTP

    ...It allows users to craft custom SMTP sessions with fine-grained control over headers, authentication, TLS, attachments, and more. swaks is commonly used by sysadmins and developers to diagnose mail delivery problems or test SMTP server configurations.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 2
    ...ContiPerf enables performance testing already in early development phases and in an easy-to-learn manner: A developer writes a performance test in form of a JUnit 4 test case and adds performance test execution settings as well as performance requirements in form of Java annotations. When JUnit is invoked by an IDE, build script or build server, ContiPerf activates, performs the tests and creates an HTML report. The report provides a detailed overview of execution, requirements and measurements, even providing a latency distribution chart. A large feature set for execution settings and performance requirements is available, e.g. Ramp up, warm up, individual pause timing, concurrent exection of test groups and more.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 3
    MailHog

    MailHog

    Web and API based SMTP testing

    Inspired by MailCatcher, easier to install. Built with Go, MailHog runs without installation on multiple platforms. Run it from Docker Hub or using the provided Dockerfile. The SMTP server starts on port 1025, the HTTP server starts on port 8025, in-memory message storage. ESMTP server implementing RFC5321. Support for SMTP AUTH (RFC4954) and PIPELINING (RFC2920). Web interface to view messages (plain text, HTML or source). Supports RFC2047 encoded headers. Real-time updates using...
    Downloads: 53 This Week
    Last Update:
    See Project
  • 4
    sysbench

    sysbench

    Scriptable database and system performance benchmark

    ...Can be used as a general-purpose Lua interpreter as well, simply replace #!/usr/bin/lua with #!/usr/bin/sysbench in your script. Execute events for this many seconds with statistics disabled before the actual benchmark run with statistics enabled. This is useful when you want to exclude the initial period of a benchmark run from statistics.
    Downloads: 1 This Week
    Last Update:
    See Project
  • Save Up to 91% on Cloud Compute With Spot VMs Icon
    Save Up to 91% on Cloud Compute With Spot VMs

    Automatic sustained-use discounts. One free VM per month. No negotiation needed.

    Run batch jobs at 60-91% off with Spot VMs. Long-running workloads get automatic discounts with sustained use.
    Start Free
  • 5
    retrap

    retrap

    Open-Source intelligence tracking and analysis tool.

    (OSINT) Open-Source intelligence tracking and analysis tool. - Disclaimer: This tool is experimental in its Alpha phase. It's developed and published as a small building block of a master's thesis research. So use it for educational purposes only and at your own discretion, the author cannot be held responsible for any damages caused.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    HTTP Test Tool
    httest is a script based tool for testing and benchmarking web applications, web servers, proxy servers and web browsers. httest can emulate clients and servers in the same test script, very useful for testing proxys.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 7
    Hitchhiker

    Hitchhiker

    A restful API test tool

    Hitchhiker API is a Restful Api integrated testing tool that supports Schedule, Response comparison, Stress Test, support upload js file to hook request, easy to deploy it in your local server. It makes it easier to manage API with your team. API collaboration development with team. Api history. Multiple environments and Runtime variables support, easy to handle api dependence. Assert based on UI. Powerful script, support requiring any js lib which upload to project, read excel, cryptographic, no can't do. Request parameterization, including ManytoMany and OnetoOne, now you can use a request to handle multiple situations like various query strings, bodies. ...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 8

    Metric Collector

    A bash-Script to collect metrics from a Linux system.

    Collects server and java process information from various tools and creates charts with the data. The script was tested on GNU/Linux with gnuplot 4.4. For the script to work you have to set the variable "JAVA_HOME" to a valid JDK location. Check the documentation in the script file. The following information gets collected: >> output from vmstat >> netstat tcp states and established connections >> information from /proc/fd >> jstat -gc output >> jstat -class output >> CPU%, MEM% and ThreadCount from top and ps-command >> disk usage for each mounted device from df-command
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    OpKey Personal Edition

    OpKey Personal Edition

    The Tool Agnostic Test Automation Platform

    It is not easy to find a perfect combination of open source automation tool and a free enterprise grade automation framework on top it. You can have this combination working for you when you use OpKey Personal Edition - The Tool Agnostic Test Automation Platform with Selenium RC(OpKey 1.0) and Selenium WebDriver(OpKey 2.0)- The most popular open source tool. And good news is - its FREE! So download it and start automating from day 1. Have Questions? Mail us at...
    Downloads: 0 This Week
    Last Update:
    See Project
  • Veeam Data Platform v13.1 - Get Your Free Trial Icon
    Veeam Data Platform v13.1 - Get Your Free Trial

    Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try it Free
  • 10

    sitecheck

    Modular web site spider for web developers.

    More than just a link checker, sitecheck is a website spider (also known as a crawler) which can assist with SEO by testing an entire site plus both inbound links from search engines and outbound links to other sites for the following issues: looping redirects (HTTP 301/302), broken links (HTTP 404), server errors (HTTP 500), spelling mistakes, low readability scores (using the Flesch Reading Ease test), missing/empty/duplicate meta tags, duplicate content, slow page speed, W3C validation errors and accessibility errors. Sitecheck can also spot some common causes of PCI compliance failure such as insecure content on secure pages, SQL injection/cross-site scripting (XSS) vulnerabilities, insecure encryption ciphers and open mail relays. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11

    dove

    a powerful little soap client.

    A little super-simple but powerful soap client that offers an easy way to send soap request to a server (from file or stdin), test server robustness by sending same request on multiple threads and eventually see the whole http conversation. If you need a quick and easy way to do soapcalls from your terminal or script, this tool is for you.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12

    TestMax

    Frontend & Backend Automation Tool

    TestMax is integrated Software Testing framework which can be used to test distributed system by developing rapid test cases using XML configuration in front and backend that talks to each other within the test framework. This tool can be used for Database, webservice, API, Junit, TestNg and Frontend including performance test. The main advantage of this TestMax architecture is separating test data configuration from test case run time environment. It reduces the maintenance of test cases...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    Mailster is a project aimed at testing software mail capabilities. It provides a mail server container to test emails sent by your apps without rewriting your application code.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    xstress is a SMTP mail server stress testing tool. xstress creates multiple connections (using threads) to the (configured) mail server and sends mails with varying subject, body, attachment and TO/FROM addresses.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    Glossword Checker is PHP-script which checks if your server configuration meets the requirements for running PHP-applications.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    FitNesse.NAntTasks contains a set of custom NAnt tasks to handle starting and stopping the FitNesse server as part of a NAnt script. Future tasks may include running tests and parsing results into XML, plus other utilities.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    The goal of this project is to develop a very simple SMTP server that responds to SMTP requests and makes received messages available for query at a later time. All useful features for a SMTP server that can be used in an automated testing suite.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    DevMentor Linux base Distro Will be compact with small install footprint, minimize memory and resource consumption. Clean separation of areas: 1. Stand alone server base ( mail, ftp, proxy, http, file-server, ... ) 2. Development Tools, Console Editors 3
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19

    Everything is Slow!

    An automated network speed test utility

    This is a utility intended for IT professionals to deploy to their users. It will do several speed tests and report the results to an e-mail address, helping to track down complaints that "everything is slow"
    Downloads: 0 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • Next