Showing 813 open source projects for "json-taglib"

View related business solutions
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • 1
    JSON-java

    JSON-java

    A reference implementation of a JSON package in Java

    JSON is a light-weight language-independent data interchange format. The JSON-Java package is a reference implementation that demonstrates how to parse JSON documents into Java objects and how to generate new JSON documents from the Java classes.
    Downloads: 34 This Week
    Last Update:
    See Project
  • 2
    JSON-Machine

    JSON-Machine

    Efficient, easy-to-use, and fast PHP JSON stream parser

    json-machine is an efficient and easy-to-use PHP JSON stream parser. It enables processing of large JSON files or streams without loading the entire content into memory, making it suitable for memory-constrained environments.​
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3
    Json.NET

    Json.NET

    A popular high-performance JSON framework for .NET

    Serialize and deserialize any .NET object with Json.NET's powerful JSON serializer. Create, parse, query and modify JSON using Json.NET's JObject, JArray and JValue objects. Query JSON with an XPath-like syntax. 50% faster than DataContractJsonSerializer, and 250% faster than JavaScriptSerializer. Json.NET makes the simple easy and the complex possible. If you need it, Json.NET supports converting between XML and JSON.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 4
    json-graphql-server

    json-graphql-server

    Get a full fake GraphQL API with zero coding in less than 30 seconds

    Get a full fake GraphQL API with zero coding in less than 30 seconds. Start playing with GraphQL right away with json-graphql-server, a testing and mocking tool for GraphQL. All it takes is a JSON of your data. Your data file should export an object where the keys are the entity types. The values should be lists of entities, i.e. arrays of value objects with at least an id key. The json-graphql-server accepts queries in GET and POST. Under the hood, it uses the express-graphql module. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 99.99% Uptime for MySQL and PostgreSQL Databases Icon
    99.99% Uptime for MySQL and PostgreSQL Databases

    Sub-second maintenance. 2x read/write performance. Built-in vector search for AI apps.

    Cloud SQL Enterprise Plus delivers near-zero downtime with 35 days of point-in-time recovery. Supports MySQL, PostgreSQL, and SQL Server.
    Start Free
  • 5
    Alternative JSON parser for Go

    Alternative JSON parser for Go

    One of the fastest alternative JSON parser for Go

    ...I investigated what's on the market and found that most libraries are just wrappers around encoding/json, there is few options with own parsers (ffjson, easyjson), but they still require you to create data structures. The goal of this project is to push JSON parser to the performance limits and not sacrifice with compliance and developer user experience.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 6
    ArduinoJson

    ArduinoJson

    JSON library for Arduino and embedded C++. Simple and efficient

    ArduinoJson is a C++ JSON library for Arduino and IoT (Internet Of Things). ArduinoJson has a simple and intuitive syntax to handle objects and arrays. ArduinoJson supports both JSON serialization and deserialization. ArduinoJson uses a fixed memory allocation, allowing to work on devices with very little RAM. ArduinoJson can filter large inputs to keep only fields that are relevant to your application, thereby saving a lot of memory.
    Downloads: 33 This Week
    Last Update:
    See Project
  • 7
    JWT

    JWT

    A simple library to work with JSON Web Token and JSON Web Signature

    lcobucci/jwt is a framework-agnostic PHP library that allows you to issue, parse, and validate JSON Web Tokens based on the RFC 7519. The package is available on Packagist, you can install it using Composer. A simple library to work with JSON Web Token and JSON Web Signature based on RFC 7519. Once the library has been installed, you are able to issue and parse JWTs. To reduce the chance of having flaky tests on your test suite, the facade supports the usage of a clock object. ...
    Downloads: 13 This Week
    Last Update:
    See Project
  • 8
    JsonCpp

    JsonCpp

    A C++ library for interacting with JSON

    JSON is a lightweight data-interchange format. It can represent numbers, strings, ordered sequences of values, and collections of name/value pairs. JsonCpp is a C++ library that allows manipulating JSON values, including serialization and deserialization to and from strings. It can also preserve existing comment in unserialization/serialization steps, making it a convenient format to store user input files.
    Downloads: 10 This Week
    Last Update:
    See Project
  • 9
    trdsql

    trdsql

    CLI tool that can execute SQL queries on CSV, LTSV, JSON and TBLN

    CLI tool that can execute SQL queries on CSV, LTSV, JSON and TBLN. Can output to various formats. CLI tool that can execute SQL queries on CSV, LTSV, JSON and TBLN. It is a tool like q, textql and others. The difference from these tools is that the syntax of PostgreSQL or MySQL can be used. Please refer to godoc and _example for usage as a library. Download binary from the releases page(Linux/Windows/macOS).
    Downloads: 18 This Week
    Last Update:
    See Project
  • Train ML Models With SQL You Already Know Icon
    Train ML Models With SQL You Already Know

    BigQuery automates data prep, analysis, and predictions with built-in AI assistance.

    Build and deploy ML models using familiar SQL. Automate data prep with built-in Gemini. Query 1 TB and store 10 GB free monthly.
    Start Free
  • 10
    Gson

    Gson

    A Java serialization/deserialization library to convert Java Objects

    Gson is a Java library developed by Google that allows conversion between Java objects and JSON. It enables serialization and deserialization of Java classes to and from JSON format, handling complex and generic types, nulls, custom naming policies, and more. Gson is lightweight, easy to use, and does not require annotation-based configuration, making it a popular choice for JSON processing in Java applications.
    Downloads: 35 This Week
    Last Update:
    See Project
  • 11
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 1 This Week
    Last Update:
    See Project
  • 12
    Render

    Render

    Go package for easily rendering JSON, XML, binary data, and HTML

    Render is a package that provides functionality for easily rendering JSON, XML, text, binary data, and HTML templates. Render can be used with pretty much any web framework provided you can access the HTTP.ResponseWriter from your handler. The rendering functions simply wraps Go's existing functionality for marshaling and rendering data. HTML: Uses the html/template package to render HTML templates. JSON: Uses the encoding/json package to marshal data into a JSON-encoded response. ...
    Downloads: 8 This Week
    Last Update:
    See Project
  • 13
    fastjson

    fastjson

    A fast JSON parser/generator for Java

    Fastjson is a Java library that can be used to quickly convert Java Objects into their JSON representation or convert JSON strings to their equivalent Java object. Based on benchmarks it provides the best performance in both server side and Android client, and can work with arbitrary Java objects, even those pre-existing objects of which you do not have the source code. Fastjson provides a simple conversion method to turn Java objects to JSON and vice versa, with extensive support of Java Generics and arbitrarily complex objects.
    Downloads: 10 This Week
    Last Update:
    See Project
  • 14
    Cheshire

    Cheshire

    Clojure JSON and JSON SMILE (binary json format) encoding/decoding

    Cheshire is a high-performance JSON encoding and decoding library for Clojure, built atop Jackson to combine fast parsing/generation with advanced support for types like Dates, UUIDs, Sets, Symbols, and the binary JSON SMILE format. Custom encoding is supported from 2.0.0 and up if you encounter a bug, please open a GitHub issue. From 5.0.0 onwards, custom encoding has been moved to be part of the core namespace (not requiring a namespace change).
    Downloads: 5 This Week
    Last Update:
    See Project
  • 15
    GJSON

    GJSON

    Get JSON values quickly, JSON parser for Go

    GJSON is a Go library designed for extremely fast, allocation-free retrieval of values from JSON documents. It enables you to query nested JSON structures using one-liner dot-notation or array-based paths and includes wildcard and comparison operators. The library is optimized for speed and zero allocations, benchmarking significantly faster than Go’s standard encoding/json unmarshal approaches. It supports parsing JSON lines (newline-delimited JSON) as an array for large stream processing. ...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 16
    NSwag

    NSwag

    The Swagger/openAPI toolchain for .NET, ASP.NET Core and TypeScript

    ...This way a lot of incompatibilities can be avoided and features that are not well described by the OpenAPI specification or JSON Schema are better supported (e.g. inheritance, enum and reference handling). The NSwag project heavily uses NJsonSchema for .NET for JSON Schema handling and C#/TypeScript class/interface generation.
    Downloads: 19 This Week
    Last Update:
    See Project
  • 17
    jwx

    jwx

    Implementation of various JWx (Javascript Object Signing

    ...It really helps keeping up our motivation. Complete coverage of JWA/JWE/JWK/JWS/JWT, not just JWT+minimum tool set. Supports JWS messages with multiple signatures, both compact and JSON serialization. Supports JWS with detached payload. Supports JWS with unencoded payload (RFC7797). Supports JWE messages with multiple recipients, both compact and JSON serialization. Most operations work with either JWK or raw keys e.g. *rsa.PrivateKey, *ecdsa.PrivateKey, etc). Opinionated, but very uniform API. Everything is symmetric, and follows a standard convention. ...
    Downloads: 2 This Week
    Last Update:
    See Project
  • 18
    JC

    JC

    CLI tool and python library

    ...In this case, the output will be a python dictionary, or a list of dictionaries, instead of JSON. Two representations of the data are available. The default representation uses a strict schema per parser and converts known numbers to int/float JSON values. Certain known values of None are converted to JSON null, known boolean values are converted, and, in some cases, additional semantic context fields are added.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 19
    fx

    fx

    Command-line tool and terminal JSON viewer

    ...To be able require global modules make sure you have correct NODE_PATH env variable. If you need output other than JSON (for example arguments for xargs), do not return anything from the reducer. undefined value is printed into stderr by default. Sometimes it is necessary to omit some messages in JSON stream, or select only specified log messages. For this purpose, fx has special helpers select/filter, pass function into it to select/filter JSON messages.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 20
    gofeed

    gofeed

    Parse RSS, Atom and JSON feeds in Go

    The gofeed library is a robust feed parser that supports parsing both RSS, Atom and JSON feeds. The library provides a universal gofeed. Parser that will parse and convert all feed types into a hybrid gofeed.Feed model. You also have the option of utilizing the feed-specific atom. Parser or RSS. Parser or JSON. Parser parsers generate atoms. Feed, RSS.Feed and JSON. Feed respectively. The gofeed library is comprised of a universal feed parser and several feed-specific parsers. ...
    Downloads: 3 This Week
    Last Update:
    See Project
  • 21
    vcr

    vcr

    Record your test suite's HTTP interactions and replay them

    ...You can use a different cassette library directory (e.g., "test/vcr_cassettes"). The recorded requests and responses are stored on disk in a serialization format of your choice (currently YAML and JSON are built in, and you can easily implement your own custom serializer) and can easily be inspected and edited.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 22
    Taplo

    Taplo

    A TOML toolkit written in Rust

    A versatile, feature-rich TOML toolkit. This is the repository for Taplo, a TOML v1.0.0 toolkit, more details are on the website. Validate TOML documents syntactically or against JSON schemas. Formatter with fine-grained options. Embeddable language server with features based on JSON schemas. Available wherever Rust compiles. Taplo CLI aims to be an one stop shop tool for working with TOML files via the command line. The features include validation, formatting, and querying TOML documents with a jq-like fashion.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 23
    wx-cli

    wx-cli

    WeChat local data CLI with daemon architecture

    ...The tool can inspect conversations, chat history, unread messages, contacts, group members, group nicknames, favorites, statistics, exports, SNS feed items, public account articles, and image attachments. It is designed to be AI-agent friendly, with YAML output by default and optional JSON output for automation or downstream processing. The project keeps data local, decrypts in real time, and avoids full pre-decryption workflows. It is useful for users who need searchable, scriptable access to their own WeChat records while preserving local control over the data.
    Downloads: 36 This Week
    Last Update:
    See Project
  • 24
    null

    null

    Reasonable handling of nullable values

    null is a library with reasonable options for dealing with nullable SQL and JSON values. There are two packages: null and its subpackage zero. Types in null will only be considered null on null input, and will JSON encode to null. If you need zero and null be considered separate values, use these. Types in zero are treated like zero values in Go: blank string input will produce a null zero.String, and null Strings will JSON encode to "".
    Downloads: 4 This Week
    Last Update:
    See Project
  • 25
    RestSharp

    RestSharp

    Simple REST and HTTP API Client for .NET

    ...However, RestSharp can call any API over HTTP (but not HTTP/2), as long as you have the resource URI and request parameters that you want to send comply with W3C HTTP standards. RestSharp can take care of serializing the request body to JSON or XML and deserialize the response. It can also form a valid request URI based on different parameter kinds.
    Downloads: 2 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • 3
  • 4
  • 5
  • Next