Showing 852 open source projects for "json-py"

View related business solutions
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • Ship Agents Faster Icon
    Ship Agents Faster

    Transform your applications and workflows into powerful agentic systems at global scale.

    Gemini Enterprise Agent Platform lets you rapidly build, scale, govern and optimize production-ready agents grounded in your organization's data. The platform enables developers to build custom or pre-built agents for virtually any use case. New customers get $300 in free credits.
    Start Free
  • 1
    JSON-java

    JSON-java

    A reference implementation of a JSON package in Java

    JSON is a light-weight language-independent data interchange format. The JSON-Java package is a reference implementation that demonstrates how to parse JSON documents into Java objects and how to generate new JSON documents from the Java classes.
    Downloads: 34 This Week
    Last Update:
    See Project
  • 2
    py-spy

    py-spy

    Sampling profiler for Python programs

    py-spy is a sampling profiler for Python programs. It lets you visualize what your Python program is spending time on without restarting the program or modifying the code in any way. py-spy is extremely low overhead: it is written in Rust for speed and doesn't run in the same process as the profiled Python program. This means py-spy is safe to use against production Python code. py-spy works from the command line and takes either the PID of the program you want to sample from or the command line of the python program you want to run. py-spy has three subcommands record, top and dump. py-spy supports recording profiles to a file using the record command. ...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 3
    blinker-py

    blinker-py

    Blinker python library for hardware. Works with Raspberry Pi

    blinker-py is a Python library for connecting hardware projects to the Blinker IoT platform. It is designed for Raspberry Pi, Banana Pi, Linux devices, and similar single-board or embedded systems. The library helps developers control hardware through the Blinker mobile app, where users can build graphical interfaces with drag-and-drop widgets.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4
    xqvm-py

    xqvm-py

    A python implementation of the Quip Network's quantum virtual machine

    xq-py is a Python implementation of the Quip Network’s quantum virtual machine, offering a more accessible and flexible alternative to the Rust-based version for experimentation and rapid development. It is designed to provide similar functionality to xq-rs while prioritizing ease of use, readability, and integration with Python-based data science and research tools.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Veeam Data Platform v13.1 - Get Your Free Trial Icon
    Veeam Data Platform v13.1 - Get Your Free Trial

    Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try it Free
  • 5
    redis-py

    redis-py

    Redis Python client

    redis-py is the official Python client for interacting with Redis, the in-memory data structure store. It supports all Redis commands and data types, making it easy to build caching, messaging, or real-time analytics features in Python applications. With both synchronous and asyncio support, redis-py is suited for modern Python projects and integrates smoothly into web frameworks, task queues, and backend services.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    JSON-Machine

    JSON-Machine

    Efficient, easy-to-use, and fast PHP JSON stream parser

    json-machine is an efficient and easy-to-use PHP JSON stream parser. It enables processing of large JSON files or streams without loading the entire content into memory, making it suitable for memory-constrained environments.​
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    Json.NET

    Json.NET

    A popular high-performance JSON framework for .NET

    Serialize and deserialize any .NET object with Json.NET's powerful JSON serializer. Create, parse, query and modify JSON using Json.NET's JObject, JArray and JValue objects. Query JSON with an XPath-like syntax. 50% faster than DataContractJsonSerializer, and 250% faster than JavaScriptSerializer. Json.NET makes the simple easy and the complex possible. If you need it, Json.NET supports converting between XML and JSON.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 8
    DBOS Transact PY

    DBOS Transact PY

    Lightweight Durable Python Workflows

    dbos-transact-py is the Python counterpart to dbos-transact-ts, offering durable transactional programming with automatic state persistence in PostgreSQL. It simplifies building resilient and idempotent applications by enabling Python functions to retain their state, restart after failure, and guarantee consistency. It's designed for data-heavy and fault-intolerant use cases.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 9
    json-graphql-server

    json-graphql-server

    Get a full fake GraphQL API with zero coding in less than 30 seconds

    Get a full fake GraphQL API with zero coding in less than 30 seconds. Start playing with GraphQL right away with json-graphql-server, a testing and mocking tool for GraphQL. All it takes is a JSON of your data. Your data file should export an object where the keys are the entity types. The values should be lists of entities, i.e. arrays of value objects with at least an id key. The json-graphql-server accepts queries in GET and POST. Under the hood, it uses the express-graphql module. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • Train ML Models With SQL You Already Know Icon
    Train ML Models With SQL You Already Know

    BigQuery automates data prep, analysis, and predictions with built-in AI assistance.

    Build and deploy ML models using familiar SQL. Automate data prep with built-in Gemini. Query 1 TB and store 10 GB free monthly.
    Start Free
  • 10
    dynaconf

    dynaconf

    Configuration Management for Python

    ...On your own code you import and use settings object imported from your config.py file. Dynaconf prioritizes the use of environment variables and you can optionally store settings in Settings Files using any of toml|yaml|json|ini|py extension.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    Alternative JSON parser for Go

    Alternative JSON parser for Go

    One of the fastest alternative JSON parser for Go

    ...I investigated what's on the market and found that most libraries are just wrappers around encoding/json, there is few options with own parsers (ffjson, easyjson), but they still require you to create data structures. The goal of this project is to push JSON parser to the performance limits and not sacrifice with compliance and developer user experience.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 12
    ArduinoJson

    ArduinoJson

    JSON library for Arduino and embedded C++. Simple and efficient

    ArduinoJson is a C++ JSON library for Arduino and IoT (Internet Of Things). ArduinoJson has a simple and intuitive syntax to handle objects and arrays. ArduinoJson supports both JSON serialization and deserialization. ArduinoJson uses a fixed memory allocation, allowing to work on devices with very little RAM. ArduinoJson can filter large inputs to keep only fields that are relevant to your application, thereby saving a lot of memory.
    Downloads: 33 This Week
    Last Update:
    See Project
  • 13
    Gitinspector

    Gitinspector

    The statistical analysis tool for git repositories

    ...This tool was originally written to help fetch repository statistics from student projects in the course Object-oriented Programming Project (TDA367/DIT211) at Chalmers University of Technology and Gothenburg University. Shows cumulative work by each author in history. Filters results by an extension (default: java,c,cc,cpp,h,hh,hpp,py,glsl,rb,js, SQL). Can display a statistical timeline analysis. Scans for all filetypes (by extension) found in the repository. Multi-threaded; uses multiple instances of git to speed up analysis when possible.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 14
    JWT

    JWT

    A simple library to work with JSON Web Token and JSON Web Signature

    lcobucci/jwt is a framework-agnostic PHP library that allows you to issue, parse, and validate JSON Web Tokens based on the RFC 7519. The package is available on Packagist, you can install it using Composer. A simple library to work with JSON Web Token and JSON Web Signature based on RFC 7519. Once the library has been installed, you are able to issue and parse JWTs. To reduce the chance of having flaky tests on your test suite, the facade supports the usage of a clock object. ...
    Downloads: 13 This Week
    Last Update:
    See Project
  • 15
    JsonCpp

    JsonCpp

    A C++ library for interacting with JSON

    JSON is a lightweight data-interchange format. It can represent numbers, strings, ordered sequences of values, and collections of name/value pairs. JsonCpp is a C++ library that allows manipulating JSON values, including serialization and deserialization to and from strings. It can also preserve existing comment in unserialization/serialization steps, making it a convenient format to store user input files.
    Downloads: 10 This Week
    Last Update:
    See Project
  • 16
    trdsql

    trdsql

    CLI tool that can execute SQL queries on CSV, LTSV, JSON and TBLN

    CLI tool that can execute SQL queries on CSV, LTSV, JSON and TBLN. Can output to various formats. CLI tool that can execute SQL queries on CSV, LTSV, JSON and TBLN. It is a tool like q, textql and others. The difference from these tools is that the syntax of PostgreSQL or MySQL can be used. Please refer to godoc and _example for usage as a library. Download binary from the releases page(Linux/Windows/macOS).
    Downloads: 18 This Week
    Last Update:
    See Project
  • 17
    Gson

    Gson

    A Java serialization/deserialization library to convert Java Objects

    Gson is a Java library developed by Google that allows conversion between Java objects and JSON. It enables serialization and deserialization of Java classes to and from JSON format, handling complex and generic types, nulls, custom naming policies, and more. Gson is lightweight, easy to use, and does not require annotation-based configuration, making it a popular choice for JSON processing in Java applications.
    Downloads: 35 This Week
    Last Update:
    See Project
  • 18
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 1 This Week
    Last Update:
    See Project
  • 19
    Render

    Render

    Go package for easily rendering JSON, XML, binary data, and HTML

    Render is a package that provides functionality for easily rendering JSON, XML, text, binary data, and HTML templates. Render can be used with pretty much any web framework provided you can access the HTTP.ResponseWriter from your handler. The rendering functions simply wraps Go's existing functionality for marshaling and rendering data. HTML: Uses the html/template package to render HTML templates. JSON: Uses the encoding/json package to marshal data into a JSON-encoded response. ...
    Downloads: 8 This Week
    Last Update:
    See Project
  • 20
    fastjson

    fastjson

    A fast JSON parser/generator for Java

    Fastjson is a Java library that can be used to quickly convert Java Objects into their JSON representation or convert JSON strings to their equivalent Java object. Based on benchmarks it provides the best performance in both server side and Android client, and can work with arbitrary Java objects, even those pre-existing objects of which you do not have the source code. Fastjson provides a simple conversion method to turn Java objects to JSON and vice versa, with extensive support of Java Generics and arbitrarily complex objects.
    Downloads: 10 This Week
    Last Update:
    See Project
  • 21
    Cheshire

    Cheshire

    Clojure JSON and JSON SMILE (binary json format) encoding/decoding

    Cheshire is a high-performance JSON encoding and decoding library for Clojure, built atop Jackson to combine fast parsing/generation with advanced support for types like Dates, UUIDs, Sets, Symbols, and the binary JSON SMILE format. Custom encoding is supported from 2.0.0 and up if you encounter a bug, please open a GitHub issue. From 5.0.0 onwards, custom encoding has been moved to be part of the core namespace (not requiring a namespace change).
    Downloads: 5 This Week
    Last Update:
    See Project
  • 22
    GJSON

    GJSON

    Get JSON values quickly, JSON parser for Go

    GJSON is a Go library designed for extremely fast, allocation-free retrieval of values from JSON documents. It enables you to query nested JSON structures using one-liner dot-notation or array-based paths and includes wildcard and comparison operators. The library is optimized for speed and zero allocations, benchmarking significantly faster than Go’s standard encoding/json unmarshal approaches. It supports parsing JSON lines (newline-delimited JSON) as an array for large stream processing. ...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 23
    jwx

    jwx

    Implementation of various JWx (Javascript Object Signing

    ...It really helps keeping up our motivation. Complete coverage of JWA/JWE/JWK/JWS/JWT, not just JWT+minimum tool set. Supports JWS messages with multiple signatures, both compact and JSON serialization. Supports JWS with detached payload. Supports JWS with unencoded payload (RFC7797). Supports JWE messages with multiple recipients, both compact and JSON serialization. Most operations work with either JWK or raw keys e.g. *rsa.PrivateKey, *ecdsa.PrivateKey, etc). Opinionated, but very uniform API. Everything is symmetric, and follows a standard convention. ...
    Downloads: 2 This Week
    Last Update:
    See Project
  • 24
    NSwag

    NSwag

    The Swagger/openAPI toolchain for .NET, ASP.NET Core and TypeScript

    ...This way a lot of incompatibilities can be avoided and features that are not well described by the OpenAPI specification or JSON Schema are better supported (e.g. inheritance, enum and reference handling). The NSwag project heavily uses NJsonSchema for .NET for JSON Schema handling and C#/TypeScript class/interface generation.
    Downloads: 19 This Week
    Last Update:
    See Project
  • 25
    JC

    JC

    CLI tool and python library

    ...In this case, the output will be a python dictionary, or a list of dictionaries, instead of JSON. Two representations of the data are available. The default representation uses a strict schema per parser and converts known numbers to int/float JSON values. Certain known values of None are converted to JSON null, known boolean values are converted, and, in some cases, additional semantic context fields are added.
    Downloads: 2 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • 3
  • 4
  • 5
  • Next