Showing 815 open source projects for "json"

View related business solutions
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • Host LLMs in Production With On-Demand GPUs Icon
    Host LLMs in Production With On-Demand GPUs

    NVIDIA L4 GPUs. 5-second cold starts. Scale to zero when idle.

    Deploy your model, get an endpoint, pay only for compute time. No GPU provisioning or infrastructure management required.
    Start Free
  • 1
    JSON-java

    JSON-java

    A reference implementation of a JSON package in Java

    JSON is a light-weight language-independent data interchange format. The JSON-Java package is a reference implementation that demonstrates how to parse JSON documents into Java objects and how to generate new JSON documents from the Java classes.
    Downloads: 27 This Week
    Last Update:
    See Project
  • 2
    JSON-Machine

    JSON-Machine

    Efficient, easy-to-use, and fast PHP JSON stream parser

    json-machine is an efficient and easy-to-use PHP JSON stream parser. It enables processing of large JSON files or streams without loading the entire content into memory, making it suitable for memory-constrained environments.​
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3
    Json.NET

    Json.NET

    A popular high-performance JSON framework for .NET

    Serialize and deserialize any .NET object with Json.NET's powerful JSON serializer. Create, parse, query and modify JSON using Json.NET's JObject, JArray and JValue objects. Query JSON with an XPath-like syntax. 50% faster than DataContractJsonSerializer, and 250% faster than JavaScriptSerializer. Json.NET makes the simple easy and the complex possible. If you need it, Json.NET supports converting between XML and JSON.
    Downloads: 12 This Week
    Last Update:
    See Project
  • 4
    json-graphql-server

    json-graphql-server

    Get a full fake GraphQL API with zero coding in less than 30 seconds

    Get a full fake GraphQL API with zero coding in less than 30 seconds. Start playing with GraphQL right away with json-graphql-server, a testing and mocking tool for GraphQL. All it takes is a JSON of your data. Your data file should export an object where the keys are the entity types. The values should be lists of entities, i.e. arrays of value objects with at least an id key. The json-graphql-server accepts queries in GET and POST. Under the hood, it uses the express-graphql module. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • Our Free Plans just got better! | Auth0 Icon
    Our Free Plans just got better! | Auth0

    With up to 25k MAUs and unlimited Okta connections, our Free Plan lets you focus on what you do best—building great apps.

    You asked, we delivered! Auth0 is excited to expand our Free and Paid plans to include more options so you can focus on building, deploying, and scaling applications without having to worry about your security. Auth0 now, thank yourself later.
    Try free now
  • 5
    Alternative JSON parser for Go

    Alternative JSON parser for Go

    One of the fastest alternative JSON parser for Go

    ...I investigated what's on the market and found that most libraries are just wrappers around encoding/json, there is few options with own parsers (ffjson, easyjson), but they still require you to create data structures. The goal of this project is to push JSON parser to the performance limits and not sacrifice with compliance and developer user experience.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    ArduinoJson

    ArduinoJson

    JSON library for Arduino and embedded C++. Simple and efficient

    ArduinoJson is a C++ JSON library for Arduino and IoT (Internet Of Things). ArduinoJson has a simple and intuitive syntax to handle objects and arrays. ArduinoJson supports both JSON serialization and deserialization. ArduinoJson uses a fixed memory allocation, allowing to work on devices with very little RAM. ArduinoJson can filter large inputs to keep only fields that are relevant to your application, thereby saving a lot of memory.
    Downloads: 25 This Week
    Last Update:
    See Project
  • 7
    JsonCpp

    JsonCpp

    A C++ library for interacting with JSON

    JSON is a lightweight data-interchange format. It can represent numbers, strings, ordered sequences of values, and collections of name/value pairs. JsonCpp is a C++ library that allows manipulating JSON values, including serialization and deserialization to and from strings. It can also preserve existing comment in unserialization/serialization steps, making it a convenient format to store user input files.
    Downloads: 12 This Week
    Last Update:
    See Project
  • 8
    NSwag

    NSwag

    The Swagger/openAPI toolchain for .NET, ASP.NET Core and TypeScript

    ...This way a lot of incompatibilities can be avoided and features that are not well described by the OpenAPI specification or JSON Schema are better supported (e.g. inheritance, enum and reference handling). The NSwag project heavily uses NJsonSchema for .NET for JSON Schema handling and C#/TypeScript class/interface generation.
    Downloads: 47 This Week
    Last Update:
    See Project
  • 9
    Gson

    Gson

    A Java serialization/deserialization library to convert Java Objects

    Gson is a Java library developed by Google that allows conversion between Java objects and JSON. It enables serialization and deserialization of Java classes to and from JSON format, handling complex and generic types, nulls, custom naming policies, and more. Gson is lightweight, easy to use, and does not require annotation-based configuration, making it a popular choice for JSON processing in Java applications.
    Downloads: 28 This Week
    Last Update:
    See Project
  • Build Securely on AWS with Proven Frameworks Icon
    Build Securely on AWS with Proven Frameworks

    Lay a foundation for success with Tested Reference Architectures developed by Fortinet’s experts. Learn more in this white paper.

    Moving to the cloud brings new challenges. How can you manage a larger attack surface while ensuring great network performance? Turn to Fortinet’s Tested Reference Architectures, blueprints for designing and securing cloud environments built by cybersecurity experts. Learn more and explore use cases in this white paper.
    Download Now
  • 10
    fx

    fx

    Command-line tool and terminal JSON viewer

    ...To be able require global modules make sure you have correct NODE_PATH env variable. If you need output other than JSON (for example arguments for xargs), do not return anything from the reducer. undefined value is printed into stderr by default. Sometimes it is necessary to omit some messages in JSON stream, or select only specified log messages. For this purpose, fx has special helpers select/filter, pass function into it to select/filter JSON messages.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 11
    JWT

    JWT

    A simple library to work with JSON Web Token and JSON Web Signature

    lcobucci/jwt is a framework-agnostic PHP library that allows you to issue, parse, and validate JSON Web Tokens based on the RFC 7519. The package is available on Packagist, you can install it using Composer. A simple library to work with JSON Web Token and JSON Web Signature based on RFC 7519. Once the library has been installed, you are able to issue and parse JWTs. To reduce the chance of having flaky tests on your test suite, the facade supports the usage of a clock object. ...
    Downloads: 4 This Week
    Last Update:
    See Project
  • 12
    jwx

    jwx

    Implementation of various JWx (Javascript Object Signing

    ...It really helps keeping up our motivation. Complete coverage of JWA/JWE/JWK/JWS/JWT, not just JWT+minimum tool set. Supports JWS messages with multiple signatures, both compact and JSON serialization. Supports JWS with detached payload. Supports JWS with unencoded payload (RFC7797). Supports JWE messages with multiple recipients, both compact and JSON serialization. Most operations work with either JWK or raw keys e.g. *rsa.PrivateKey, *ecdsa.PrivateKey, etc). Opinionated, but very uniform API. Everything is symmetric, and follows a standard convention. ...
    Downloads: 4 This Week
    Last Update:
    See Project
  • 13
    GJSON

    GJSON

    Get JSON values quickly, JSON parser for Go

    GJSON is a Go library designed for extremely fast, allocation-free retrieval of values from JSON documents. It enables you to query nested JSON structures using one-liner dot-notation or array-based paths and includes wildcard and comparison operators. The library is optimized for speed and zero allocations, benchmarking significantly faster than Go’s standard encoding/json unmarshal approaches. It supports parsing JSON lines (newline-delimited JSON) as an array for large stream processing. ...
    Downloads: 2 This Week
    Last Update:
    See Project
  • 14
    gRPC-Gateway

    gRPC-Gateway

    gRPC to JSON proxy generator following the gRPC HTTP spec

    ...However, you might still want to provide a traditional RESTful JSON API as well. Reasons can range from maintaining backward compatibility, supporting languages or clients that are not well supported by gRPC, to simply maintaining the aesthetics and tooling involved with a RESTful JSON architecture. This project aims to provide that HTTP+JSON interface to your gRPC service.
    Downloads: 20 This Week
    Last Update:
    See Project
  • 15
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    Render

    Render

    Go package for easily rendering JSON, XML, binary data, and HTML

    Render is a package that provides functionality for easily rendering JSON, XML, text, binary data, and HTML templates. Render can be used with pretty much any web framework provided you can access the HTTP.ResponseWriter from your handler. The rendering functions simply wraps Go's existing functionality for marshaling and rendering data. HTML: Uses the html/template package to render HTML templates. JSON: Uses the encoding/json package to marshal data into a JSON-encoded response. ...
    Downloads: 3 This Week
    Last Update:
    See Project
  • 17
    JC

    JC

    CLI tool and python library

    ...In this case, the output will be a python dictionary, or a list of dictionaries, instead of JSON. Two representations of the data are available. The default representation uses a strict schema per parser and converts known numbers to int/float JSON values. Certain known values of None are converted to JSON null, known boolean values are converted, and, in some cases, additional semantic context fields are added.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 18
    decimal

    decimal

    Arbitrary-precision fixed-point decimal numbers in go

    ...The zero-value is 0, and is safe to use without initialization. Addition, subtraction, and multiplication with no loss of precision. Division with specified precision. Database/sql serialization/deserialization. JSON and XML serialization/deserialization. big.Int's API is built to reduce the number of memory allocations for maximal performance. This makes sense for its use-case, but the trade-off is that the API is awkward and easy to misuse. In contrast, it's difficult to make such mistakes with decimal. Decimals behave like other go numbers types: even though a = b will not deep copy b into a, it is impossible to modify a Decimal, since all Decimal methods return new Decimals and do not modify the originals. ...
    Downloads: 3 This Week
    Last Update:
    See Project
  • 19
    null

    null

    Reasonable handling of nullable values

    null is a library with reasonable options for dealing with nullable SQL and JSON values. There are two packages: null and its subpackage zero. Types in null will only be considered null on null input, and will JSON encode to null. If you need zero and null be considered separate values, use these. Types in zero are treated like zero values in Go: blank string input will produce a null zero.String, and null Strings will JSON encode to "".
    Downloads: 3 This Week
    Last Update:
    See Project
  • 20
    Centrifuge

    Centrifuge

    Real-time messaging library for Go with scalability in mind

    This library has no v1 release, API may change. Before v1 release patch version updates only have backward-compatible changes and fixes, minor version updates can have backward-incompatible API changes. Master branch can have unreleased code. Only two last Go minor versions are officially supported by this library. Centrifuge library is a real-time core of Centrifugo server. It's a general-purpose real-time messaging library for Go programming language. Real-time messaging can help create...
    Downloads: 10 This Week
    Last Update:
    See Project
  • 21
    V2rayU

    V2rayU

    A tool to manage v2ray config json

    V2ray multi-user management script, wizard-style management [new|delete|modify] transmission protocol, enjoy the fun of V2ray. Quickly view server connection information, general configuration modification. Freely change the transmission configuration. Upgrade command (keep the configuration file, if the upgrade fails, please install it completely). Call v2ray official api for traffic statistics. Multi-user, multi-port management , mixed transmission protocol management is no longer a dream....
    Downloads: 25 This Week
    Last Update:
    See Project
  • 22
    vcr

    vcr

    Record your test suite's HTTP interactions and replay them

    ...You can use a different cassette library directory (e.g., "test/vcr_cassettes"). The recorded requests and responses are stored on disk in a serialization format of your choice (currently YAML and JSON are built in, and you can easily implement your own custom serializer) and can easily be inspected and edited.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 23
    fastjson

    fastjson

    A fast JSON parser/generator for Java

    Fastjson is a Java library that can be used to quickly convert Java Objects into their JSON representation or convert JSON strings to their equivalent Java object. Based on benchmarks it provides the best performance in both server side and Android client, and can work with arbitrary Java objects, even those pre-existing objects of which you do not have the source code. Fastjson provides a simple conversion method to turn Java objects to JSON and vice versa, with extensive support of Java Generics and arbitrarily complex objects.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 24
    Aeson

    Aeson

    A fast Haskell JSON library

    ...Fast JSON parsing and serialization.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    RestSharp

    RestSharp

    Simple REST and HTTP API Client for .NET

    ...However, RestSharp can call any API over HTTP (but not HTTP/2), as long as you have the resource URI and request parameters that you want to send comply with W3C HTTP standards. RestSharp can take care of serializing the request body to JSON or XML and deserialize the response. It can also form a valid request URI based on different parameter kinds.
    Downloads: 1 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • 3
  • 4
  • 5
  • Next