Showing 29972 open source projects for "linux scanner software"

View related business solutions
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • Save Up to 91% on Cloud Compute With Spot VMs Icon
    Save Up to 91% on Cloud Compute With Spot VMs

    Automatic sustained-use discounts. One free VM per month. No negotiation needed.

    Run batch jobs at 60-91% off with Spot VMs. Long-running workloads get automatic discounts with sustained use.
    Start Free
  • 1
    devenv

    devenv

    Fast, declarative, reproducible, and composable developer environments

    Fast, declarative, reproducible, and composable developer environments using Nix. Declaratively define your development environment by toggling basic options.
    Downloads: 10 This Week
    Last Update:
    See Project
  • 2
    Sol

    Sol

    MacOS launcher & command palette

    Sol is an open source app launcher, focused on ease of use and speed. It has minimal configuration and runs natively.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 3
    PowerGlitch

    PowerGlitch

    Tiny JS library to glitch anything on the web

    PowerGlitch is a standalone library with no external dependencies. It leverages CSS animations to glitch anything on the web, without using a canvas. It weights less than 2kb minified and gzipped.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 4
    Rapidcsv

    Rapidcsv

    C++ CSV parser library

    Rapidcsv is an easy-to-use C++ CSV parser library. It supports C++11 (and later), is header-only and comes with a basic test suite.
    Downloads: 8 This Week
    Last Update:
    See Project
  • Veeam Data Platform v13.1 Icon
    Veeam Data Platform v13.1

    Move workloads across hypervisors and clouds with no vendor lock-in. Try VDP free today.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try Now
  • 5
    OpenID Connect SDK for Go

    OpenID Connect SDK for Go

    Easy to use OpenID Connect client and server library written for Go

    This project is an easy-to-use client (RP) and server (OP) implementation for the OIDC (OpenID Connect) standard written for Go. The RP is certified for the basic and config profile.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 6
    libssh2

    libssh2

    the SSH library

    libssh2 is a client-side C library implementing the SSH2 protocol. The libssh2 offers a large amount of functions and this is an attempt to provide HTML versions of the man pages present in the source tree. These pages are updated automatically from the source code repository.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 7
    Kamel

    Kamel

    Kotlin asynchronous media loading and caching library for Compose

    Kamel is an asynchronous media loading library for Compose Multiplatform. It provides a simple, customizable, and efficient way to load, cache, decode, and display images in your application. By default, it uses the Ktor client for loading resources.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 8
    koa2-swagger-ui

    koa2-swagger-ui

    Swagger UI as Koa v2 middleware

    Host swagger ui at a given directory from your koa v2 app.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 9
    nbdime

    nbdime

    Tools for diffing and merging of Jupyter notebooks

    nbdime provides tools for diffing and merging Jupyter notebooks. Jupyter notebooks are useful, rich media documents stored in a plain text JSON format. This format is relatively easy to parse. However, primitive line-based diff and merge tools do not handle well the logical structure of notebook documents. nbdime, on the other hand, provides “content-aware” diffing and merging of Jupyter notebooks. It understands the structure of notebook documents. Therefore, it can make intelligent...
    Downloads: 25 This Week
    Last Update:
    See Project
  • $300 Free Credits to Build on Google Cloud Icon
    $300 Free Credits to Build on Google Cloud

    New customers can spin up VMs, build with AI, and query data at no cost.

    Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
    Start Free
  • 10
    SGDK 1.90

    SGDK 1.90

    A free and open development kit for the Sega Mega Drive

    SGDK is a free development kit allowing the development of software in C language for the Sega Mega Drive. It contains the development library itself (with the code sources) and some custom tools used to compile resources. SGDK uses the GCC compiler (m68k-elf target) and the libgcc to generate a ROM image. Binaries (GCC 6.3) are provided for Windows OS for convenience, but you need to install it by yourself for other operating systems. Note that SGDK also requires Java (custom tools require...
    Downloads: 16 This Week
    Last Update:
    See Project
  • 11
    International Components for Unicode

    International Components for Unicode

    The home of the ICU project source code

    ICU is a mature, widely used set of C/C++ and Java libraries providing Unicode and Globalization support for software applications. ICU is widely portable and gives applications the same results on all platforms and between C/C++ and Java software. ICU is released under a nonrestrictive open-source license that is suitable for use with both commercial software and with other open-source or free software. Convert text data to or from Unicode and nearly any other character set or encoding....
    Downloads: 11 This Week
    Last Update:
    See Project
  • 12
    Stash

    Stash

    An organizer for your videos, written in Go

    Stash allows you to organize and view your own collection of adult video and image files. Think of it like a private Hub site for your personal porn collection. Every video file has its own scene. Scenes can be rated and tagged with performers, tags, movies and a studio. Bookmark your favorite parts of a scene with markers. Markers can be tagged and appear in the video scrubber when viewing a scene. Images can be rated and tagged with performers, tags and a studio. Galleries are collections...
    Downloads: 21 This Week
    Last Update:
    See Project
  • 13
    opam

    opam

    opam is a source-based package manager

    Opam is a source-based package manager for OCaml. It supports multiple simultaneous compiler installations, flexible package constraints, and a Git-friendly development workflow. Opam was created and is maintained by OCamlPro. To get started, checkout the Install and Usage guides. Run ./configure. If you don't have the dependencies installed, this will locally take care of all OCaml dependencies for you (downloading them, unless you used the inclusive archive we provide for each release)....
    Downloads: 16 This Week
    Last Update:
    See Project
  • 14
    Just the Docs

    Just the Docs

    A modern, high customizable, responsive Jekyll theme for documention

    Just the Docs gives your documentation a jumpstart with a responsive Jekyll theme that is easily customizable and hosted on GitHub Pages. Just the Docs is built for Jekyll, a static site generator. View the Jekyll quick start guide for more information. Just the Docs requires no special plugins and can run on GitHub Pages’ standard Jekyll compiler. The Jekyll SEO Tag plugin is included by default (no need to run any special installation) to inject SEO and open graph metadata on docs pages....
    Downloads: 25 This Week
    Last Update:
    See Project
  • 15
    Ghost

    Ghost

    The world’s most popular open source headless Node.js CMS

    Ghost is a popular open source headless Node.js CMS for professional online publishing. Ghost allows writers, podcasters and other online content creators to quickly and easily set up their own sites, publish content on their own terms and deliver newsletters online. Ghost is a powerful platform that gives you complete control over design, content, delivery, experience and more. It’s got built-in SEO features, email newsletters, and works with hundreds of tools that can help speed up...
    Downloads: 16 This Week
    Last Update:
    See Project
  • 16
    Fetch JSONP

    Fetch JSONP

    Make JSONP request like window.fetch

    Fetch JSONP is a small JavaScript library that provides a Fetch-like API for JSONP requests. Standard Fetch does not support JSONP, so this package fills that specific compatibility gap. Developers can call fetchJsonp, receive a promise, and parse the response with a familiar .json() flow. The library supports custom callback parameter names, custom callback function names, and request timeouts. It also documents the difference between regular JSON APIs and JSONP endpoints, which helps avoid...
    Downloads: 15 This Week
    Last Update:
    See Project
  • 17
    busted

    busted

    Elegant Lua unit testing

    busted is a unit testing framework with a focus on being easy to use. Supports Lua >= 5.1, luajit >= 2.0.0, and moonscript. busted test specs read naturally without being too verbose. You can even chain asserts and negations, such as assert.is_not.equal. Nest blocks of tests with contextual descriptions using describe, and add tags to blocks so you can run arbitrary groups of tests. An extensible assert library allows you to extend and craft your own assert functions specific to your case...
    Downloads: 7 This Week
    Last Update:
    See Project
  • 18
    Gradle Advanced Build Version Plugin

    Gradle Advanced Build Version Plugin

    A plugin to generate the Android version code and version name

    A plugin to generate the Android version code and version name automatically based on git commits number, date and Semantic Versioning.
    Downloads: 6 This Week
    Last Update:
    See Project
  • 19
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 15 This Week
    Last Update:
    See Project
  • 20
    PhpSpreadsheet

    PhpSpreadsheet

    A pure PHP library for reading and writing spreadsheet files

    PhpSpreadsheet is a library written in pure PHP and offers a set of classes that allow you to read and write various spreadsheet file formats such as Excel and LibreOffice Calc. PhpSpreadsheet is a library written in pure PHP and offers a set of classes that allow you to read and write various spreadsheet file formats such as Excel and LibreOffice Calc. Support for PHP versions will only be maintained for a period of six months beyond the end of life of that PHP version. Use composer to...
    Downloads: 29 This Week
    Last Update:
    See Project
  • 21
    Mimesis

    Mimesis

    High-performance fake data generator for Python

    Mimesis is an open source high-performance fake data generator for Python, able to provide data for various purposes in various languages. It's currently the fastest fake data generator for Python, and supports many different data providers that can produce data related to people, food, transportation, internet and many more. Mimesis is really easy to use, with everything you need just an import away. Simply import an object, called a Provider, which represents the type of data you...
    Downloads: 6 This Week
    Last Update:
    See Project
  • 22
    Neosync

    Neosync

    Open Source Data Security Platform for Developers to Monitor

    Neosync is a secure, open-source platform to generate, mask, and sync realistic test data across environments. It helps engineering teams create privacy-compliant datasets using synthetic data, transformations, and pseudonymization techniques. Designed with extensibility and data governance in mind, Neosync integrates with common databases and cloud services, enabling safe test environments for development and QA.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 23
    NPM Publish

    NPM Publish

    GitHub Action to publish to NPM

    npm-publish is a Node.js utility that simplifies the process of publishing npm packages by automating checks, versioning, and distribution. It helps maintainers streamline their release workflow.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 24
    serverless-express

    serverless-express

    Run Express and other Node.js frameworks on AWS Serverless

    Serverless Express is a framework for deploying Express.js applications on AWS Lambda and other serverless environments, enabling efficient, scalable web applications without managing infrastructure.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 25
    Angular Full Stack

    Angular Full Stack

    Angular Full Stack project built using Angular, Express, Mongoose

    Angular Full Stack is a project to easily get started with the latest Angular using a real backend and database. The whole stack is in TypeScript, from frontend to backend, giving you the advantage of coding in one single language throughout the stack.
    Downloads: 9 This Week
    Last Update:
    See Project