Showing 4865 open source projects for "java project with source code"

View related business solutions
  • Ship Agents Faster Icon
    Ship Agents Faster

    Transform your applications and workflows into powerful agentic systems at global scale.

    Gemini Enterprise Agent Platform lets you rapidly build, scale, govern and optimize production-ready agents grounded in your organization's data. The platform enables developers to build custom or pre-built agents for virtually any use case. New customers get $300 in free credits.
    Start Free
  • Demo Series - Small Business Backup By Veeam Icon
    Demo Series - Small Business Backup By Veeam

    Learn how to protect your Microsoft 365 data, with simple, actionable tips today.

    Watch this on-demand demo series and learn how to protect your Microsoft 365 data with clear, simple, actionable steps that are easy to implement for businesses of all sizes.
    Watch Demo Series
  • 1
    PHP Class Generator Eclipse plug-in

    PHP Class Generator Eclipse plug-in

    Eclipse Plugin to generated PHP classes from existing database schema

    PHP Class Generator Eclipse plug-in creates multiple PHP classes based on an XML template and a MySQL database table. Each generated class represents an access object for one database table, offering getters and setters for each database table field.
    Leader badge
    Downloads: 0 This Week
    Last Update:
    See Project
  • 2
    A request tracking system that can be used though email and allows linking of tickets to exteranl applications such as XPlanner stories.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3
    Implementation of an open source FTP Server which comply with RFC 959, RFC 2228, RFC 2389 and RFC 2428. Implemented in Java. This server can be run as a stand alone FTP server and can be easily embedded in any java project. Please visit our project h
    Downloads: 4 This Week
    Last Update:
    See Project
  • 4
    Make Targeter for Eclipse/CDT

    Make Targeter for Eclipse/CDT

    Compose build options with the declarative UI

    The project moved to GitHub. SF version is no longer updated. See https://github.com/mikhail-barg/maketargeter for the latest versions. --- Make Targeter aims to help creating and building C/C++ make targets for projects where lots of build options are available in makefile.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Train ML Models With SQL You Already Know Icon
    Train ML Models With SQL You Already Know

    BigQuery automates data prep, analysis, and predictions with built-in AI assistance.

    Build and deploy ML models using familiar SQL. Automate data prep with built-in Gemini. Query 1 TB and store 10 GB free monthly.
    Start Free
  • 5
    Task for ANT to produce documentation with (PDF)LaTeX using BibTeX, Makeindex and GlossTeX.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6

    XJML

    XJML 1.0 is a platform for Verification and Validation of Java classes

    XJML 1.0 actually can reads one Java class and its contract (written in XML) and then executes the next verification techniques: 1. Runtime Assertion Checking (RAC). Using JML4c and JML4rt tools. 2. Extended Static Checking (ESC). Using ESC/Java2. 3. Full Static Program Verification (FSPV). Using the Why platform (tested with Why 2.30 and Why3 0.71)
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    This project attemps to integrate the Eclipse CDT C/C++ IDE and the Splint static checker.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    Zebra is a java workflow engine - originally developed to fill in the gaps in some commercial and open source workflow engines. The project also contains a sample application based on Zebra and Apache Turbine
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    The DPML is an open-source project contributing to the development of advanced Java-based component management solutions. DPML products include the Transit resource management system, the Depot build system, the Metro IOC container, and Station console.
    Downloads: 0 This Week
    Last Update:
    See Project
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 10
    NOTE: This project has moved out of berliOS. See http://antdoclet.neuroning.com - AntDoclet is a tool to automatically generate documentation for your custom Ant Tasks.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    A Swing-1.1-Component for displaying a JList-Datamodel in more than one coloumn. The preferred project-language is german.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    Equals Checker
    A static checker that model checks the implementation of equality for an Eclipse Java Project.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13

    swingframework

    MVC Framework for Writing Swing Client.

    Writing modular Swing code is hard and this simple framework helps with implementing MVC in Swing.,
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    Pour vous développeur, j'ai créer CodeLibrary. Le logiciel qui vous permet de gérer vos sources, astuces, fonctions. Le but du programme et d'archiver son code d'une manière ordrée (language, catégorie). Multi-OS, CodeLibrary est le compagnon idéal
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    OPALE is an Open Source project which development is done at two different levels: the OPALE library: which is a scientific library written in Java and which is composed of different modules (tools, swools, mathtools,...). Its purpose is to give
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    cpp2xml

    cpp2xml

    A tool to convert C++ definitions into XML

    cpp2xml is a tool to convert C/C++ definitions into XML. The main goal is to use the XML as input to code generation tools, but any other usage may be imagined.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    J2ME Polish is a next generation framework for the rapid development of J2ME applications. Features included are a powerful GUI framework, utility classes and ant-based build tools for the creation of device optimised applications.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 18
    StatCvs-XML provides statistics about cvs usage based on the cvs log. It extends the StatCvs project with fancy 3D charts, advanced report generation and customization features. It also features a plugin for seamless integration with Apache Maven.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    Dojo Faces is a set of JavaServerFaces components based on the widgets of the Dojo Javascript toolkit. It offers dynamic, AJAX ready user interface components for JSF based web applications.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    Logic Custom OS

    Logic Custom OS

    A students experimental command driven OS

    ...Logic Custom OS will have many features all listed in the wiki. The project is Java based and will support most versions of Java the JRE and JDK. And most importantly its open source anyone can edit this software and use it for themselves!
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    UniversalIndentGUI
    A cross platform GUI for several code formatter, beautifier and indenter like AStyle, GNU Indent, GreatCode, HTML Tidy, Uncrustify and many more. Main feature is a live preview to directly see how the selected formatting option affects the source code.
    Downloads: 13 This Week
    Last Update:
    See Project
  • 22

    Swallow Project

    Libraries, utilities, and applications designed to simplify java

    Swallow project is a collection of libraries, utilities, and applications designed to simplify the java based developments.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    Developer tools for EXPRESS (ISO 10303-11), an information modeling language. The core of this project is a Java Express parser using the ANTLR parser generator. This project was initiated by the National Institute of Standards and Technology.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    A fully automated database benchmark suite that prints tabular and graphic results for multiple tested disciplines, given JDBC database connections. Some free open source database engines are included.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    Java Assertions to Code (JAC) is the tool which is used to generate the code from contracts of the method in Java. COFOJA is used to write contracts and JDT is used to create abstract syntax tree for parsing and manipulation of Java file.
    Downloads: 0 This Week
    Last Update:
    See Project