New customers can spin up VMs, build with AI, and query data at no cost.
Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
Start Free
Build Agents and Models on One Platform
Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.
Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
This is a simple Java application that will run on Unix/Linux operating systems as a daemon using the Apache Commons Daemon. The purpose of this application is to serve as a template/example of how to set up a Java application as a daemon on Unix/linux systems and as an example of how to use jsvc.
The java_daemon_init script can be copied to /etc/init.d/ (and renamed to an appropriate name) and then used in the normal {start|stop} manner.
Dojo Faces is a set of JavaServerFaces components based on the widgets of the Dojo Javascript toolkit. It offers dynamic, AJAX ready user interface components for JSF based web applications.
Implementation of an open source FTP Server which comply with RFC 959, RFC 2228, RFC 2389 and RFC 2428. Implemented in Java. This server can be run as a stand alone FTP server and can be easily embedded in any java project. Please visit our project h
This is a series of *.java Classes for making programming tasks simpler, much like Apache Commons. Included in this src package is an Advanced Randomizer, TStringList Clone From Delphi, an Algorithem Class, and Method MultiTask Better than Runnables.
Lay a foundation for success with Tested Reference Architectures developed by Fortinet’s experts. Learn more in this white paper.
Moving to the cloud brings new challenges. How can you manage a larger attack surface while ensuring great network performance? Turn to Fortinet’s Tested Reference Architectures, blueprints for designing and securing cloud environments built by cybersecurity experts. Learn more and explore use cases in this white paper.
Makes using log frameworks as painless as printing to stdout by adding intentions, live templates and code inspections that support most aspects of the configured log framework. On top of this log IDs and reviews can be generated in addition.
Basic Electronical Medical Management (BEMM) is an application to control medical data of a set of patients. It is built on top of open source technologies, to provide an integration skeleton of mvn, Datanucleus, Spring, Vaadin, Acceleo technologies.
Pwing is a GUI toolkit, Is a set of widgets/components for use in designing applications with graphical user interfaces (GUI’s). It is developed to provide a better set of components to create more interactive GUI based applications in Java.
Put idle assets to work with competitive interest rates, borrow without selling, and trade with precision. All in one platform.
Geographic restrictions, eligibility, and terms apply.
Compiled template language to write text output program in Java. Compilation of templates is bi-directional: template to Java and Java to template. The compiler is integrated into Eclipse and also can be accessed as an Ant task.
The Checker framework is an easily expansible set of check/transformation to build hierarchy of chain operations easily to-store/to-be created and re utilized (at run time if you want).
This project contains a way to test a JSF managed bean in the context of a spring integration test, resolving the session scopes problem and emulating a faces context
The project is focused on building logical websites , where the users can come to the admin screens and design the website layout and drop the components.
This is a template application that implements a "conversational" extended persistence context: with Spring and Maven: - Annotation-driven Hibernate mappings - Configuration of the AOP-based service layer - A unit- and integration-test framework
Because of the convergence of automation and information techniques in Networks evolve new possibilities to controll and visualize these mixed control systems with with software without the need for special wires
To implement the State Machine model of behavior with chain of command design pattern. Commands and created out of Actions of a State Model {ENTRY, INPUT, TRANSACTION, EXIT} and can be exectued independently or bundled together to form a chain.
Tools and libraries for IBM Tivoli Maximo customization developers. The main artifact is an Apache Maven plug-in that generating Maximo custom classes for MBOs, FLDs, Beans, Crontasks, etc.
GWT 1.7 with JBoss/Hibernate JPA persistence using Maven. It requires jboss and gwt plugins for eclipse to edit/debug, but can be compiled without an IDE using only maven2. A sample, working, template application with UI and persistence.