Showing 64 open source projects for "role based access control"

View related business solutions
  • Veeam Data Platform v13.1 - Get Your Free Trial Icon
    Veeam Data Platform v13.1 - Get Your Free Trial

    Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try it Free
  • Train ML Models With SQL You Already Know Icon
    Train ML Models With SQL You Already Know

    BigQuery automates data prep, analysis, and predictions with built-in AI assistance.

    Build and deploy ML models using familiar SQL. Automate data prep with built-in Gemini. Query 1 TB and store 10 GB free monthly.
    Start Free
  • 1
    Codename One

    Codename One

    Cross-platform app development framework for Java & Kotlin developers.

    Build native mobile applications using Java or Kotlin with our open source tools. Codename One seamlessly integrates with IntelliJ/IDEA, Eclipse & NetBeans to make native write once run anywhere a reality on iOS (iPhone/iPad), Android, Windows (UWP), Desktops and more.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 2
    StrongKey CryptoEngine

    StrongKey CryptoEngine

    FIDO strong authentication, encryption, digital signature engine

    StrongKey CryptoEngine (SKCE) 2.0 is a "crypto Swiss Army knife" server to perform cryptographic functions through web services, while freeing application developers to focus on business functionality. Its modules include: - A FIDO Engine to support FIDO U2F key registrations/authentications - An encryption engine to encrypt/decrypt files using AES/TDES keys - Escrowing keys to on-premises key management system (StrongAuth KeyAppliance/SAKA) - Integration to cloud storage services...
    Downloads: 3 This Week
    Last Update:
    See Project
  • 3
    JPA Security is an Access Control Solution for the Java Persistence API. JPA Security enables you to configure access control to your JPA Entity Beans based on the currently authenticated user and its roles via XML or Annotations.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 4
    SoyBeans

    SoyBeans

    A Task Processing Framework for Java

    Soy Beans is an HTTP request processing framework written in Java. Written as an alternative to frameworks like Struts and Stripes, it provides a robust and extremely flexible API enabling rapid deployment, and dynamic configuration.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 5
    JFig

    JFig

    JFig is a simple, powerful tool to manage application configuration

    JFig provides developers with a simple yet powerful tool to manage their applications’ configuration. Using a combination of hierarchical xml files and substitution variables, it enables developers to: 1. Store application configuration in one common repository of XML files 2. Access configuration data using one common, convenient interface 3. Easily define multiple configurations tailored to different environments, with the ability to dynamically modify those variables that need to...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    MOBIDICK
    MOBIDICK (MOdular But IntegrateD applICation frameworK) is dedicated to gather as less as possible Java frameworks in order to complete full needs of large business application and allow regeneration of code, even when java frameworks change.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    FaceAccess Facial Recognition System

    FaceAccess Facial Recognition System

    FaceAccess is an Access Control System based on Facial Recognition

    With the growing need to exchange information and share resources, information security has become more important than ever in both the public and private sectors. Although many technologies have been developed to control access to files or resources, to enforce security policies, and to audit network usages, there does not exist a technology that can verify that the user who is using the system is the same person who logged in. FaceAccess provides a prototype implementation as a "login...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8

    FieldCatalog

    Documentation System

    This is a centralize system to 1. Define Software Products 2. Define Software Products Version 3. Define Screens 4. Define Rules 5. Build Relationships between Products, Versions, Screens and Fields Beside core features, the system will provide more functions for end-user(s) such as 1. Search 2. Tag 3. Control by Role 4. Control by Group 5. Comparison with Version or Versioning
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9

    Java MythTV API

    An API allowing java applications to connect to MythTV as a client.

    jMythAPI is a java library to query and control a MythTV backend and MythTV database. JMythAPI uses the Myth protocol to communicate with the MythTV backend and the MySQL JDBC driver to query the MythTV database. It provides a high level API enabling java developers to easily access MythTV, without the need to know all the details about the underlying protocol and differences between various protocol versions.
    Downloads: 1 This Week
    Last Update:
    See Project
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • 10
    NextBase

    NextBase

    NextBase – the enterprise level applications development platform.

    NEXTBASE FRAMEWORK Group of enthusiasts are having experience programming various enterprise systems highlighted some conceptual moments that helped with the design of this platform. These moments are the following: The platform supports, along with standard primitive types of data such as text, number, etc., some types that represent objects with certain fields and behavior model. These objects represent complete business modules which carry out a row...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    Access Road

    Access Road

    Simulator of access controls

    The Access Road software is a universal simulator of access controls that is intended to improve design and auditing of IT security. Access Road offers the out-of-the-box simulations of GNU/Linux Ubuntu® (components and rights on the file system), MySQL Server®, and a generic Role-Based-Access-Control application to adapt to your needs.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    2step is a development framework written in Java for developing complete web applications (including web services). As a servlet framework features access control, logging, I18N, database access, deploy, XML/XSL, etc, and uses Jetty, FOP and jCharts.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    remoteME

    remoteME

    Remote computer access through Android devices

    remoteME is a good-looking, extremely configurable and open source Android remote controller for your computers no matter what operation system you are using (Linux, MAC OS, or MS Windows). It offers you at least 11 remotes for the most frequent media players plus those which you create by yourself. Remotes for mouse, keyboard, presentation and power control are also included. Before using client application, please be sure you have a remoteME server running on your...
    Downloads: 3 This Week
    Last Update:
    See Project
  • 14
    Ralasafe Access Control Middleware focus on data-level privilege management, including database row/column and content privilege management. It also manages 2) login control; 3) function-level privilege management; and 4) URL privilege authentication
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15

    RELATED - REmotes LAboraTories extenED

    Java Framework for developing of remote/virtual laboratories

    RELATED framework proposes a structured methodology of remote/virtual labs development and, also, provides common facilities as user management, booking, basic visualization (trend graphs and direct interaction using interactives variables), data logging and experimental session’s control. In order to get these facilities, an RLAB (Remote LABoratory) system it defined using a formal specification of a virtual or remote laboratory (based on XML and used to structure components for laboratory). The main component is experiment, so students could run these experiments using RELATED facilities as painting data from the laboratory, change any relevant variable or take a look on laboratory structure. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    Implementation of an open source FTP Server which comply with RFC 959, RFC 2228, RFC 2389 and RFC 2428. Implemented in Java. This server can be run as a stand alone FTP server and can be easily embedded in any java project. Please visit our project h
    Downloads: 4 This Week
    Last Update:
    See Project
  • 17

    Document Management System

    This project is for managing documents in an organisation effectively

    As business grows, Capturing, Storing and Sharing corporate knowledge is vital to the success of business. Electronic Document Management System (EDMS) is the best solution for managing information more efficiently, accurately, and cost-effectively. EDMS improves organizational effectiveness by providing companies with greater ability to manage their unstructured information. It also enhances an organization’s ability to leverage information stores by allowing enterprise wide access for...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    Rasea
    An acronym for cRoss-plAtform accesS control for Enterprise Applications. Rasea aims to become a reference in access control as a service based on the RBAC model.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    Given an XSD schema and an XSA.xml configuration file, XML Skeleton Annotations (XSA) generates JSF forms UI to create XML records compliant to the XSD and following the XML skeleton defined in XSA.xml, still keeping everything under your control.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    Jefe SDWMS
    Jefe is a Workflow Management Solution in a form of a web portal that unifies the enterprise information and applications in the domain of Software Development. It integrates CASE tools which are highly use in the industry of software engineering.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    J2EE framework with 0-configuration.debug/unit test without J2EE server,using Velocity/Freemarker as view,directly JDBC with Apache DBUtils,reusable SQL pagination, SQL transaction based on TRANSACTION_PER_REQUEST,And URL based user access control(UAC).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    Target of the project is to simplify access right management of a Subversion server running with webdav on apache2. Users and groups can be imported out of an LDAP directory or added manually.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    A Standalone and Flexible Framework which allows java developers to access CVS with minimal understanding of its implementation details. JRepository is a command pattern based framework where each command wraps a cvs command. Most common commands are imp
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    Information system to manage execution of manual test scripts. Includes comprehensive issue tracking linked to scripts. Web-based UI, JBoss app server. Standard role-based user access. Test cases written in Excel and loaded up to application using a tool
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    NoteCat is a web-based application to manage and categorize Wiki notes with user registration and access control. NoteCat demonstrates integration with Hibernate (object-relational persistence) , Lucene (full text search), Radeox (wiki engine), etc.
    Downloads: 0 This Week
    Last Update:
    See Project