Showing 16 open source projects for "arithmetics"

View related business solutions
  • $300 Free Credits to Build on Google Cloud Icon
    $300 Free Credits to Build on Google Cloud

    New customers can spin up VMs, build with AI, and query data at no cost.

    Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
    Start Free
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 1

    half

    C++ library for half precision floating point arithmetics.

    This is a C++ header-only library to provide an IEEE-754 conformant half-precision floating point type along with corresponding arithmetic operators, type conversions and common mathematical functions. It aims for both efficiency and ease of use, trying to accurately mimic the behaviour of the builtin floating point types at the best performance possible. It automatically uses and provides C++11 features when possible, but stays completely C++98-compatible when neccessary.
    Leader badge
    Downloads: 3,680 This Week
    Last Update:
    See Project
  • 2
    Agena

    Agena

    Agena is an interpreted procedural programming language.

    Agena is an easy-to-learn procedural programming language designed for science, scripting, and many other applications. Binaries are available for Windows, Linux, Solaris, OS/2, Mac OS X, Raspberry Pi and DOS.
    Leader badge
    Downloads: 146 This Week
    Last Update:
    See Project
  • 3
    jsondata

    jsondata

    Modular JSON by trees and branches, pointers and patches

    ... - JSONDataSerializer - Core for RFC7159 based data persistence. Provides modular data serialization. - JSONPointer - RFC6901 for addressing by pointer paths. Provides pointer arithmetics. - JSON Relative Pointer - draft-handrews-relative-json-pointer/2018, contained in JSONPointer. - JSONPatch - RFC6902 for modification by patch lists. Provides the assembly of modular patch entries and the serialization of resulting patch lists. - JSONDiff - Diff utility for JSON data. - JSONSearch - Search utility JSON patterns. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4
    fzcal

    fzcal

    A calculator capable of complex arithmetics

    A command line calculator capable of complex arithmetics.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Veeam Data Platform v13.1 Icon
    Veeam Data Platform v13.1

    Move workloads across hypervisors and clouds with no vendor lock-in. Try VDP free today.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try Now
  • 5
    CVM C++ Class Library encapsulates concepts of vector and square, band, symmetric and hermitian matrices in Euclidean space of real and complex numbers. It utilizes BLAS and LAPACK Fortran libraries. See http://cvmlib.com for binaries and more details.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    A formal specification language and tools based on high-school mathematics - sets theory, functions, arithmetics and Boolean algebra.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    Translation of RPG/400- (as well as RPG-II/III)- programs to native C++. Runtime-Environment for RPG/400-programs Class-library for RPG/400 programs and datatypes, including high-precision arithmetics
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    Specter - Abstract Arithmetics Library (AAL) is a library coded in native C which is able to do operations with numbers of virtually unlimited length. Specter is targeting mainly cryptography and big integer maths though.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    FPM - Fixed Point Math substitutes expensive floating point operations by much cheaper integer arithmetics. Use this library in your plain C (gcc) projects if you like.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Host LLMs in Production With On-Demand GPUs Icon
    Host LLMs in Production With On-Demand GPUs

    NVIDIA L4 GPUs. 5-second cold starts. Scale to zero when idle.

    Deploy your model, get an endpoint, pay only for compute time. No GPU provisioning or infrastructure management required.
    Start Free
  • 10
    Low-latency high speed hybrid framework-library for utilizing the IBM Cell processor SPE units (PS3, QS20) to carry out computational tasks. Provides some DSP tasks such as FFT and complex MAC. Thread-safe and easily extensible with new arithmetics tasks
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    Pi
    Pi combines a programming language (comparable to 'R') with an advanced GUI including 3D and 2D visualizations and a highly flexible interface to analyse, visualize and manipulate data. It is extendible by C++ librarys as well as by Pi-scripts
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    FuzzyArithmetic
    Fuzzy numbers and basic fuzzy arithmetics (+, -, *, /, 1/x) implementation written in Java. Should be used as a library, but it also has a GUI which demonstrates its capabilities (using SWT widgets).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    A simulator of Donald E. Knuth's fictitious MIX processor written in Java, which includes support for floating-point arithmetics.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    TAROT is a easy-to-use framework for Monte Carlo simulations in python. Calculations between different kinds of randomly distributed numbers are made as easy as basic arithmetics. Tarot provides an interactive graphical interface for interpretation.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    This Java library (currently 217 classes) is able to handle quantities in terms of basic arithmetics, conversion to similar units, serialization. As framework it allows to create new dimensions and units by inheritance.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    Projet cpp consistant à créer une librairie effectuant des opérations arithmétiques simples (somme, différence, produit, division) sur des grands nombres. Creation of an open source library managing huge numbers with simples arithmetics operations.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • Next