Showing 177 open source projects for "java swing components"

View related business solutions
  • $300 Free Credits to Build on Google Cloud Icon
    $300 Free Credits to Build on Google Cloud

    New customers can spin up VMs, build with AI, and query data at no cost.

    Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
    Start Free
  • Veeam Data Platform v13.1 - Get Your Free Trial Icon
    Veeam Data Platform v13.1 - Get Your Free Trial

    Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try it Free
  • 1
    tnv
    TNV visualizes pcap data to graphically depict network packets, links, and ports for network traffic analysis to facilitate learning what constitutes 'normal' behavior, investigating security events, or network troubleshooting.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 2
    System Information Monitor is a java based program that monitors various system information, it supports many platform including Windows, Linux and Unix. The underlying API utilizes Hyperic SIGAR API, JFreeChart and Swing Application Framework.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3
    Gostril Network Manager is a platform-independent, modular and extensible network management and monitoring software with graphing functionality and much more.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4
    Network Engineer Helper V1.0 program help NE in carrying out the usual operations like port scanning ip subnetting calc ... etc developed by x-max1212 http://xmax1212.freehostia.com abdallah abuouf http://abuouf.wordpress.com it's under GPL V2.0
    Downloads: 0 This Week
    Last Update:
    See Project
  • Train ML Models With SQL You Already Know Icon
    Train ML Models With SQL You Already Know

    BigQuery automates data prep, analysis, and predictions with built-in AI assistance.

    Build and deploy ML models using familiar SQL. Automate data prep with built-in Gemini. Query 1 TB and store 10 GB free monthly.
    Start Free
  • 5
    A WiMAX simulation system that supports 802.16e-2005 standard. The system provides the simulation of BS, MS, and Gateway in various environments.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    A software solution for managing Cybercafes,register users,define a network,log client's internet traffic,define custom services and block client workstations according to the antiterror laws of Italy (Legge Pisanu 155/05) and of other countries.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    AtomicDate is a Simple Network Time Protocol (SNTP) implementation in Java, as described by RFC 2030. It's composed by a client/server framework and works as an extension to java.util.Date class.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    Link-Rank visualizes large scale BGP routing changes. Each AS-AS link is weighed by the number of BGP routes carried and changes in link weights are used to visualize routing events. Currently, shows views from about 40 BGP routers from Oregon RouteViews
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    For new versions, check https://github.com/Darkkey/javaNetSim javaNetSim (Java Network Simulator) - it's a fork of a project jFirewallSim. The main goal of javaNetSim is creating a software to simulate various TCP/IP networks based on Ethernet, WiFi, PPP, etc...
    Downloads: 13 This Week
    Last Update:
    See Project
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • 10
    The main goal of this project is the development of an IFX Transaction Switch that handle particular devices like an ATM (J/XFS compliant), POS in the future, and other devices that speak a common language: IFX
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    IPv6SubnetCalc is a comprehensive calculator for IPv6 addresses. It comes with Java Swing GUI and supports the following RFCs: RFC4291, RFC4193, RFC3849, RFC2464, RFC5375, RFC4941, RFC3513, RFC3879, RFC4941, RFC3056, RFC3587, RFC2374, RFC3306, RFC3956.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 12
    Communication program that allows one instance to act as a server and then any number of instances to connect through any desired port (specified by the server) to Chat and transfer Files, the server relaying. Chat history can also be saved.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    The main purpose of this project is to develop a Graphic policy definition editor implemented in Java language and based on the XACML standard which manages access control policies
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    A simple, efficient, cross-platform port scanner implemented in Java. Features an intuitive user interface that is simple to use.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    Siganture Translator is a Java application which can translate signatures between different IDS's and Common Intrusion Detection Signatures Standard (CIDSS).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    Java based utility which graphically displays NS1 NetStumbler Files. Allows importing of a background image/map. Quickly displays the contents of the NS1 file, displays strength/noise/SNR and allows access point selection.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    SocketTest - powerful and small software tool for socket testing. It can create both TCP and UDP client or server. It can be used to test any server or client that uses TCP or UDP protocol to communicate.
    Leader badge
    Downloads: 55 This Week
    Last Update:
    See Project
  • 18

    MBJ

    Java SNMP MIB Browser

    Free SNMP MIB Browser written in Java. Provides support for running Jython scripts.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 19
    The Palantir project aims to monitor network health through agents distributed across the network. Each Palantir Agent monitors and tests the network from an enduser point of view and transmits the results to a central facility for analysis.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    HTTP Client Plugin is an Eclipse 3.3+ plugin that enables users to construct and execute HTTP protocol messages. It is intended to support protocol level testing of web components.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 21

    Java Network Scanner

    Simple java network scanner utility

    jnetscan is a simple java network utility, it allows you to scan networks, find reachable hosts , opened ports and sheared resources, with additional functions (ping, trace route, netstat, send message, ...)
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    SSH macro tool. This software is used for running simple command line based macros on multiple hosts running SSH. It provides remote scripting to multiple platforms via SSH (i.e. change your password on 20 systems automatically).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    CartoReso intends to facilitate enterprise computer network mapping.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    The XE Toolkit is a multi-platform, network-aware, secure performance monitoring solution for tactical analysis of enterprise computing systems.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    manetconfig is a graphical application implemented in Java and developed at TELECOM ParisTech. It allows the creation of multi-hop Manet environments where due to space limitations, only one-hop would appear. Different mobility models can be applied.
    Downloads: 0 This Week
    Last Update:
    See Project