Search Results for "object relational mapping" - Page 8

Showing 773 open source projects for "object relational mapping"

View related business solutions
  • Veeam Data Platform v13.1 - Get Your Free Trial Icon
    Veeam Data Platform v13.1 - Get Your Free Trial

    Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try it Free
  • Earn up to 16% annual interest with Nexo. Icon
    Earn up to 16% annual interest with Nexo.

    Let your crypto work for you

    Put idle assets to work with competitive interest rates, borrow without selling, and trade with precision. All in one platform. Geographic restrictions, eligibility, and terms apply.
    Get started with Nexo.
  • 1
    Voldemort

    Voldemort

    A distributed key-value storage system

    ...It offers many other features such as pluggable serialization support, data item versioning and an SSD Optimized Read Write storage engine. Voldemort is not a relational database or an object database. It is essentially a big, distributed, persistent, fault-tolerant hash table. This doesn’t make it ideal for all applications but does offer unique advantages, such as the ability to read and write scale horizontally, and the ability to combine in memory caching with the storage system so that a separate caching tier is not required.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 2

    OpenSource Domain Name Registry Platform

    Open-Source Domain Name Registry Platform based on Perl and mod_epp

    EPP Server, robust EPP-based Domain Name Registry System for New gTLD (.yourbrand) or for second level domains *.yourdomain.com. EPP Server supports the following RFCs: - RFC 5730 - (EPP) - RFC 5731 - (EPP) Domain Name Mapping - RFC 5732 - (EPP) Host Mapping - RFC 5733 - (EPP) Contact Mapping - RFC 5734 - (EPP) Transport over TCP The interface supports the following object types and transactions: - Domain commands: check, info, create, update, renew, delete, transfer - Host commands: check, info, create, update, delete - Contact commands: check, info, create, update, delete - Session commands: login, logout, hello, poll Uses the 'prepaid' billing model. ...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 3

    School Homework

    An open source website for help in grade 1-4 school work practice.

    An open source web-site for helping parents and students practice for school. Grade 1 to 4 Math work sheets are the main focus. Currently it only has content for grade 3 Math and applet for drawing in Raster and Vector formats. Project moved to: https://github.com/hammadrauf/School-Homework https://github.com/JuniorSchool https://github.com/JuniorSchool/SchoolShorts
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4
    360-FAAR  Firewall Analysis Audit Repair

    360-FAAR Firewall Analysis Audit Repair

    360-FAAR Analyze FW1 Cisco Netscreen Policy Offline Using Config/Logs

    360-FAAR (Firewall Analysis Audit and Repair) is an offline, command line, firewall policy manipulation tool to filter, compare to logs, merge, translate and output firewall commands for new policies, in Checkpoint dbedit, Cisco ASA or ScreenOS commands, and its one file! Read Policy and Logs for: Checkpoint FW1 (in odumper.csv / logexport format), Netscreen ScreenOS (in get config / syslog format), Cisco ASA (show run / syslog format), 360-FAAR compares firewall policies and uses...
    Leader badge
    Downloads: 0 This Week
    Last Update:
    See Project
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 5
    SimpleORM provides provides a very simple and easy way to implement object/relational mapping on top of JDBC atlow cost and low overhead. Not even an XML file to configure! It has clean database semantics and is very scalable. See http://berglas.org/simpleorm/index.html.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    Lattice Miner is a data mining prototype for creating, visualizing and exploring concept (Galois) lattices. It allows the generation of formal concepts and association rules.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    Better SQL in java! Offering a seamless java class mapping and SQL-like domain-specific language implemented for number of commercial and open-source DBMS
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    GeOxygene
    GeOxygene aims at providing an open framework which implements OGC/ISO specifications for the development and deployment of geographic (GIS) applications. It is a open source contribution of the COGIT lab. at the IGN (the French National Mapping Agency).
    Leader badge
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    Go XORM

    Go XORM

    Simple and Powerful ORM for Go

    XORM is a simple and powerful Object-Relational Mapping (ORM) library for Go. It provides a clean API for interacting with databases, supporting multiple database systems. XORM simplifies database operations by allowing developers to work with Go structs instead of writing raw SQL queries.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Fully Managed MySQL, PostgreSQL, and SQL Server Icon
    Fully Managed MySQL, PostgreSQL, and SQL Server

    Automatic backups, patching, replication, and failover. Focus on your app, not your database.

    Cloud SQL handles your database ops end to end, so you can focus on your app.
    Start Free
  • 10
    waterline

    waterline

    ORM for Node.js with support for mysql, mongo, postgres, mssql

    It provides a uniform API for accessing stuff from different kinds of databases, protocols, and 3rd party APIs. That means you write the same code to get and store things like users, whether they live in Redis, mySQL, LDAP, MongoDB, or Postgres. Waterline strives to inherit the best parts of ORMs like ActiveRecord, Hibernate, and Mongoose, but with a fresh perspective and emphasis on modularity, testability, and consistency across adapters. Sails comes installed with a powerful ORM/ODM...
    Downloads: 2 This Week
    Last Update:
    See Project
  • 11
    Empusa has moved to the HotRod project at Source Forge. Full DAO generator for MyBatis. Takes structure of an existing database using JDBC and generates DAOs, mappers, and all Mybatis configuration files.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    littletable is a lightweight in-memory data manager of collections of Python objects, providing ORM-like access for querying and joining data using object attributes as pseudo-columns.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13

    mgntprs

    framework for develop of json-service

    this project aims to create the most simple basics to create simple json-services to support mobile platforms and the most easy integration with the existing services.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14

    Harbour OORDB

    OORDB is a Object Oriented Relational Database Lib for Harbour Lang

    OORDB is a Harbour Library that provides capability to define, build and maintain Relational Databases using an Object Oriented approach in which the Database is maintained by defining Primary Keys, Relations, Dependencies, Constrains (at table and field level), Secondary Indexes are supported. Fields can be of the following types: String, Memo, Integer, Float, Logical, Date, DateTime, Modtime, Object ( a Table Object )
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    The Jcptbr is a framework for object-relational mapping written in the Java language. This framework addresses the problem of incompatibility between object and relational models, without the necessity of using xml for the mapping.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16

    HORK

    HORK v1.1 Object Relational Mapping (ORM) toolKit

    HORK stands for: HORK Object Relational toolKit. HORK is an open-source Object Relational Mapping (ORM) toolkit for database systems. HORK supports SQL Server and DBLX, and we will be adding support for other databases as the project moves along. HORK was designed by developers that use ORM frameworks every day. HORK will eventually provide everything needed in an ORM, but will have to retain its low complexity and very good performance. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17

    java-object-merger

    Library for merging and mapping of java objects

    Main goal of this library is to provide lightweight, easy configurable with annotations, and powerful tool for object mapping/merging, making life easier for projects with multilayer structure. It was take for me less then one day to completely migrate project at my main work (hundreds of classes, mappings between DTOs, Business objects and view objects) from dozer to java-object-merger without any serious issues. Go to Wiki pages for technical FAQ with examples! ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    OraExp

    OraExp

    Cross platform, native, asynchronous, free Oracle IDE

    ...It works on Linux and Windows (should theoretically work on Mac as well, though not tested yet) and supports Oracle 9i and later. Below is list of currently supported features: - Full unicode support - Creators/Editors/Viewers for following object types: Relational tables, Views, Packages, Procedures, Functions, Triggers, Sequences, Types, Synomyms, Database links, Users - Worksheet with support for bind parameters (including cursors) and multiple resultsets - DBMS output - Explain plan - Autotrace - Schema comparer - Schema exporter - Data comparer - Data copier - Data exporter - Data importer - Session browser
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    node-orm2

    node-orm2

    Object Relational Mapping

    Supported: 4.0 + If using Nodejs >= 14 & Postgres, you must use pg driver >= 8.1. v7 doesn't work correctly (tests time out). Tests are run on Travis CI If you want you can run tests locally. Create Models, sync, drop, bulk create, get, find, remove, count, aggregated functions. Create Model associations, find, check, create and remove. Define custom validations (several builtin validations, check instance properties before saving - see enforce for details). Model instance caching and...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    Pop Framework

    Pop Framework

    Use Java bean as model of web page, reference beans in hyperlinks

    Pop Framework (or Pop), http://www.popframework.net, is a bean-based MVC framework for Java/J2EE web applications. Pop implements IoC, Dependency Injection, and AOP. Pop provides annotations for users to define and reference a bean. Pop can help users to customize a bean, a scope, a factory and a reference in object-oriented way. Pop treats a bean as the model of a web page (JSP or servlet), the webpage itself is a view of the bean. The model provides the data for the view, the view is...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21

    ThinORM

    A lightweight ORM that does not require annotations.

    This project was the result of working on systems constrained to versions of Java < 1.5 and including a great deal of code dealing with object persistence. This project was essentially a proof-of-concept to determine whether or not I could create, essentially, an alternative to JPA that did not rely on annotations. I was able to create a working system, and a fairly lightweight one at that, but it would require a great deal of work to be production ready.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    strato

    strato

    模块化Web开发框架

    Downloads: 0 This Week
    Last Update:
    See Project
  • 23

    TreeFrog Framework

    High-speed C++ MVC Framework for Web Application

    TreeFrog Framework is a high-speed C++ MVC framework for developing Web applications.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    encuestame web survey tool

    encuestame web survey tool

    open source web survey software social tool

    Encuestame is an Open Source Java web application to publish, collect, share and measure the opinion of the people thought the social media or private environments. Private or public surveys, protected by password, widgets embeddable, ready for mobile and multi language
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    As of 03/2017, this project is moved to GitHub: https://github.com/cyberborean/rdfbeans ---- A simple Java-to-RDF databinding framework for transparent mapping JavaBean-like objects to RDF resources and vice versa.
    Downloads: 0 This Week
    Last Update:
    See Project