Showing 280 open source projects for "dns server"

View related business solutions
  • Veeam Data Platform v13.1 - Get Your Free Trial Icon
    Veeam Data Platform v13.1 - Get Your Free Trial

    Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try it Free
  • Ship Agents Faster Icon
    Ship Agents Faster

    Transform your applications and workflows into powerful agentic systems at global scale.

    Gemini Enterprise Agent Platform lets you rapidly build, scale, govern and optimize production-ready agents grounded in your organization's data. The platform enables developers to build custom or pre-built agents for virtually any use case. New customers get $300 in free credits.
    Start Free
  • 1
    TOFFEE-DataCenter

    TOFFEE-DataCenter

    Linux Server and Data-Center WAN Optimization

    TOFFEE-DataCenter is the new TOFFEE variant meant for Data-Center, Server, HPC, Load Balancing, Cluster/Cloud Computing and SDN deployments. With TOFFEE-DataCenter (and or TOFFEE), OEMs and other equipment vendors can make use of this platform/stack, integrate, port and build WAN Optimization devices/appliances on to their existing product range. Or build a dedicated WAN Optimization hardware product series via the same.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 2

    OpenSource Domain Name Registry Platform

    Open-Source Domain Name Registry Platform based on Perl and mod_epp

    EPP Server, robust EPP-based Domain Name Registry System for New gTLD (.yourbrand) or for second level domains *.yourdomain.com. EPP Server supports the following RFCs: - RFC 5730 - (EPP) - RFC 5731 - (EPP) Domain Name Mapping - RFC 5732 - (EPP) Host Mapping - RFC 5733 - (EPP) Contact Mapping - RFC 5734 - (EPP) Transport over TCP The interface supports the following object types and transactions: - Domain commands: check, info, create, update, renew, delete, transfer - Host...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3
    Advanced Persistent Security

    Advanced Persistent Security

    Advanced Persistent Threat Security

    The architecture of the system is integrated by different Fingerprinting mechanisms. The system is designed from a core that avoids the detection of sdhash and Memory analysis Built-in security, allows anonymous browsing by filtering requests external identification, Exit Tor Nodes and using the TOR Fingerprinting structure The system is designed to navigate without being detected or registered by any search engine or online platform denying all types of response to servers, The...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4
    VirtualMailServer Script

    VirtualMailServer Script

    Easy installation and configuration of a complete mail server

    Sorry. VirtulMailServer is not anymore an opensource project cause it's been involved in a commercial project. VMS is now an app for Bulk Email and it comes with new fully working features. If you are interested in the project, please contact me: claudio.taccogna@gmail.com . See you.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Train ML Models With SQL You Already Know Icon
    Train ML Models With SQL You Already Know

    BigQuery automates data prep, analysis, and predictions with built-in AI assistance.

    Build and deploy ML models using familiar SQL. Automate data prep with built-in Gemini. Query 1 TB and store 10 GB free monthly.
    Start Free
  • 5
    A simple but relatively complete DNS and DHCP implementation based on a MySQL (Or other) database with both servers drawing information from the same source thus eliminating one of the headaches of administering a small network.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6

    BNDC - Bind zone generator

    Forward and reverse zone generator for Bind nameserver.

    DNS zone file generator for Bind name server. It keeps fully customizable forward and reverse zones synchronized and reloads the server when necessary. Repository is on GitHub.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7

    Pen Loadbalancer

    Pen is a load balancer for udp and tcp based protocols.

    This is Pen, a load balancer for udp and tcp based protocols such as dns, http or smtp. It allows several servers to appear as one to the outside and automatically detects servers that are down and distributes clients among the available servers. This gives high availability and scalable performance.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8

    complemento

    Complemento is a collection of tools for pentesters.

    Complemento is a collection of tools for pentesters: LetDown is a powerful tcp flooder ReverseRaider is a domain scanner that use wordlist scanning or reverse resolution scanning Httsquash is an http server scanner, banner grabber and data retriever
    Downloads: 1 This Week
    Last Update:
    See Project
  • 9
    CODDNS

    CODDNS

    Custom Open Dynamic DNS, an integrated solution for DNS management.

    ...LAN Mode: In the version 1.0 of coddns there's the posibility of install the system as DNS master of your LAN. You and your colleagues will be able to manage the DNS server without enter any line in the shell. Enjoy the Linux capabilities without need to know how it works!
    Downloads: 0 This Week
    Last Update:
    See Project
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 10

    HomeDNS

    This is a tiny DNS server only for family used.

    This is a tiny DNS server only for family used. Support python2 and python3. https://github.com/liuyug/homedns
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    DNSChain

    DNSChain

    A blockchain-based DNS + HTTP server that fixes HTTPS security

    DNSChain by okTurtles is an experimental protocol and implementation combining DNS and PKI on blockchain for secure, censorship-resistant name resolution and certificate issuance. It aims to prevent MITM attacks and domain seizures by anchoring DNS records in blockchains, integrating DPKI, RESTful APIs, and interoperability with Namecoin and Onename.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12

    DNS rewriter

    simple local dns that either answer query or forward them

    Local DNS server, that act as a proxy and will rewrite request according to a config file and an "active" environement. Usefull to switch easily between diffent configuration without touch the host file. small web server embeded to display current configuration, control active environment and reload configuraiton.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    MITMf

    MITMf

    Framework for Man-In-The-Middle attacks

    ...Originally built to address the significant shortcomings of other tools (e.g Ettercap, Mallory), it's been almost completely rewritten from scratch to provide a modular and easily extendible framework that anyone can use to implement their own MITM attack. The framework contains a built-in SMB, HTTP and DNS server that can be controlled and used by the various plugins, it also contains a modified version of the SSLStrip proxy that allows for HTTP modification and a partial HSTS bypass. As of version 0.9.8, MITMf supports active packet filtering and manipulation (basically what better filters did, only better), allowing users to modify any type of traffic or protocol. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14

    power-console-admin

    Unix/Linux console admin for PowerDNS server

    Easy to use PowerDNS admin for Unix/Linux console. Work with SQLite3, MySQL, PostgreSQL backend. Easy way to create domain, add/update record data - simultaneously forward and reverse zone. Both IPv4 and IPv6 addresses. In the future maybe with ncurces UI.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    Passive network application response time monitor utilising libpcap packet capture. Maintains session state tracking host response, network round-trip times and end-point/network congestion. Can be configured for many protocols such as http, telnet...
    Leader badge
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    Those who have read past the "Malware" warning can be assured there is absolutely no malware in this OS or in the download. This warning comes from the "netcat" binary included in the download as a DOS time client. Unfortunately netcat has code that is flagged as malware. FREESCO, a NAT/firewall router/server based on Linux and runs on a single 1.44MB floppy. Freesco is very powerful and versatile and can connect multiple home or small office networks to most types of Internet connections...
    Downloads: 13 This Week
    Last Update:
    See Project
  • 17
    MyDNS-NG is the Next Generation DNS Server for fast and scalable sql based DNS services.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 18

    Viapps

    opensource Virtual Appliance Factory

    Viapps in an automation solution that support full live cycle of infrastructure services on Cloud environments, reducing very significantly time and resources needed to implement and operate these services. Solution allows to create, install, config, update, admin, monitor and audit services like Firewalls, DNS/DHCP/NTP Servers, HTTP Proxy, SMTP Gateways and IP LoadBalance (more services are comming). It is based on opensource components like Chef Server and own development, is compatible with main Cloud infrastructure technologies like VMWARE, Openstack, Cloudstack and openNebula . Extensible, it is posible to easily add new functionality and integrate with other platforms with a powerfull RESTful API
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    Z4 Phreak Tools 2.3

    Z4 Phreak Tools 2.3

    Modify Request and Response Header

    Version 2.3 Pro Edition is available (Mar/01/2015) What's new in version 2.3? - Fixed bugs Traffic - Fixed bugs Dialer - Fixed bugs Set Proxy IDM - Change Proxy Server (with listview) - Fixed bugs Query (add use query mode only) - Add New User-Agent to Query (SonyEriccson, NOKIA, Opera Mini, and Custom) - SMS (Create, Inbox, Outbox, Draft, Kontak) - Diagnostics Modem (Operator, Speed, RSSI, MCC, MNC, LAC, Cell ID, QoS, Sent, Recieved) - Set Network Type modem (3G Only, 3G Preferred, Edge Only, Edge Preferred) - Move Apps to main menu file (Tools > Apps External) - Move +Header to Header (in Manual mode configuration header) - Fixed bugs Lock GUI - Change main menu MDMA to PING - Fixed bugs GUI Header Log - New Icon for Change icon button - Add Updater - Fixed location tor.exe - Fixed Redial/ Reconnect (with count dial attemps) - Fixed Properties Modem (add number dial, use dns, disable netbios) Regards, Author : zaya razta (z4y4@bugs4u)
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20

    Navi

    Chat and Voice chat system

    Chat and Voice chat system based on a distributed network of cooperating servers. You can download your own server at: https://github.com/xeyos/RM-Kaepora The idea may seem a little complex, everyone can run his own server and each server can register its own users, but every user can contact each other even if they're registered on different servers. Comunication is handled over a P2P connection and servers are used just as mere DNS machines and to recover your friendlist data. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    Kloxo

    Kloxo

    Kloxo Web Hosting Panel

    ...Kloxo allows the host administrators to run a combination of lighttpd or Apache with djbdns or BIND, and provides a graphical interface to switch between these programs without losing data. Kloxo Enterprise can transparently move web/mail/dns from one server running Apache to another running lighttpd.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    Multi Whois Client
    Multi Whois is a small whois domain name search program capable of finding bulk domains via a wordlist file or specific domains provided by the user. It's a good way to search for domains that are available to buy. The wordlist format consists of a domain name per line with or without the .dot tld.. Examples below google yahoo foobar Note:Must select a tld from the dropdown box or google.com yahoo.net foobar.guru
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    EbolaShell -Ddos with multiple methods -DNS info and reporting -Whois site look up -Port scanner -Site Check ( is it up) (only checks site from server location)
    Downloads: 1 This Week
    Last Update:
    See Project
  • 24
    EbolaShell (3) 2.1 update This is not ebola 3, just the update to 2.1 The full 3 (new) will be posted sometime this week. -Ddos with multiple methods -DNS info and reporting -Whois site look up -Port scanner -Site Check ( is it up) (only checks site from server location)
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    EbolaShell -Ddos with multiple methods -DNS info and reporting -Whois site look up -Port scanner -Site Check ( is it up) (only checks site from server location)
    Downloads: 0 This Week
    Last Update:
    See Project