Showing 2384 open source projects for "json-py"

View related business solutions
  • Build Data Resilience - Take the Assessment Today Icon
    Build Data Resilience - Take the Assessment Today

    Can you recover when it matters most? Take this quick assessment to identify gaps and build greater recovery confidence.

    Is your recovery strategy as strong as you think? Take this quick self-assessment to check your recovery readiness and gain tailored insights. In only 2 minutes, you'll learn where you fall on the recovery readiness scale.
    Take the Assessment
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • 1
    yyjson

    yyjson

    The fastest JSON library in C

    A high-performance JSON library written in ANSI C.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 2
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 1 This Week
    Last Update:
    See Project
  • 3
    Countries States Cities Database

    Countries States Cities Database

    Discover our global repository of countries, states, and cities

    Full Database of city state country available in JSON, SQL, XML, YAML & CSV format. All Countries, States and cities are Covered and populated with Different Combinations and versions. The API database is regularly updated to ensure the latest data is available to users. Discover our global repository of countries, states, and cities! Get comprehensive data in JSON, SQL, XML, YAML, and CSV formats.
    Downloads: 14 This Week
    Last Update:
    See Project
  • 4
    OSCAL

    OSCAL

    Open Security Controls Assessment Language (OSCAL)

    ...The OSCAL website provides an overview of the OSCAL project, including an XML and JSON schema reference, examples, and other resources.
    Downloads: 53 This Week
    Last Update:
    See Project
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 5
    simdjson

    simdjson

    Parsing gigabytes of JSON per second

    JSON is everywhere on the Internet. Servers spend a *lot* of time parsing it. We need a fresh approach. The simdjson library uses commonly available SIMD instructions and microparallel algorithms to parse JSON 4x faster than RapidJSON and 25x faster than JSON for Modern C++. The simdjson library uses three-quarters less instructions than state-of-the-art parser RapidJSON.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 6
    ZJsonPatch

    ZJsonPatch

    This is an implementation of RFC 6902 JSON Patch written in Java

    This is an implementation of RFC 6902 JSON Patch written in Java. It can be used to avoid sending a whole document when only a part has changed, thus reducing network bandwidth requirements if data (in JSON format) is required to send across multiple systems over network or in case of multi DC transfer.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 7
    BSON parser

    BSON parser

    BSON Parser for node and browser

    BSON parser is the core JavaScript implementation of BSON (Binary JSON), the data format used by MongoDB to represent documents on the wire and in storage. It provides encoding and decoding capabilities so JavaScript environments like Node.js and browsers can serialize rich data structures (including types not native to JSON) into the compact, efficient BSON binary representation used by MongoDB drivers and servers.
    Downloads: 17 This Week
    Last Update:
    See Project
  • 8
    dyff

    dyff

    diff tool for YAML files, and sometimes JSON

    A diff tool for YAML files, and sometimes JSON. dyff is inspired by the way the old BOSH v1 deployment output reported changes from one version to another by only showing the parts of a YAML file that changed. Similar to the standard diff tool, it follows the principle of describing the change by going from the input file to the target to the input file. Input files can be local files (filesystem path), remote files (URI), or the standard input stream (using -).
    Downloads: 12 This Week
    Last Update:
    See Project
  • 9
    Manfred Awesomic CV

    Manfred Awesomic CV

    Manfred Awesomic CV

    The MAC (or Manfred Awesomic CV) is a(nother) naive attempt to create a standard open-source format to define and share CVs. The format is defined as a JSON Schema to validate CVs stored as JSON files. There are A LOT of CV formats, and some of them are a nice try to define a universal CV format, but we think that a CV should include not only what candidates are or know but also what they are interested in and what they want to become. Like most open-source projects, the first use case was found in the company where the first contributors worked. ...
    Downloads: 5 This Week
    Last Update:
    See Project
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 10
    Shale

    Shale

    Shale is a Ruby object mapper and serializer for JSON, YAML, TOML

    Shale is a Ruby object mapper and serializer for JSON, YAML, TOML, CSV and XML. It allows you to parse JSON, YAML, TOML, CSV and XML data and convert it into Ruby data structures, as well as serialize data structures into JSON, YAML, TOML, CSV or XML.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    Render

    Render

    Go package for easily rendering JSON, XML, binary data, and HTML

    Render is a package that provides functionality for easily rendering JSON, XML, text, binary data, and HTML templates. Render can be used with pretty much any web framework provided you can access the HTTP.ResponseWriter from your handler. The rendering functions simply wraps Go's existing functionality for marshaling and rendering data. HTML: Uses the html/template package to render HTML templates. JSON: Uses the encoding/json package to marshal data into a JSON-encoded response. ...
    Downloads: 8 This Week
    Last Update:
    See Project
  • 12
    Glaze

    Glaze

    Extremely fast, in memory, JSON and interface library for modern C++

    One of the fastest JSON libraries in the world. Glaze reads and writes from C++ memory, simplifying interfaces and offering incredible performance. Glaze also supports binary messages via BEVE and CSV support. And, the library has many more useful features for building APIs.
    Downloads: 7 This Week
    Last Update:
    See Project
  • 13
    keycloak-config-cli

    keycloak-config-cli

    Import YAML/JSON-formatted configuration files into Keycloak

    keycloak-config-cli is a Keycloak utility to ensure the desired configuration state for a realm based on a JSON/YAML file. The format of the JSON/YAML file is based on the export realm format. Store and handle the configuration files inside git just like normal code. A Keycloak restart isn't required to apply the configuration. The config files are based on the keycloak export files. You can use them to re-import your settings. But keep your files as small as possible. ...
    Downloads: 6 This Week
    Last Update:
    See Project
  • 14
    Editor.js

    Editor.js

    A block-style editor with clean JSON output

    ...It has a modern, block-style interface that allows users to easily add and arrange different types of content, such as text, images, lists, quotes, etc. Each Block is provided via a separate plugin making Editor.js extremely flexible. Editor.js outputs clean JSON data instead of heavy HTML markup. Use it in the Web, iOS, Android, AMP, Instant Articles, speech readers, and AI chatbots, everywhere. Easy to sanitize, extend, and integrate with your logic.
    Downloads: 10 This Week
    Last Update:
    See Project
  • 15
    pyserde

    pyserde

    Yet another serialization library on top of dataclasses

    Yet another serialization library on top of data classes, inspired by serde-rs. Declare a class with pyserde's @serde decorator.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 16
    svelte-jsoneditor

    svelte-jsoneditor

    Web-based tool to view, edit, format, repair, query, & transform JSON

    A web-based tool to view, edit, format, transform, and validate JSON. The library is written with Svelte, but can be used in plain JavaScript too, and in any framework (SolidJS, React, Vue, Angular, etc). View and edit JSON, has a low-level text editor and high-level tree view and table view. Format (beautify) and compact JSON. Sort, query, filter, and transform JSON. JSON schema validation and pluggable custom validation.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    restc-cpp C++ library

    restc-cpp C++ library

    Modern C++ REST Client library

    The magic that takes the pain out of accessing JSON API's from C++. It formulates a HTTP request to a REST API server. Then, it transforms the JSON formatted payload in the reply into a native C++ object (GET). It Serializes a native C++ object or a container of C++ objects into a JSON payload and sends it to the REST API server (POST, PUT). It formulates an HTTP request to the REST API without serializing any data in either direction (typically DELETE).
    Downloads: 4 This Week
    Last Update:
    See Project
  • 18
    Jwt.Net

    Jwt.Net

    Jwt.Net, a JWT (JSON Web Token) implementation for .NET

    This library supports generating and decoding JSON Web Tokens. By default JSON serialization is performed by JsonNetSerializer implemented using JSON.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    Jansson

    Jansson

    C library for encoding, decoding and manipulating JSON data

    Jansson is a C library for encoding, decoding and manipulating JSON data.
    Downloads: 4 This Week
    Last Update:
    See Project
  • 20
    react-jsonschema-form

    react-jsonschema-form

    A React component for building Web forms from JSON Schema

    A simple React component capable of using JSON Schema to declaratively build and customize web forms.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 21
    granary

    granary

    The social web translator

    The social web translator. Fetches and converts data between social networks, HTML and JSON with microformats2, ActivityStreams/ActivityPub, Atom, JSON Feed, and more. Granary is a library and REST API that fetches and converts between a wide variety of social data sources and formats. Free yourself from silo API chaff and expose the sweet social data foodstuff inside in standard formats and protocols.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 22
    easyjson

    easyjson

    Fast JSON serializer for golang

    Package easyjson provides a fast and easy way to marshal/unmarshal Go structs to/from JSON without the use of reflection. In performance tests, easyjson outperforms the standard encoding/json package by a factor of 4-5x, and other JSON encoding packages by a factor of 2-3x. easyjson aims to keep generated Go code simple enough so that it can be easily optimized or fixed. Another goal is to provide users with the ability to customize the generated code by providing options not available with the standard encoding/json package, such as generating "snake_case" names or enabling omitempty behavior by default.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 23
    fastjson

    fastjson

    A fast JSON parser/generator for Java

    Fastjson is a Java library that can be used to quickly convert Java Objects into their JSON representation or convert JSON strings to their equivalent Java object. Based on benchmarks it provides the best performance in both server side and Android client, and can work with arbitrary Java objects, even those pre-existing objects of which you do not have the source code. Fastjson provides a simple conversion method to turn Java objects to JSON and vice versa, with extensive support of Java Generics and arbitrarily complex objects.
    Downloads: 10 This Week
    Last Update:
    See Project
  • 24
    circe

    circe

    Yet another JSON library for Scala

    circe is a JSON library for Scala (and Scala.js).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    License List Data

    License List Data

    Various data formats for the SPDX License List

    Various data formats for the SPDX License List including RDFa, HTML, Text, and JSON.
    Downloads: 1 This Week
    Last Update:
    See Project