Showing 39238 open source projects for "web-cat"

View related business solutions
  • Ship Agents Faster Icon
    Ship Agents Faster

    Transform your applications and workflows into powerful agentic systems at global scale.

    Gemini Enterprise Agent Platform lets you rapidly build, scale, govern and optimize production-ready agents grounded in your organization's data. The platform enables developers to build custom or pre-built agents for virtually any use case. New customers get $300 in free credits.
    Start Free
  • Host LLMs in Production With On-Demand GPUs Icon
    Host LLMs in Production With On-Demand GPUs

    NVIDIA L4 GPUs. 5-second cold starts. Scale to zero when idle.

    Deploy your model, get an endpoint, pay only for compute time. No GPU provisioning or infrastructure management required.
    Start Free
  • 1
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 2
    Chyrp Lite

    Chyrp Lite

    An ultra-lightweight blogging engine, written in PHP

    Chyrp Lite makes it possible to host a blog on your own web server with minimal fuss. You can have a traditional blog, a tumble blog, or you can add oodles of customization and build a general-purpose web publishing platform with blogging features on the side. You get four beautiful blog themes and a friendly administration console, all fully navigable on a broad range of devices, thanks to the power of responsive HTML5.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 3
    Retire.js

    Retire.js

    Scanner detecting the use of JavaScript libraries

    There is a plethora of JavaScript libraries for use on the web and in node.js apps out there. This greatly simplifies, but we need to stay updated on security fixes. "Using Components with Known Vulnerabilities" is now a part of the OWASP Top 10 and insecure libraries can pose a huge risk for your web app. The goal of Retire.js is to help you detect the use of versions with known vulnerabilities.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 4
    Frappe Books

    Frappe Books

    Free Desktop book-keeping software for small-businesses & freelancers

    ...It's made to work offline using a local SQLite file as the database, so you don't have to be dependent on a Cloud service provider. Frappe Books features a clean and modern, web-friendly UI, beautiful invoice templates, standard financial reports and other great features. It's inherently portable and secure, as your data is never uploaded into the Cloud.
    Downloads: 26 This Week
    Last Update:
    See Project
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 5
    JKVideo

    JKVideo

    Bilibili-like app with DASH playback, danmaku, WBI sign

    JKVideo is a feature-rich, open-source video streaming client built with React Native, designed as a third-party interface for consuming video content similar to platforms like Bilibili. It supports multiple platforms, including Android, iOS, and web environments, providing a consistent and modern user experience across devices. The application focuses on delivering high-quality playback using technologies such as DASH streaming, ensuring smooth and adaptive video performance. It includes advanced features like live streaming support and real-time comment overlays, commonly known as danmaku, which enhance interactivity and engagement. ...
    Downloads: 8 This Week
    Last Update:
    See Project
  • 6
    eLabFTW

    eLabFTW

    Open source electronic lab notebook for research labs

    eLabFTW is a modern, open-source electronic laboratory notebook (ELN) that helps research teams store, organize, and manage experimental records and laboratory data from a central web interface. Designed for scientific environments, the software provides a secure, browser-accessible platform where users can log protocols, results, and observations in structured records that replace traditional paper notebooks. Beyond simple experiment journaling, eLabFTW includes an inventory database for tracking lab materials, reagents, and equipment, making it a versatile tool for laboratory management. ...
    Downloads: 8 This Week
    Last Update:
    See Project
  • 7
    Omnom

    Omnom

    A web content preservation service

    Omnom is a self-hosted content preservation and web bookmarking platform that lets individuals and communities save and archive web content in a way that reflects exactly what they saw in their browser at the moment of capture. Unlike simple bookmark lists, Omnom makes full page snapshots — including dynamic content — so that saved pages remain viewable even if the original goes offline or changes later.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    Easy Diffusion

    Easy Diffusion

    An easy 1-click way to create beautiful artwork on your PC using AI

    Easy Diffusion is a widely used community-driven repository offering a simple, one-click way to install and use Stable Diffusion-based generative AI on a personal computer without advanced technical skills or prior setup. It provides a browser-based user interface that runs locally, allowing users to type text prompts and immediately generate images directly within their web browser, democratizing access to powerful text-to-image models for artists and hobbyists alike. The project abstracts away environment setup, dependencies, and model installation — tasks that can be daunting to beginners — and instead lets users focus on creative experimentation with prompt phrasing, model parameters, and image output settings. ...
    Downloads: 34 This Week
    Last Update:
    See Project
  • 9
    Servo

    Servo

    Embed web technologies in applications

    ...It leverages Rust’s memory-safety and concurrency strengths, supports modern GPU-powered rendering (WebGL/WebGPU), and serves as a research-forward alternative to traditional browser engines. Servo is a prototype web browser engine written in the Rust language. It is currently developed on 64-bit macOS, 64-bit Linux, 64-bit Windows, 64-bit OpenHarmony, and Android. Open governance under Linux Foundation Europe; collaborative project evolving standards. Cross-platform support including Windows, macOS, Linux, Android, OpenHarmony.
    Downloads: 8 This Week
    Last Update:
    See Project
  • Train ML Models With SQL You Already Know Icon
    Train ML Models With SQL You Already Know

    BigQuery automates data prep, analysis, and predictions with built-in AI assistance.

    Build and deploy ML models using familiar SQL. Automate data prep with built-in Gemini. Query 1 TB and store 10 GB free monthly.
    Start Free
  • 10
    LANraragi

    LANraragi

    Web application for archival and reading of manga/doujinshi

    LANraragi is a web application for archiving and reading manga/doujinshi. Lightweight and Docker-ready, it's designed for NAS and server environments, providing a user-friendly interface for managing comic collections.​
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    noVNC

    noVNC

    VNC client web application

    noVNC is a VNC client JavaScript library as well as an application built on top of that library. noVNC runs well in any modern browser, including mobile browsers (iOS and Android).
    Downloads: 20 This Week
    Last Update:
    See Project
  • 12
    lambda-request-handler

    lambda-request-handler

    Package your Node.js web app as a Lambda function executed by an API

    Package your Node.js web app as a Lambda function executed by an API Gateway or ALB event. An npm module that allows your Node.js web applications to be deployed as an AWS Lambda function and invoked in response to API Gateway, HTTP API, or Application Load Balancer requests.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    metasfresh

    metasfresh

    Fast, Flexible & Free Software to scale your Business

    ...Equipped with wide and detailed functionality, metasfresh fits for companies from industry and trade that are searching business software that provides high scalability and flexibility. It has a 3-tier architecture with Rest-API and a Web User Frontend developed in HTML5/ ReactJS/ Redux.
    Downloads: 6 This Week
    Last Update:
    See Project
  • 14
    PufferPanel

    PufferPanel

    PufferPanel is an open source game server management panel

    The simplest, free, open source game management panel. PufferPanel is an open source game server management panel designed to be easy to use and easy to install. PufferPanel supports Minecraft, Forge, Spigot, Sponge, Source Dedicated Servers, BungeeCord, PocketMine, Forge, and much more. In addition to being a free and open source project, PufferPanel provides an easy-to-use interface for everyone from individual users to large networks or companies. We strive to create a friendly community,...
    Downloads: 34 This Week
    Last Update:
    See Project
  • 15
    Roach

    Roach

    The complete web scraping toolkit for PHP

    Roach is a complete web scraping toolkit for PHP. It is a shameless clone heavily inspired by the popular Scrapy package for Python. Roach allows us to define spiders that crawl and scrape web documents. But wait, there’s more. Roach isn’t just a simple crawler, but includes an entire pipeline to clean, persist and otherwise process extracted data as well.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    Brotli

    Brotli

    Brotli compression format

    Version 1.0.9 contains a fix to "integer overflow" problem. This happens when "one-shot" decoding API is used (or input chunk for streaming API is not limited), input size (chunk size) is larger than 2GiB, and input contains uncompressed blocks. After the overflow happens, memcpy is invoked with a gigantic num value, that will likely cause the crash. Brotli is a generic-purpose lossless compression algorithm that compresses data using a combination of a modern variant of the LZ77 algorithm,...
    Downloads: 38 This Week
    Last Update:
    See Project
  • 17
    React

    React

    A JavaScript library for building user interfaces

    React makes it painless to create interactive UIs. Design simple views for each state in your application, and React will efficiently update and render just the right components when your data changes. React lets you build user interfaces out of individual pieces called components. Create your own React components like Thumbnail, LikeButton, and Video. Then combine them into entire screens, pages, and apps. Whether you work on your own or with thousands of other developers, using React...
    Downloads: 16 This Week
    Last Update:
    See Project
  • 18
    INTERCEPT

    INTERCEPT

    Unites the best signal intelligence tools

    iNTERCEPT is a web-based interface that brings multiple software-defined radio and signal-intelligence style tools under one consistent dashboard, making complex workflows more approachable. Rather than requiring you to learn a different UI and setup process for each underlying utility, it provides a single place to start modes, view results, and monitor activity from a browser.
    Downloads: 29 This Week
    Last Update:
    See Project
  • 19
    VibeSDK

    VibeSDK

    Open source full-stack AI vibe coding platform & web app generator

    ...Support for React + TypeScript + Tailwind generation, backend routing, and modern web stack scaffolding.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 20
    Playwright for Go

    Playwright for Go

    Playwright for Go a browser automation library to control Chromium

    Playwright is a Node.js library to automate Chromium, Firefox, and WebKit with a single API. Playwright is built to enable cross-browser web automation that is ever-green, capable, reliable and fast. Headless execution is supported for all browsers on all platforms. Playwright is built to automate the broad and growing set of web browser capabilities used by Single Page Apps and Progressive Web Apps. Scenarios that span multiple page, domains and iframes. Auto-wait for elements to be ready before executing actions (like click, fill). ...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 21
    OpenUI5

    OpenUI5

    OpenUI5 lets you build enterprise-ready web applications

    OpenUI5 lets you build enterprise-ready web applications, responsive to all devices, running on almost any browser of your choice. OpenUI5 follows open standards and includes powerful development concepts, efficient tools, as well as a rich set of UI controls. No need to worry about device specifics! UI5 apps and controls run on smartphones, tablets and desktop browsers. OpenUI5 is a JavaScript UI Framework released by SAP under the Apache 2.0 license.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 22
    You-Get

    You-Get

    Dumb downloader that scrapes the web

    You-Get is a small command-line utility for downloading media (video, audio and images) from the Web when there are no other means to do so. It can download video and audio files from such popular web sites as YouTube, Twitter, Niconico, Vimeo, Flickr, Instagram and a whole lot more. You-Get is a great option for when you want to enjoy your favorite videos, audio or images from the internet without having to open any web browsers or get interrupted by ads. ...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 23
    XUI-PRO

    XUI-PRO

    XUI-PRO nginx reverse proxy with ws/grpc/httpupgrade/splithttp

    ...It also includes Cloudflare SSL and Nginx reverse proxy behavior for supported configurations. x-ui-pro is aimed at users who want a web panel and bundled setup process for managing complex proxy configurations. Because it deals with network circumvention and proxy infrastructure, it should be used only in lawful, authorized environments.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 24
    AtlantaFX

    AtlantaFX

    Modern JavaFX CSS theme collection with additional controls

    Modern JavaFX CSS theme collection with additional controls.
    Downloads: 14 This Week
    Last Update:
    See Project
  • 25
    web-mode.el

    web-mode.el

    Web template editing mode for emacs

    web-mode.el is an autonomous emacs major mode for editing web templates. HTML documents can embed parts (CSS / JavaScript) and blocks (client / server side). web-mode.el is compatible with many template engines: PHP, JSP, ASP, Django, Twig, Jinja, Mustache, ERB, FreeMarker, Velocity, Cheetah, Smarty, CTemplate, Mustache, Blade, ErlyDTL, Go Template, Dust.js, Google Closure (soy), React/JSX, Angularjs, ejs, Nunjucks, etc.
    Downloads: 0 This Week
    Last Update:
    See Project