Showing 92 open source projects for "linux system"

View related business solutions
  • Build Securely on AWS with Proven Frameworks Icon
    Build Securely on AWS with Proven Frameworks

    Lay a foundation for success with Tested Reference Architectures developed by Fortinet’s experts. Learn more in this white paper.

    Moving to the cloud brings new challenges. How can you manage a larger attack surface while ensuring great network performance? Turn to Fortinet’s Tested Reference Architectures, blueprints for designing and securing cloud environments built by cybersecurity experts. Learn more and explore use cases in this white paper.
    Download Now
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 1
    C++ Airline Inventory Management Library
    That project aims at providing a clean API and a simple implementation, as a C++ library, of an Airline-related Inventory Management system. That library uses the Standard Airline IT C++ object model (http://sf.net/projects/stdair).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 2

    Ionflux Tools

    Metaprogramming framework for C++ development with Python bindings

    NOTICE: This repository of IFTools will no longer be maintained. You can find the current version at https://github.com/TehFlux/iftools iftools is an umbrella project for various libraries and utilities that facilitate application development in C++ with full Python bindings. It provides a rich set of features while still maintaining compatibility with other frameworks through a very low overhead and a lack of "tricks". iftools uses its own, easily extensible template system to provide a...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3

    Tygamusic

    A pygame music lib.

    This lib was produced while I was programming an other program/game. I was tired of pygame's bad system of handling playlists and the management of music in general. With this lib I want to create an layer that allows you to interact with the music, how you would expect it. Currently featuring: -Playlist -Normal pausing and resuming (played time isn’t lost when new song is loaded) -Automatic recognition of songs and adding them to a separate list
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4

    Flask-AppBuilder

    Rapid web application development (python + Flask)

    Simple and rapid Application builder, built on top of Flask. includes detailed security, auto form generation, google charts and much more. Demo on: http://flaskappbuilder.pythonanywhere.com/
    Downloads: 0 This Week
    Last Update:
    See Project
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • 5
    Fast Artificial Neural Network Library is a free open source neural network library, which implements multilayer artificial neural networks in C with support for both fully connected and sparsely connected networks. Cross-platform execution in both fixed and floating point are supported. It includes a framework for easy handling of training data sets. It is easy to use, versatile, well documented, and fast. Bindings to more than 15 programming languages are available. An easy to read...
    Downloads: 17 This Week
    Last Update:
    See Project
  • 6
    z-utalm

    z-utalm

    Unified Test and Logging layer for multiple programming languages

    Modern software systems and application are commonly written in multiple languages, include scripting engines, and are frequently build on multiple specialized frameworks and middleware for a considerable diversity of runtime environments. The latest influencing update in development paradigm is the application of multicore processors. This projects is aimed to unify the required trace and logging output and integrate into debugging environments. The target is to provide general development,...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7

    math toolkit

    A C++ and Python library for finance, statistics and linear algebra.

    A lightweight C++ and Python library for finance, statistics and linear algebra. Finance features include compound rate present/future value, annuity, various present/future value coefficients ... Statistics features include mean, median, variance, standard deviation, covariance, correlation, linear regression, probabilities and random variates of various distributions ... Linear algebra features include matrix arithmetic, inverse, determinant, rank, linear system solution, lu/qr...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    Voikko

    Voikko

    Library of linguistic tools

    Voikko is a spell checking, grammar checking, morphological analysis and hyphenation system. Spell checkers are available for multiple languages, other features for Finnish only.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 9

    vsResolver

    DNS Validating Stub Resolver

    The Validating Stub Resolver (vsResolver) is a DNS stub resolver that implements the Domain Name System Security Extensions (DNSSEC) specified in RFC 4033, RFC 4034 and RFC 4035. These add data origin authentication and data integrity to the Domain Name System. vsResolver extends the dnspython toolkit (http://www.dnspython.org/) and uses the pycrypto library for its underlying crypto implementation(https://www.dlitz.net/software/pycrypto/). Click on this link for a ridiculously simple...
    Downloads: 0 This Week
    Last Update:
    See Project
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 10

    pytkmdiapp

    Python package to develop a simple app. with multi-window tk interface

    Python package to develop a simple application with multi-window interface using tkinter library.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    Reporting engine library written in C. Create one XML file and generate PDF, HTML, TXT, and CSV reports based on queries. Has support for MySQL, PostgreSQL, ODBC. Bindings for PHP, Java, Python.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 12
    PyMW is a Python module for parallel master-worker computing in a variety of environments. With the PyMW module, users can write a single program that scales from multicore machines to global computing platforms.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    Web gallery based on pre-generated metadata, typically according to directory structure, not database or an administration. Development moved to: http://github.com/martinkozak/fsgal.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    CTypes-based python bindings to the GSASL library (www.gnu.org/software/gsasl ). This package provides a parser that generates python code w/ types checking and more pythonish feel than just plain usage of the library through ctypes.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    C Library to manage a pool of event/task in a persistent way to assure that your events/tasks won't be deleted because of a failure. Events/tasks are saved on a FS. if FS is NFS, NFS availability checks are made. (comes with a python binding)
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    context_menu

    context_menu

    A Python library to create and deploy cross-platform native context

    A Python library to create and deploy cross-platform native context. context_menu was created as due to the lack of an intuitive and easy to use cross-platform context menu library. The library allows you to create your own context menu entries and control their behavior seamlessly in native Python code. It's fully documented and used by over 80,000 developers worldwide.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17

    Atta

    Build tool in pure Python. http://boguslawski-piotr.github.com/atta/

    Atta is a FREE build tool, targets-tasks driven, developed in pure Python. Similar in philosophy to the Ant, NAnt, etc. but without the use of XML syntax nightmare. http://boguslawski-piotr.github.com/atta/
    Downloads: 0 This Week
    Last Update:
    See Project