Showing 135 open source projects for "web server open source"

View related business solutions
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 1
    JSON Server

    JSON Server

    Get a full fake REST API with zero coding

    Get a full fake REST API with zero coding in less than 30 seconds (seriously). Created with <3 for front-end developers who need a quick back-end for prototyping and mocking. If you need to add authentication, validation, or any behavior, you can use the project as a module in combination with other Express middleware. You can deploy JSON Server. For example, JSONPlaceholder is an online fake API powered by JSON Server and running on Heroku. If you make POST, PUT, PATCH or DELETE requests,...
    Downloads: 5 This Week
    Last Update:
    See Project
  • 2
    webrpc

    webrpc

    webrpc is a schema-driven approach to writing backend services

    webrpc is a schema-driven approach to writing backend servers for the Web. Write your server's API interface in a schema format of RIDL or JSON, and then run webrpc-gen to generate the networking source code for your server and client apps. From the schema, webrpc-gen will generate application-based class types/interfaces, JSON encoders, and networking code. In doing so, it's able to generate fully functioning and typed client libraries to communicate with your server. ...
    Downloads: 84 This Week
    Last Update:
    See Project
  • 3
    Express Zod API

    Express Zod API

    A Typescript library to help you get an API server up and running

    Start your API server with I/O schema validation and custom middlewares in minutes. I made this library because of the often repetitive tasks of starting a web server API with the need to validate input data. It integrates and provides the capabilities of popular web servers, logger, validation, and document solutions. Therefore, many basic tasks can be accomplished faster and easier.
    Downloads: 12 This Week
    Last Update:
    See Project
  • 4
    Bludit

    Bludit

    Simple, Fast, Secure, Flat-File CMS

    Bludit the Simple, Fast, and Flexible CMS. With Bludit, you can build your own website or blog in just seconds. It’s completely free, open-source, and easy to use. Bludit stores content in JSON format, eliminating the need for database installation or configuration. All you need is a web server with PHP support. As a Flat-File CMS, Bludit offers unparalleled flexibility and speed. Plus, with support for both Markdown and HTML code, creating and managing content has never been easier.
    Downloads: 15 This Week
    Last Update:
    See Project
  • Demo Series - Small Business Backup By Veeam Icon
    Demo Series - Small Business Backup By Veeam

    Learn how to protect your Microsoft 365 data, with simple, actionable tips today.

    Watch this on-demand demo series and learn how to protect your Microsoft 365 data with clear, simple, actionable steps that are easy to implement for businesses of all sizes.
    Watch Demo Series
  • 5
    fastn

    fastn

    (Alpha stage software) fastn - Full-stack Web Development Made Easy

    ftd is a programming language for building user interfaces and content-centric websites. ftd is easy to learn, especially for nonprogrammers, but it does not compromise on what you can build with it. fastn is a web framework, a content management system, and an integrated development environment for ftd. fastn is a web server, that compiles ftd to HTML/CSS/JS and can be deployed on your server, or on fastn cloud by FifthTry. ftd is designed with minimal and uniform syntax, and at first...
    Downloads: 4 This Week
    Last Update:
    See Project
  • 6
    TreeFrog Framework

    TreeFrog Framework

    TreeFrog Framework, High-speed C++ MVC Framework for Web Applications

    ...TreeFrog Framework is cross-platform. It runs on Windows, of course, but also on UNIX-like Operating Systems, macOS, and Linux. Using Windows open-source coding, it is possible to support Linux. Web applications that run on multiple platforms are also possible, simply by recompiling the source code. TreeFrog Framework is open-source software, under the new BSD license (3-clause BSD License).
    Downloads: 8 This Week
    Last Update:
    See Project
  • 7
    Cutelyst

    Cutelyst

    Web Framework built on top of Qt, using the approach of Catalyst

    Create fast and modern web applications that share the same code as your desktop or mobile apps. Why have two or more development teams focused on a specific platform when you can have a single team coding the same code, sharing skills and lines of code. With Qt, you already can write applications for Windows, Linux, Android, MacOS, and iOS using the same source code, Cutelyst allows you to share your C++ code with your web application.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 8
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 15 This Week
    Last Update:
    See Project
  • 9
    Biome

    Biome

    A toolchain for web projects, aimed to provide functionalities

    Biome formats and lints your code in a fraction of a second. Biome supports JavaScript, TypeScript, JSON, and CSS. It aims to support all main languages of modern web development. Biome has sane defaults and requires minimal configuration. Biome helps you as much as possible by displaying detailed and contextualized diagnostics. Biome unifies functionality that has previously been separate tools. Building upon a shared base allows us to provide a cohesive experience for processing code,...
    Downloads: 48 This Week
    Last Update:
    See Project
  • Train ML Models With SQL You Already Know Icon
    Train ML Models With SQL You Already Know

    BigQuery automates data prep, analysis, and predictions with built-in AI assistance.

    Build and deploy ML models using familiar SQL. Automate data prep with built-in Gemini. Query 1 TB and store 10 GB free monthly.
    Start Free
  • 10
    restc-cpp C++ library

    restc-cpp C++ library

    Modern C++ REST Client library

    The magic that takes the pain out of accessing JSON API's from C++. It formulates a HTTP request to a REST API server. Then, it transforms the JSON formatted payload in the reply into a native C++ object (GET). It Serializes a native C++ object or a container of C++ objects into a JSON payload and sends it to the REST API server (POST, PUT). It formulates an HTTP request to the REST API without serializing any data in either direction (typically DELETE). It uploads a stream of data, like a...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 11
    JOSE JWT

    JOSE JWT

    Ultimate Javascript Object Signing and Encryption (JOSE)

    Minimalistic zero-dependency library for generating, decoding, and encryption JSON Web Tokens. Supports full suite of JSON Web Algorithms and Json Web Keys. JSON parsing agnostic can plug any desired JSON processing library. Extensively tested for compatibility with jose.4.j, Nimbus-JOSE-JWT, and json-jwt libraries. JWE JSON Serialization cross-tested with JWCrypto.
    Downloads: 16 This Week
    Last Update:
    See Project
  • 12
    react-jsonschema-form

    react-jsonschema-form

    A React component for building Web forms from JSON Schema

    A simple React component capable of using JSON Schema to declaratively build and customize web forms.
    Downloads: 12 This Week
    Last Update:
    See Project
  • 13
    JSON Editor

    JSON Editor

    A web-based tool to view, edit, format, and validate JSON

    JSON Editor is a web-based JSON editing and visualization tool designed for viewing, editing, formatting, validating, and transforming JSON documents in multiple interactive modes. The project provides several editing interfaces including tree view, code editor, form-based editing, and plain text modes, allowing users to work with structured data in the format most suitable for their workflow. It can be embedded directly into web applications as a reusable component and supports large JSON...
    Downloads: 28 This Week
    Last Update:
    See Project
  • 14
    Bebop

    Bebop

    No ceremony, just code. Blazing fast, typesafe binary serialization

    Bebop enables schema-based, typesafe, binary serialization and code generation. It is designed to be a good fit for client–server or distributed web apps that require a faster, more concise, and more typesafe alternative to JSON or MessagePack, while avoiding the complexity of Protocol Buffers, FlatBuffers, and similar solutions.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 15
    Airframe

    Airframe

    Essential Building Blocks for Scala

    Airframe is an essential building block for developing applications in Scala, including logging, object serialization using JSON or MessagePack, dependency injection, HTTP server/client with RPC support, functional testing with AirSpec, etc. Airframe RPC supports seamless integration of servers and clients using Scala as RPC interfaces. AirSpec is a simple unit testing framework for Scala and Scala.js. You can use public methods in your classes as test cases. There is no need to remember...
    Downloads: 17 This Week
    Last Update:
    See Project
  • 16
    Chronicle Wire

    Chronicle Wire

    Low Garbage Java Serialisation Library that supports multiple formats

    Chronicle Wire is a Wire Format abstraction library. Chronicle Wire uses Chronicle Bytes for bytes manipulation, and Chronicle Core for low-level JVM access. Configuration includes aliased type information. This supports easy extension by adding new classes/versions, and cross-platform using type aliasing. By supporting types, a configuration file can bootstrap itself. You control how the configuration file is decoded. See example Queue Enterprise config. To send the configuration of a...
    Downloads: 12 This Week
    Last Update:
    See Project
  • 17
    ChirpStack Gateway Bridge

    ChirpStack Gateway Bridge

    ChirpStack Gateway Bridge abstracts Packet Forwarder protocols

    ChirpStack Gateway Bridge is a service that converts LoRa® Packet Forwarder protocols into a ChirpStack common data format (JSON and Protobuf). This component is part of the ChirpStack open-source LoRaWAN® Network Server project.
    Downloads: 7 This Week
    Last Update:
    See Project
  • 18
    JWT

    JWT

    A simple library to work with JSON Web Token and JSON Web Signature

    lcobucci/jwt is a framework-agnostic PHP library that allows you to issue, parse, and validate JSON Web Tokens based on the RFC 7519. The package is available on Packagist, you can install it using Composer. A simple library to work with JSON Web Token and JSON Web Signature based on RFC 7519. Once the library has been installed, you are able to issue and parse JWTs. To reduce the chance of having flaky tests on your test suite, the facade supports the usage of a clock object. That allows...
    Downloads: 3 This Week
    Last Update:
    See Project
  • 19
    BSON parser

    BSON parser

    BSON Parser for node and browser

    BSON parser is the core JavaScript implementation of BSON (Binary JSON), the data format used by MongoDB to represent documents on the wire and in storage. It provides encoding and decoding capabilities so JavaScript environments like Node.js and browsers can serialize rich data structures (including types not native to JSON) into the compact, efficient BSON binary representation used by MongoDB drivers and servers. Value types such as ObjectId, Binary, UTC datetime, Decimal128, and Long are...
    Downloads: 8 This Week
    Last Update:
    See Project
  • 20
    Editor.js

    Editor.js

    A block-style editor with clean JSON output

    Editor.js is an open-source text editor offering a variety of features to help users create and format content efficiently. It has a modern, block-style interface that allows users to easily add and arrange different types of content, such as text, images, lists, quotes, etc. Each Block is provided via a separate plugin making Editor.js extremely flexible.
    Downloads: 28 This Week
    Last Update:
    See Project
  • 21
    JSON Hero

    JSON Hero

    JSON Hero is an open-source, beautiful JSON explorer for the web

    JSON Hero is a beautiful and powerful JSON viewer designed for developers who work with large and complex JSON files. It runs as a web-based interface (and as a standalone app) that provides semantic, interactive rendering of JSON content, helping users understand the structure and meaning of data at a glance. JSON Hero automatically detects data types such as URLs, dates, colors, and base64 images, and presents them in meaningful ways. It’s designed for productivity and readability, with...
    Downloads: 9 This Week
    Last Update:
    See Project
  • 22
    jsonista

    jsonista

    Clojure library for fast JSON encoding and decoding

    Clojure library for fast JSON encoding and decoding.
    Downloads: 10 This Week
    Last Update:
    See Project
  • 23
    svelte-jsoneditor

    svelte-jsoneditor

    Web-based tool to view, edit, format, repair, query, & transform JSON

    A web-based tool to view, edit, format, transform, and validate JSON. The library is written with Svelte, but can be used in plain JavaScript too, and in any framework (SolidJS, React, Vue, Angular, etc). View and edit JSON, has a low-level text editor and high-level tree view and table view. Format (beautify) and compact JSON. Sort, query, filter, and transform JSON. JSON schema validation and pluggable custom validation. Color highlighting, undo/redo, search and replace. Utilities like a...
    Downloads: 16 This Week
    Last Update:
    See Project
  • 24
    Hateoas

    Hateoas

    A PHP library to support implementing representations

    A PHP library to support implementing representations for HATEOAS REST web services.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 25
    Java JWT JSON

    Java JWT JSON

    Java JWT: JSON Web Token for Java and Android

    JJWT aims to be the easiest-to-use and understand library for creating and verifying JSON Web Tokens (JWTs) and JSON Web Keys (JWKs) on the JVM and Android. JJWT is a pure Java implementation based exclusively on the JOSE Working Group RFC specifications.
    Downloads: 3 This Week
    Last Update:
    See Project