General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.
Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
Start Free
$300 Free Credits to Build on Google Cloud
New customers can spin up VMs, build with AI, and query data at no cost.
Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
A Java based Rent Software for everything that has to come back.
A Java based Rent Software for everything that has to come back.
With all-built-in Client-Server Architecture using local H2 or external MySQL as Database.
The Client can run as Client+Server+Database, as Server+Database or simply as bare Client, connected through serialized Apache Mina Socket Connection to any Rentit Server+Database or Client+Server+Database.
SimpleHTTPDB is a client based key-value database that allows for storing data on any http-server via FTP. This way, no server-based functionality is required. Security of the data is provided by high-level encryption.
Implementation of an open source FTP Server which comply with RFC 959, RFC 2228, RFC 2389 and RFC 2428. Implemented in Java. This server can be run as a stand alone FTP server and can be easily embedded in any java project. Please visit our project h
A file splitter made in java to split and join files very quickly for easier transfer over the internet. Has option to delete parts one by one while joining/splitting. Supports joining .001, .002 parts as well. Just double click to join the files..
Java program that creates an SMTP message and sends it off. It can be used to test SMTP functionality as well as security. This test SMTP at the application level. Requires Java 6.
A distributed FTP daemon written in java. Instead of conventional server<->client transfer it uses master<->client for control connections and slave<->client for (most) data transfers, the master must tell the slave to initiate/respond to a transfer
Antrunner4e is an eclipse-plugin that inserts a contextmenue item to start a antfile with the current file or directoryname as input.This provides an easy way to execute actions like compiling the current file, transfer by ftp, execute sql and so on.
World of Warcraft player account synchronization and backup. This will save your WTF/Account files and not the interface directory. Using JSCH for secure file transfer.
JFtpSync is for uploading web content to a server via FTP. It is designed to do FTP uploading only, and do it well, offering recursive uploading of content filtered by file type. It is primarily a command-line tool but there is a Java GUI as well.
FONC (FTP Over Normal Connections) allows both active and passive FTP transfers via normal port connections. This allows FTP (both control and data transfers) over simple ssh tunnels among other things. FONC is easy to setup, and runs anywhere java can.
XSP is an eXtensible socket-based protocol. XSP 1.0 is an XSP client. The main idea of this project is to connect two devices directly without any servers between them. Chat, file sharing and voice chat are supported now. Authors: m1kc and Solkin.
Azureus 7(Cayenne) is a BitTorrent client, used to transfer files via the P2P protocol. Cayenne is written in Java and based on Vuze/Azureus client . Cayenne contains completely redesigned lightweight UI, speed and functionality optimizations.
This project provides useful tools/plugins for simplifying the development with Eclipse. Our first tool is a log file viewer plugin for Eclipse that reads JavaUtil JDK logs from socket or file. Multiple logs can be viewed at the same time.
cuBnc is a multisite bnc for ftp servers. It allows you to have multiple slave-servers connected to one master. When you enter the master via normal ftp, you see the slaves as dirs. When you enter such a dir, you become logged in to the site.
XSP is an eXtensible socket-based protocol. XSP PDA is a mobile version of XSP 1.0. The main idea of this project is to connect two devices directly without any servers between them. Chat and file sharing are supported now. Authors: m1kc and Solkin.
Deliver is a file transfer protocol and implementation designed to be a safe, open-source alternative to the most extended transfer protocols like the traditional e-mail.
JavaEmailer is a Java Classes Library that allows Java developers to easily integrate a mass mailer to their applications. JavaEmailer manages file attachments, SMTP servers, CCs, BCCs, plain text and/or html messages, and more...
This is a software to access and download your files on a remote sytem to your own machine (over the internet) with Java for cross-compatibility. Works perfectly to browse and copy files, directories on a computer behind a proxy (eg: at your office).
GiraffeFTP is a Java based FTP client and server. It includes GUI and command line tools. Good code to see to understand the FTP Protocol and sockets. Also includes a non-standard implementation of SSL sockets.
Backup & restore contacts, calendar and to-do’s on your phone
Changing phone? Or just feeling better with important data backed up? Transfer your contacts, calendar and to-do’s or make a backup and restore it later, all that using small Java ME app with Polish and English interface.