Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.
Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
Try it Free
Ship Agents Faster
Transform your applications and workflows into powerful agentic systems at global scale.
Gemini Enterprise Agent Platform lets you rapidly build, scale, govern and optimize production-ready agents grounded in your organization's data. The platform enables developers to build custom or pre-built agents for virtually any use case. New customers get $300 in free credits.
CoDec is a Java package for encoding and decoding ASN.1 data structures. CoDec supports the Basic Encoding Rules (BER) as well as the Distinguished Encoding Rules (DER) and provides a library with data structures for many cryptographic standards.
Data types and utility classes for use with evolutionary algorithms.
EZvolve Foundation Classes is a set of data types and utility classes for use with evolutionary algorithms. Currently implemented support for bit string encoding, populations, fitnesses, fitness functions, probabilities, and probability vectors.
JavaEmailer is a Java Classes Library that allows Java developers to easily integrate a mass mailer to their applications. JavaEmailer manages file attachments, SMTP servers, CCs, BCCs, plain text and/or html messages, and more...
Java classes that enable definition of new Charsets based on other existing Charsets, without additional programming. Includes a character set with Kamenik encoding.
This simple Java applet will use a few URL obfuscation methods to mask a URL. This isn't meant to be anything earth shattering, but maybe useful. It does more than basic URL encoding (although it does that). Also contains a library to do it all.
This program aims at providing a java solution to hide secret information(such as secret file) to JPEG images. Hiding algorithm contains Jsteg and F5. The main(probably the toughest) stuff is encoding and decoding JFIF files.
Small and simple java library for working with Jasper Reports dynamically, enabling dynamic column creation and dynamic data sets using Apache DynaBeans. Project is developed by people at small software company called Softberries www.softberries.com
IvmaiAsn ASN1/ECN/XDR Tools. A collection of the ASN.1/ECN parser, XDR-to-ASN.1 converter and pretty-printer scripts for ASN.1/ECN specifications. Contains also a formal definition of the ASN.1 built-in types, ECN encoding classes and XDR encodings.
Charset implementation adding encoding and decoding support for UTF-7 (as in RFC 2152, in two variants) and modified UTF-7 (RFC 3501) to Java. The two variants of UTF-7 supported differ in the encoding chosen for Set O (optional direct characters).
Http FX is a HTTP request mockup tool developed in JavaFX. It can make a HTTP request to a location with request parameters, HTTP authentication. It supports GET, POST, PUT and DELETE operation, and you can specify the encoding for sending data.
This software provides library to encode/decode Java strings to/from Base64 encoding and variants. Just include the .jar file into your classpath, to encode: string.getbytes("x-base64"); to decode: new String(bytearray, "x-base64");
RTP text/t140 Library is a reference implementation for RTP Payload Type for Text Conversation (RFC 4103). The library has source code for encoding and decoding RFC 4103 data, and may be used either as a plug-in to JMF or in a separate RTP sender/receive
DataScript Tools for formal specification and automatic decoding of binary data formats. NOTE: This project has moved to http://developer.berlios.de/projects/datascript/.
This project aims to produce an efficient Java library for decoding and encoding the SMS binary format as defined in 3GPP TS 23.040. This project has moved to http://attention.googlecode.com/
SandR is a Recursive Regex Search and Replacement utility. It works on files or directories recursively. It supports Java-style Regular Expression in Search terms; it supports auto-detection of character encoding of the files. SandR is written in Java.
Eclipse Plugin for tailing logfiles, including syntax coloring. It allows you to have multiple files open concurrently. and all files have a predefined syntax coloring applied. The plugin offers to set the backlog and encoding for each file.
Utility library for Java, including Boyer-Moore search, hex, base32 and base64 coders with user-defined alphabets, variable-length int and long encoding.
basE91 is an advanced method for encoding binary data as ASCII characters. It is similar to UUencode or base64, but is more efficient. The overhead produced by basE91 depends on the input data. It amounts at most to 23% and can range down to 14%.
Java framework to simplify LDAP operations, based on the pattern of Spring's JdbcTemplate. Relieves the users of the burden of looking up and closing contexts, looping through NamingEnumerations, encoding/decoding values and filters, and more.
XML Universal Packet Archiver (PKT) is a platform independant universal file archiving system with pluggable options for encryption, encoding, compression, parity/RAID protection and more.