Deploy in 115+ regions with the modern database for every enterprise.
MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
Start Free
Save Up to 91% on Cloud Compute With Spot VMs
Automatic sustained-use discounts. One free VM per month. No negotiation needed.
Run batch jobs at 60-91% off with Spot VMs. Long-running workloads get automatic discounts with sustained use.
Ajax Data Objects (ajaxdo) provides an easy database persistency framework for JavaScript objects. Ajaxdo enables runtime loading, saving, deleting, and listing of JavaScript objects stored on the server database.
WorkingCode gives you what the name says working pieces of codes in Java. We are talking about code snippets and full utility apps for Java and J2me. It's use is intended as a library.
Hermes FTP Server is a free, cross-platform FTP server adhering to RFC 959, RFC 2228, and RFC 2389. It is being developed in Java with a strong focus on security and extensibility.
Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.
Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
JSONator is a java based product that allows the serialization and de-serialization of java objects to and from JSON. The website http://json.sourceforge.net/ has detailed information.
geoLucene is an extension of Lucene that allows to effectively index and search documents that contain locational information (longitude/latitude). It uses R-tree as a spacial index. See http://www.gossamer-threads.com/lists/lucene/java-dev/53378.
BloggerTools provides useful functions, accessible via the command line,to manage your Blogs in Blogger.The main tool available is the importation of posts from one blog to another. More information: http://bruno-wp.blogspot.com/2007/10/bloggertools.html
Smart Memo System (SMS) is simple memo and notes management system which includes some community functionality such as access rights. A smart memo object consists of a text, an author, a title, a change date, an access policy.
The Kharthick Review And Posting System (codename: Duckstein) will be a fully-featured, cutting-edge product review management system, built with proven web technologies including Spring, Tapestry, and Hibernate.
TXS provides a basic HTTP server. Its own XML Script language can produce, via XSL-T, XForms or XHTML pages (tested with FireFox). It can also be used to read and generate CSV, XML or ZIP files. HTML page capture and email generation also available.
hypKNOWsys aims at developing a Java-based workbench for knowledge discovery and knowledge management. Currently, hypKNOWsys has released two intermediate tools: DIAsDEM Workbench (text mining for semantic tagging) and WUMprep (Web mining pre-processing)
e-government web interface targets the public sector for serving the governmental activities , this is a fast solution till the egov os is released (sourceforge.net/projects/egovsh)
STGC is a browser-based game set in the Star Trek (tm) universe which has been developed over three years and now finally has gone open-source. For support please visit the homepage of this project.
The Internet Protocol Address Calculator is an open-source java-based tool. This calculator will assist network administrators to perform calculations over both IPv4 and IPv6 address space. A handy whois search client is also integrated into this tool.
VC² is a tool that integrates with off-the-shelf version control systems and monitors file system access in order to enhance awareness among users. The tool warns about actions made by other users and suggests conflict avoiding actions.
MillScript is a full featured, yet easy to use language for the batch production of templated Web sites. The language is a Java-based, early implementation of Spice: an experimental language developed by the OpenSpice group.
JSerWeb is a flexible HTTP/1.1 compliant Java Web Server. JSerWeb supports
the use of Perl and PHP scripts. These are very popular scripting tool for
extending web servers because they are extremely flexible and easy to learn.
ThinWire is an Ajax RIA framework for building zero footprint Ajax browser applications that feel like desktop GUI applications. Program Ajax on the server, using an event driven GUI model that reconnects program logic. All Major Ajax Browsers Supported!
CMS is built based on the SOA design principle and it offers a nice looking web UI and a simple web service interface. It utilizes maven2, struts2, axis2, jboss, ejb3 and many other java technologies and tools.
A client-server based reservation tool written in java. The server part relys on mysql. The rooms can be designed using a wysiwyg editor. Applications range from cinema seat reservations to restaurant table reservations. Room is an applet wich loads