Showing 1904 open source projects for "simple http server"

View related business solutions
  • Veeam Data Platform v13.1 - Get Your Free Trial Icon
    Veeam Data Platform v13.1 - Get Your Free Trial

    Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try it Free
  • $300 Free Credits to Build on Google Cloud Icon
    $300 Free Credits to Build on Google Cloud

    New customers can spin up VMs, build with AI, and query data at no cost.

    Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
    Start Free
  • 1
    myrtille

    myrtille

    A native HTML4 / HTML5 Remote Desktop Protocol client

    Myrtille is a simple way to connect remote desktops and applications from a native web browser, without plugin, extension or configuration. For the end user, there is just need for a browser. Server side, it uses the .NET (C#) framework and the RDP protocol through an HTTP(S) gateway. It's very comparable to Guacamole (https://github.com/glyptodon) or FreeRDP-WebConnect (https://github.com/FreeRDP/FreeRDP-WebConnect), except it uses the Microsoft .NET (C#) technologies for a better integration with the Remote Desktop Services (RDS) layer. ...
    Downloads: 13 This Week
    Last Update:
    See Project
  • 2
    Ziproxy is forwarding HTTP proxy server aimed to speed up low-bandwidth connections. It does so by gzipping HTML and using lossy compression of GIF, PNG and JPEG pictures. Ziproxy also offers JPEG 2000 support, transparent proxying and more.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 3
    nostr

    nostr

    A truly censorship-resistant alternative to Twitter

    ...To get updates from other people, you ask multiple relays if they know anything about these other people. Anyone can run a relay. A relay is very simple and dumb. It does nothing besides accepting posts from some people and forwarding to others. Relays don't have to be trusted. Signatures are verified on the client side.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4
    N2O

    N2O

    Distributed WebSocket Application Server ISO 20922

    N2O is an embeddable message protocol loop library for WebSocket, HTTP, MQTT and TCP servers. It provides basic features, such as process management, virtual nodes ring for request processing, sessions, frame encoding, and unified API for external mq and caching services.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • 5
    ProxyKit

    ProxyKit

    A toolkit to create code-first HTTP reverse proxies on ASP.NET Core

    A toolkit to create code-first HTTP Reverse Proxies hosted in ASP.NET Core as middleware. This allows focused code-first proxies that can be embedded in existing ASP.NET Core applications or deployed as a standalone server. Deployable anywhere ASP.NET Core is deployable such as Windows, Linux, Containers and Serverless (with caveats). Having built proxies many times before, I felt it is time to make a package.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    Swifter

    Swifter

    Tiny http server engine written in Swift programming language

    Tiny http server engine written in Swift programming language. Lands on CocoaPods and others. Supports the latest non-beta Xcode and SPM. Stable. Stable branch plus experimental web-framework layer. Next version of Swifter (async IO).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    sWAF

    sWAF

    A simple Web Application Firewall docker image

    sWAF is a simple Web Application Firewall docker image, pre-configured to be easily used within your web services architecture. It runs NGINX as a dedicated reverse proxy embedding powerful WAF engines: ModSecurity 3, using OWASP® ModSecurity Core Rule Set (CRS) rules, and NAXSI. It uses acme.sh for Let's Encrypt and other free CA support. A lot of people are self-hosting their own cloud infrastructure (using Nextcloud, Synology, QNAP, a cloud lease server or home-made solutions...), but we can never be too much paranoid about web security for a lot of good reasons. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    IZ-WAMP

    IZ-WAMP

    Easily install WAMP Server with Wordpress and more.

    IZ-WAMP is a WAMP package combining the latest stable versions of Windows x64, Apache, MySQL and PHP. In addition, IZ-WAMP embeds the latest version of differents CMS. In this way, you can manage your site on your local machine and offline without a network connection. A good way to work on improvements and a redesign of the site securely before switching it online. Once IZ-WAMP installed on your PC, note the appearance of a drop-down menu accessible from the system tray. Among the...
    Leader badge
    Downloads: 2 This Week
    Last Update:
    See Project
  • 9
    DigiOz .NET Portal

    DigiOz .NET Portal

    ASP.NET MVC Based Portal CMS System to Create an Instant Website

    DigiOz .NET Portal is a FREE web based portal CMS system written in ASP.NET MVC 5 in C# which uses a Microsoft SQL Database to allows webmasters to setup and customize an instant website for either business or personal use. List of Technologies used: - ASP.NET MVC 5 - Microsoft SQL Server - Bootstrap - HTML 5 - jQuery Demo Site: http://digioznetportal.digioz.net/ Source Code: https://sourceforge.net/p/digioznetportal/codenew/ci/master/tree/ Installation Instructions: https://sourceforge.net/p/digioznetportal/wiki/Home/ Help Wanted: If you are a developer, and wish to join the project, please email us at support@digioz.com.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Cut Data Warehouse Costs by 54% Icon
    Cut Data Warehouse Costs by 54%

    Easily migrate from Snowflake, Redshift, or Databricks with free tools.

    BigQuery delivers 54% lower TCO with exabyte scale and flexible pricing. Free migration tools handle the SQL translation automatically.
    Start Free
  • 10

    simple-multicast

    A simple Multicast server and client app

    Project moved to GitHub
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    Mocky.io Lockdown Edition

    Mocky.io Lockdown Edition

    Generate custom HTTP responses, the simpler way to test your services

    Generate custom HTTP responses, the simpler way to test your web services. Mocky is a simple app that allows to generate custom HTTP responses. It's helpful when you have to request a build-in-progress WS, when you want to mock the backend response in a single app, or when you want to test your WS client. Don't wait for the backend to be ready, generate custom API responses with Mocky and start working on your application straight away.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    MailHog

    MailHog

    Web and API based SMTP testing

    Inspired by MailCatcher, easier to install. Built with Go, MailHog runs without installation on multiple platforms. Run it from Docker Hub or using the provided Dockerfile. The SMTP server starts on port 1025, the HTTP server starts on port 8025, in-memory message storage. ESMTP server implementing RFC5321. Support for SMTP AUTH (RFC4954) and PIPELINING (RFC2920). Web interface to view messages (plain text, HTML or source). Supports RFC2047 encoded headers. Real-time updates using EventSource. Release messages to real SMTP servers. ...
    Downloads: 46 This Week
    Last Update:
    See Project
  • 13
    Koa2 & Next.js hydration packages

    Koa2 & Next.js hydration packages

    A koa middleware for next.js with some common tools

    Koa2 & Next.js hydration packages. Firstly set up a koa server entry, then write your own next.js pages.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    Java_console

    Java_console

    Java console is used for managing files, directories, URLs, DBMSes.

    This command-line interface has been written in Java 7+. The datasheet is available at http://debian.nostalgy.net.ru/Java_console/.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 15

    Proxy Checker

    A programm to check HTTP, HTTPS, SOCKS4 and SOCKS5 proxy servers.

    Requirements: .NET Framework 4.6.1 or higher.
    Downloads: 7 This Week
    Last Update:
    See Project
  • 16

    PHP mini vulnerability suite

    Multiple server/webapp vulnerability scanner

    github: https://github.com/samedog/phpmvs
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    jfProxy

    jfProxy

    Proxy Server

    Proxy Server. Supports http, https, allow IP list, block domains.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    ssh-chat

    ssh-chat

    Chat over SSH

    ssh-chat is a custom SSH server written in Go that allows you to chat over SSH connection. When you open your terminal and type in a command, instead of getting a shell you get a chat prompt. With ssh-chat you get a simple chat room over a secure shell connection, where you can send and receive private messages, check any user's public key fingerprint for identification purposes, and more.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    RESTBolt

    RESTBolt

    Browser WebExtension to work on http(s) requests

    ## Inspired by POSTMAN browser extension Add-on is based on [RESTMan](https://github.com/jsargiot/restman) Opera extension --- #### Note - Use a simple HTTP Request & Response Service to test WebExtension
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20

    tamacat-httpd

    Java HTTP Server / Reverse Proxy

    [Moved] https://github.com/tamacat-1-4 The tamacat-httpd is a open source Java Web Server software, powered by Apache HttpComponents. This is a customizable HTTP/HTTPS Server framework and Reverse Proxy.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    Log.io

    Log.io

    Real-time log monitoring in your browser

    Inputs watch log files for changes, send new log messages to the server, which broadcasts to web clients. Log messages are tagged with stream and source information based on user configuration. log.io has no persistence layer. File inputs are informed of file changes via inotify, and log messages hop from input to server to web client via TCP and socket.io, respectively. log.io uses a stateless TCP API to receive log messages. Writing a third party harvester is easy. Open a TCP connection to...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    Performance Timing Test

    Performance Timing Test

    Get accurate performance timing for any page with this add-on Firefox

    Measures the timing performance of any web page using Web APIs. You can immediately save the chart test result within your file system for a comparison with other subsequent tests. Get Opera extension: http://bit.ly/1O9OvRx Get Firefox extension: http://mzl.la/1Vs0UV2 == Installation == 1. Click on download directly from your Firefox browser and install add-on 2. Then click on the icon of the extension included in toolbar to start test
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    SolucWebServer

    SolucWebServer

    Simple HTTP Web Server

    Simple HTTP Web Server - Host the files in the same folder as the application.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    EZ DDNS Client

    EZ DDNS Client

    Dynamic DNS updater client for ddns service from dnsexit (and others).

    A set of 'ddns client' support scripts for using a dynamic IP (via DHCP) to run a server. It is designed to be used with the DDNS service from: http://www.dnsexit.com/ but could be adapted for any DDNS service that uses a URL to perform DNS updates.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    GCDWebServer

    GCDWebServer

    The #1 HTTP server for iOS, macOS & tvOS

    GCDWebServer is a modern and lightweight GCD based HTTP 1.1 server designed to be embedded in iOS, macOS & tvOS apps. Elegant and easy to use architecture with only 4 core classes: server, connection, request and response. Well designed API with fully documented headers for easy integration and customization. Entirely built with an event-driven design using Grand Central Dispatch for best performance and concurrency.
    Downloads: 0 This Week
    Last Update:
    See Project