Showing 6740 open source projects for "linux scanner software"

View related business solutions
  • Veeam Data Platform v13.1 - Get Your Free Trial Icon
    Veeam Data Platform v13.1 - Get Your Free Trial

    Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try it Free
  • $300 Free Credits to Build on Google Cloud Icon
    $300 Free Credits to Build on Google Cloud

    New customers can spin up VMs, build with AI, and query data at no cost.

    Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
    Start Free
  • 1
    rtlamr

    rtlamr

    An rtl-sdr receiver for Itron ERT compatible smart meters

    Utilities often use "smart meters" to optimize their residential meter reading infrastructure. Smart meters transmit consumption information in the various ISM bands allowing utilities to simply send readers driving through neighborhoods to collect commodity consumption information. One protocol in particular: Encoder Receiver Transmitter by Itron is fairly straightforward to decode and operates in the 900MHz ISM band, well within the tunable range of inexpensive rtl-sdr dongles. This...
    Downloads: 11 This Week
    Last Update:
    See Project
  • 2
    Nuxt

    Nuxt

    The Intuitive Vue Framework

    Nuxt is a free, open‑source framework built on Vue.js that streamlines the development of type‑safe, high-performance full‑stack web applications and static sites, with an emphasis on developer experience, modularity, and extensibility. Simple, intuitive and powerful, Nuxt lets you write Vue components in a way that makes sense. Every repetitive task is automated, so you can focus on writing your full-stack Vue application with confidence. We highly recommend you take a look at the Nuxt...
    Downloads: 16 This Week
    Last Update:
    See Project
  • 3
    grammY

    grammY

    The Telegram Bot Framework

    grammY makes it easy to create Telegram bots. Both for beginners and at scale. You want grammY because it is easy to use. It is very powerful and always up to date. It has the best documentation in town. It is extremely efficient and scales up effortlessly. It has a thriving ecosystem of plugins, a friendly community chat, seamless integrations with web frameworks and databases, and so much more.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 4
    Laravel Sharp

    Laravel Sharp

    Laravel 10+ Content management framework

    Sharp is a content management framework, a toolset that provides help to build a CMS section in a website, with some rules in mind. The public website should not have any knowledge of the CMS, the CMS is a part of the system, not the center of it. In fact, removing the CMS should not have any effect on the project. Content administrators should work with their data and terminology, not CMS terms. I mean, if the project is about spaceships, space travels, and pilots, why would the CMS talk...
    Downloads: 24 This Week
    Last Update:
    See Project
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • 5
    Keploy

    Keploy

    Testing for Developers. Toolkit that creates test-cases and data mocks

    Keploy is a functional testing toolkit for developers. It generates E2E tests for APIs (KTests) along with mocks or stubs(KMocks) by recording real API calls. KTests can be imported as mocks for consumers and vice-versa. Merge KTests with unit testing libraries(like Go-Test, JUnit..) to track combined test coverage. KMocks can also be referenced in existing tests or use anywhere (including any testing framework). KMocks can also be used as tests for the server. Keploy is added as a...
    Downloads: 7 This Week
    Last Update:
    See Project
  • 6
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 15 This Week
    Last Update:
    See Project
  • 7
    APKUpdater

    APKUpdater

    Simplify the process of finding updates for your installed apps

    APKUpdater is an open source tool that simplifies the process of finding updates for your installed apps. It provides similar functionality to an app store, but instead of depending on a single source, it aggregates the results from APKMirror, Aptoide, F-Droid and Google Play. Schedule background update checks and receive a notification when updates are found. Supports Android 4.0.3 to Android 10. Supports Android TV. Material Design 2 with multiple theme support. Direct install of updates...
    Downloads: 28 This Week
    Last Update:
    See Project
  • 8
    koa-helmet

    koa-helmet

    Important security headers for koa

    koa-helmet is a wrapper for helmet to work with koa. It provides important security headers to make your app more secure by default.
    Downloads: 7 This Week
    Last Update:
    See Project
  • 9
    Air Go

    Air Go

    Live reload for Go apps

    When I get started with developing websites in Go and gin framework, it's a pity that gin lacks live-reloading function. In fact, I tried fresh and it seems not much flexible, so I intended to rewrite it in a better way. Air is yet another live-reloading command line utility for Go applications in development. Just air in your project root directory, leave it alone, and focus on your code. For less typing, you could add alias air='~/.air' to your .bashrc or .zshrc. You can pass arguments for...
    Downloads: 18 This Week
    Last Update:
    See Project
  • Build Securely on Azure with Proven Frameworks Icon
    Build Securely on Azure with Proven Frameworks

    Lay a foundation for success with Tested Reference Architectures developed by Fortinet’s experts. Learn more in this white paper.

    Moving to the cloud brings new challenges. How can you manage a larger attack surface while ensuring great network performance? Turn to Fortinet’s Tested Reference Architectures, blueprints for designing and securing cloud environments built by cybersecurity experts. Learn more and explore use cases in this white paper.
    Download Now
  • 10
    reko

    reko

    Reko is a binary decompiler

    Reko (Swedish: "decent, obliging") is a decompiler for machine code binaries. This project is freely available under the GNU General Public License. The project consists of front ends, core decompiler engine, and back ends to help it achieve its goals. A command line, a Windows GUI, and a ASP.NET front end exist at the time of writing. The decompiler engine receives inputs from the front ends in the form of either individual executable files or decompiler project files. Reko project files...
    Downloads: 15 This Week
    Last Update:
    See Project
  • 11
    Leptos

    Leptos

    Build fast web applications with Rust

    Leptos is a full‑stack Rust framework for building web apps that supports client-only SPAs, SSR/MPR rendered on the server, and hydrated progressive apps. It offers fine‑grained reactivity, server functions, and cohesive front‑end/backend code using shared Rust abstractions.
    Downloads: 13 This Week
    Last Update:
    See Project
  • 12
    serverless-express

    serverless-express

    Run Express and other Node.js frameworks on AWS Serverless

    Serverless Express is a framework for deploying Express.js applications on AWS Lambda and other serverless environments, enabling efficient, scalable web applications without managing infrastructure.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 13
    XIU2/CloudflareSpeedTest

    XIU2/CloudflareSpeedTest

    "Preferred IP" Test Cloudflare CDN latency and speed

    "Preferred IP" Test Cloudflare CDN latency and speed, get the fastest IP (IPv4 / IPv6)! In addition, other CDN / website IPs are also supported. Many foreign websites are using Cloudflare CDN, but the IPs assigned to visitors from mainland China are not friendly (high latency, high packet loss, and slow speed). Although Cloudflare discloses all IP segments , it would be exhausting to find the one that suits you among so many IPs, so this software came into existence. After the speed...
    Downloads: 15 This Week
    Last Update:
    See Project
  • 14
    NVIDIA Warp

    NVIDIA Warp

    A Python framework for accelerated simulation, data generation

    NVIDIA Warp is a high-performance Python framework developed by NVIDIA for building and accelerating simulation, graphics, and physics-based workloads using GPU computing. It enables developers to write kernel-level code in Python that is automatically compiled into efficient CUDA kernels, combining ease of use with near-native performance. The framework is designed for applications such as robotics, reinforcement learning, physical simulation, and differentiable computing, where performance...
    Downloads: 19 This Week
    Last Update:
    See Project
  • 15
    MinIO Client Quickstart Guide

    MinIO Client Quickstart Guide

    Fast tool to manage MinIO clusters

    MinIO Client (mc) provides a modern alternative to UNIX commands like ls, cat, cp, mirror, diff, find etc. It supports filesystems and Amazon S3-compatible cloud storage service (AWS Signature v2 and v4). MinIO is distributed under GNU AGPLv3. See the source tree for complete information on all components of the work and their licenses. MinIO is a high-performance object storage solution that provides an Amazon Web Services S3-compatible API and supports all core S3 features. MinIO is built...
    Downloads: 27 This Week
    Last Update:
    See Project
  • 16
    Criterion

    Criterion

    A cross-platform C and C++ unit testing framework for the 21st century

    Most test frameworks for C require a lot of boilerplate code to set up tests and test suites -- you need to create a main, then register new test suites, then register the tests within these suites, and finally call the right functions. This gives the user great control, at the unfortunate cost of simplicity. Criterion follows the KISS principle, while keeping the control the user would have with other frameworks. Supports parameterized tests and theories. Progress and statistics can be...
    Downloads: 6 This Week
    Last Update:
    See Project
  • 17
    Laravel Envoy

    Laravel Envoy

    Elegant SSH tasks for PHP

    Laravel Envoy is a tool for executing common tasks you run on your remote servers. Using Blade-style syntax, you can easily set up tasks for deployment, Artisan commands, and more. Currently, Envoy only supports the Mac and Linux operating systems. However, Windows support is achievable using WSL2.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 18
    graphql upload typescript

    graphql upload typescript

    Middleware and an Upload scalar to add support for GraphQL

    Minimalistic and developer-friendly middleware and an Upload scalar to add support for GraphQL multipart requests (file uploads via queries and mutations) to various Node.js GraphQL servers. This module was forked from the amazing graphql-upload-minimal. The original module is exceptionally well-documented and well-written. It was very easy to fork and amend.
    Downloads: 10 This Week
    Last Update:
    See Project
  • 19
    gopsutil

    gopsutil

    psutil for golang

    gopsutil tag policy is almost same as Semantic Versioning but automatically increases like Ubuntu versioning. gopsutil aims to keep backward compatibility until a major version change. Tagged at the end of the month, but if there are only a few commits, it can be skipped. All works are implemented without cgo by porting C structs to golang structs.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 20
    Android Runtime for NativeScript

    Android Runtime for NativeScript

    NativeScript for Android using v8

    Contains the source code for the NativeScript's Android Runtime. NativeScript is a framework that enables developers to write truly native mobile applications for Android and iOS using JavaScript and CSS. Each mobile platform has its own ecosystem and offers completely different development tools and language(s) - Java for Android and Objective C (Swift) for iOS. In order to translate JavaScript code to the corresponding native APIs some kind of proxy mechanism is needed. This is exactly...
    Downloads: 11 This Week
    Last Update:
    See Project
  • 21
    sftp

    sftp

    SFTP support for the go.crypto/ssh package

    The sftp package provides support for file system operations on remote ssh servers using the SFTP subsystem. It also implements an SFTP server for serving files from the filesystem. The basic operation of the package mirrors the facilities of the os package. The Walker interface for directory traversal is heavily inspired by Keith Rarick's fs package.
    Downloads: 11 This Week
    Last Update:
    See Project
  • 22
    Dockle

    Dockle

    Container Image Linter for Security

    Container Image Linter for Security, Helping build the Best-Practice Docker Image, Easy to start. You can install dockle with the asdf version manager with this plugin, which automates the process of installing (and switching between) various versions of github release binaries. With asdf already installed, run commands to install dockle. You can scan your built image with Dockle in Travis CI/CircleCI. Though, you can ignore the specified target checkpoints by using .dockleignore file. Or,...
    Downloads: 8 This Week
    Last Update:
    See Project
  • 23
    Thanos

    Thanos

    Highly available Prometheus setup with long term storage capabilities

    Open source, highly available Prometheus setup with long-term storage capabilities. Scale your Prometheus setup by enabling querying of your Prometheus metrics across multiple Prometheus servers and clusters. Extend the system with the object storage of your choice to store your metrics for an unlimited time. Supports GCP, S3, Azure, Swift and Tencent COS. Use the same tools you love, such as Grafana and others, that support the Prometheus Query API. Downsample historical data for massive...
    Downloads: 22 This Week
    Last Update:
    See Project
  • 24
    Django-CRM

    Django-CRM

    Open Source CRM based on Django

    Django CRM is opensource CRM developed on django framework. It has all the basic features of CRM to start with. We welcome code contributions and feature requests via github. Create and activate a virtual environment. Install the project's dependency after activating env.
    Downloads: 7 This Week
    Last Update:
    See Project
  • 25
    NeuroSploit

    NeuroSploit

    NeuroSploit is an advanced, AI-powered penetration testing framework

    NeuroSploit is a Rust-based autonomous penetration-testing framework that coordinates multiple AI models for authorized security assessments. It accepts targets such as URLs, source repositories, applications, hosts, and infrastructure environments. The system performs reconnaissance, selects specialized agents for the discovered attack surface, and runs applicable assessments in parallel. Candidate findings are checked through cross-model validation and supporting tool evidence before being...
    Downloads: 18 This Week
    Last Update:
    See Project