Showing 513 open source projects for "ppt web development"

View related business solutions
  • Fully Managed MySQL, PostgreSQL, and SQL Server Icon
    Fully Managed MySQL, PostgreSQL, and SQL Server

    Automatic backups, patching, replication, and failover. Focus on your app, not your database.

    Cloud SQL handles your database ops end to end, so you can focus on your app.
    Start Free
  • Veeam Data Platform v13.1 - Get Your Free Trial Icon
    Veeam Data Platform v13.1 - Get Your Free Trial

    Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try it Free
  • 1
    Bootstrap

    Bootstrap

    HTML, CSS and JS framework for developing responsive websites and apps

    Bootstrap is an HTML, CSS, and JS framework designed for developing responsive, mobile first projects on the web. It's one of the most popular front-end frameworks and for good reason: it simply makes web development faster and easier. People of all skill levels can create projects of all sizes with Bootstrap, and for all types of devices too. With Bootstrap, you get a host of nifty features such as precompiled CSS, impressive scalability, dozens of custom HTML and CSS components and more.
    Downloads: 35 This Week
    Last Update:
    See Project
  • 2
    Gatsby

    Gatsby

    Build blazing fast, modern apps and websites with React

    Gatsby is a free and open source web framework based on React that allows you to build blazing fast websites and apps. It offers the latest web technologies, such as React.js, Webpack, modern JavaScript, CSS and more to help you build really fast websites. A Progressive Web App generator, it’s fast in every way that matters.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 3
    Bedrock

    Bedrock

    WordPress boilerplate with modern development tools

    WordPress boilerplate with modern development tools, easier configuration, and an improved folder structure. Bedrock is an open source project and completely free to use. Bedrock is a modern WordPress stack that helps you get started with the best development tools and project structure. Much of the philosophy behind Bedrock is inspired by the Twelve-Factor App methodology including the WordPress specific version. Bedrock is multisite network compatible, but needs the...
    Downloads: 13 This Week
    Last Update:
    See Project
  • 4
    Docker Compose

    Docker Compose

    Define and run multi-container applications with Docker

    Docker Compose is an open source tool for defining and running multi-container applications with Docker. Compose lets you use a YAML file to configure your application’s services, and then create and start all the services from your configuration with just a single command. Compose works great in all environments: production, staging, testing, development, and on CI workflows. Compose has commands for every stage of your application lifecycle, from starting, stopping and rebuilding services,...
    Downloads: 197 This Week
    Last Update:
    See Project
  • Paessler: Easy to Use With Enterprise Power. Free Trial Icon
    Paessler: Easy to Use With Enterprise Power. Free Trial

    A low-code dashboard makes monitoring intuitive for any admin, while scripting and custom sensors give experts full control.

    You shouldn't have to choose between a monitoring tool that's easy to use and one that's powerful enough for a complex environment. PRTG's low-code interface lets any admin build dashboards, set alerts and monitor devices without scripting, while custom sensors and full API access are there when your team needs deeper control. One platform, no compromise. Download a free 30-day trial now.
    Get Free Download
  • 5
    phantomas

    phantomas

    Headless Chromium-based web performance metrics collector

    Headless Chromium-based modular web performance metrics collector. Modular approach, each metric is generated by a separate "module". phantomas "core" acts as an events emitter that each module can hook into. In-depth metrics such as: number of events bound via jQuery, calls to window.writeor complex and duplicated CSS selectors (via analyze-css). JSON as an output format. Easy integration with other nodejs projects via CommonJS module (see API docs). Metrics can be emitted from the...
    Downloads: 6 This Week
    Last Update:
    See Project
  • 6
    miniblink49

    miniblink49

    Lighter, faster browser kernel of blink to integrate HTML UI in apps

    miniblink is an open source, one file, small browser widget based on chromium. By using C interface, you can create a browser with just some line code. miniblink is an open source, single-file, and currently the smallest known chromium-based browser control. Through its exported pure C interface, a browser control can be created in a few lines of code. C++, C#, Delphi and other language calls (support C++, C#, Delphi language to call). Embedded Nodejs, support electron (with Nodejs, can run...
    Downloads: 42 This Week
    Last Update:
    See Project
  • 7
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 1 This Week
    Last Update:
    See Project
  • 8
    JWT

    JWT

    A simple library to work with JSON Web Token and JSON Web Signature

    lcobucci/jwt is a framework-agnostic PHP library that allows you to issue, parse, and validate JSON Web Tokens based on the RFC 7519. The package is available on Packagist, you can install it using Composer. A simple library to work with JSON Web Token and JSON Web Signature based on RFC 7519. Once the library has been installed, you are able to issue and parse JWTs. To reduce the chance of having flaky tests on your test suite, the facade supports the usage of a clock object. That allows...
    Downloads: 2 This Week
    Last Update:
    See Project
  • 9
    Biome

    Biome

    A toolchain for web projects, aimed to provide functionalities

    Biome formats and lints your code in a fraction of a second. Biome supports JavaScript, TypeScript, JSON, and CSS. It aims to support all main languages of modern web development. Biome has sane defaults and requires minimal configuration. Biome helps you as much as possible by displaying detailed and contextualized diagnostics. Biome unifies functionality that has previously been separate tools. Building upon a shared base allows us to provide a cohesive experience for processing code, displaying errors, parallelizing work, caching, and configuration.
    Downloads: 14 This Week
    Last Update:
    See Project
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 10
    pywebview

    pywebview

    Build GUI for your Python program with JavaScript, HTML, and CSS

    pywebview is a lightweight cross-platform wrapper around a webview component that allows to display HTML content in its own native GUI window. It gives you power of web technologies in your desktop application, hiding the fact that GUI is browser based. You can use pywebview either with a lightweight web framework like Flask or Bottle or on its own with a two way bridge between Python and DOM. pywebview uses native GUI for creating a web component window: WinForms on Windows, Cocoa on macOS...
    Downloads: 4 This Week
    Last Update:
    See Project
  • 11
    WebF

    WebF

    Build flutter apps with HTML/CSS and JavaScript.

    ...Expand your Web App with Flutter: WebF is fully customizable. You can define a customized HTML element with Flutter Widgets and use it in your application or add a JavaScript API for any Dart library from pub.dev registry. Web Development Experience. WebF supports inspecting DOM structure, CSS styles and debugging JavaScript with Chrome DevTools, providing a browser-like web development experience.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    warp

    warp

    A super-easy, composable, web server framework for warp speeds

    The fundamental building block of warp is the Filter, they can be combined and composed to express rich requirements on requests. A Filter in warp is essentially a function that can operate on some input, either something from a request, or something from a previous Filter, and returns some output, which could be some app-specific type you wish to pass around, or can be some reply to send back as an HTTP response. That might sound simple, but the exciting part is the combinators that exist...
    Downloads: 2 This Week
    Last Update:
    See Project
  • 13
    ServiceStack

    ServiceStack

    Simple, fast, versatile and full-featured services framework

    One framework to power them all. Write your HTTP APIs once and take advantage of end-to-end typed integrations for all popular web, mobile and desktop platforms. ServiceStack's primary goal is to enhance the value of System APIs which serve as the blueprint that most features centered around. By using simple & pure dependency-free DTO models decoupled from any implementation we're free to continue layering on features which now sees ServiceStack APIs as the most versatile in the world where...
    Downloads: 7 This Week
    Last Update:
    See Project
  • 14
    fastn

    fastn

    (Alpha stage software) fastn - Full-stack Web Development Made Easy

    ftd is a programming language for building user interfaces and content-centric websites. ftd is easy to learn, especially for nonprogrammers, but it does not compromise on what you can build with it. fastn is a web framework, a content management system, and an integrated development environment for ftd. fastn is a web server, that compiles ftd to HTML/CSS/JS and can be deployed on your server, or on fastn cloud by FifthTry. ftd is designed with minimal and uniform syntax, and at first glance does not even look like a programming language.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    JS Beautifier

    JS Beautifier

    Beautifier for javascript

    This little beautifier will reformat and re-indent bookmarklets, ugly JavaScript, unpack scripts packed by Dean Edward’s popular packer, as well as partly deobfuscate scripts processed by the npm package javascript-obfuscator. All of the source code is completely free and open, available on GitHub under MIT licence, and we have a command-line version, python library and a node package as well. You may install the NPM package js-beautify. When installed globally, it provides an executable...
    Downloads: 4 This Week
    Last Update:
    See Project
  • 16
    SWC

    SWC

    Rust-based platform for the Web

    SWC is an extensible Rust-based platform for the next generation of fast developer tools. It's used by tools like Next.js, Parcel, and Deno, as well as companies like Vercel, ByteDance, Tencent, Shopify, and more. SWC can be used for both compilation and bundling. For compilation, it takes JavaScript / TypeScript files using modern JavaScript features and outputs valid code that is supported by all major browsers. SWC is 20x faster than Babel on a single thread and 70x faster on four cores....
    Downloads: 6 This Week
    Last Update:
    See Project
  • 17
    WebHarvest - web data extraction tool
    Web data extraction (web data mining, web scraping) tool. It leverages well proved XML and text processing techologies in order to easely extract useful data from arbitrary web pages.
    Downloads: 13 This Week
    Last Update:
    See Project
  • 18
    AWS Lambda Python Runtime Interf Client

    AWS Lambda Python Runtime Interf Client

    Seamlessly extend your preferred base images to be Lambda compatible

    We have open-sourced a set of software packages, Runtime Interface Clients (RIC), that implement the Lambda Runtime API, allowing you to seamlessly extend your preferred base images to be Lambda compatible. The Lambda Runtime Interface Client is a lightweight interface that allows your runtime to receive requests from and send requests to the Lambda service. The Lambda Python Runtime Interface Client is vended through pip. You can include this package in your preferred base image to make...
    Downloads: 7 This Week
    Last Update:
    See Project
  • 19
    Lume

    Lume

    Create 3D web applications with HTML, bring a new depth to your DOM

    A toolkit that simplifies the creation of rich and interactive 2D or 3D experiences. LUME is composed of several packages that can be used individually, or together as a whole. HTML elements for easily defining rich and interactive 2D or 3D applications powered by CSS3D, WebGL, or both mixed together. This is a web component system that allows you to create new, fast, and performant HTML elements in a simple way. It provides the foundation for LUME's HTML elements and a standard pattern for...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    Formly

    Formly

    JSON powered dynamic forms for Angular

    Formly is a dynamic (JSON-powered) form library for Angular that brings unmatched maintainability to your application's forms. Easy to extend with custom field type, validation, wrapper and extension. Every developer that’s using Angular to build cool web applications knows forms are among the most common things to build. We are building by hand with all the tools Angular gives us. NGX Formly was built as an open-source project, which you can find on GitHub. The tool lets you create forms...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    express-openapi-validator

    express-openapi-validator

    Auto-validates api requests, responses, and securities using ExpressJS

    Auto-validates api requests, responses, and securities using ExpressJS and an OpenAPI 3.x specification. Express-openapi-validator is an unopinionated library that integrates with new and existing API applications. express-openapi-validator lets you write code the way you want; it does not impose any coding convention or project layout. Simply, install the validator onto your express app, point it to your OpenAPI 3 specification, then define and implement routes the way you prefer. An...
    Downloads: 3 This Week
    Last Update:
    See Project
  • 22
    Suave

    Suave

    Suave is a simple web development F# library

    Suave is a simple web development F# library providing a lightweight web server and a set of combinators to manipulate route flow and task composition. Suave is inspired in the simplicity of Happstack and born out of the necessity of embedding web server capabilities in my own applications. Suave supports Websocket, HTTPS, multiple TCP/IP bindings, Basic Access Authentication, Keep-Alive.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    kotlinx.html

    kotlinx.html

    Kotlin DSL for HTML

    A kotlinx.html library provides DSL to build HTML to Writer/Appendable or DOM. Available to all Kotlin Multiplatform targets and browsers (or other JavaScript engines) for better Kotlin programming for the Web.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 24
    Simple.css

    Simple.css

    Simple.css is a classless CSS template to make a good website

    A classless CSS framework that makes semantic HTML look good. By classless I mean that there are no CSS classes anywhere in the CSS or the HTML. So your website can look just like this using plain old vanilla HTML. When starting a new project, I wanted a CSS framework that would get me up and running quickly, and give me something I could hack on. I got sick of all these giant frameworks that include everything but the kitchen sink, 90% of which I’ll never use. For example, the minified CSS...
    Downloads: 3 This Week
    Last Update:
    See Project
  • 25
    Tacit

    Tacit

    CSS framework for dummies, without a single CSS class

    Tacit is a CSS framework for dummies, who want their web services to look attractive but have almost zero skills in graphic design, just like myself. Tacit is a primitive CSS framework for dummies, like myself, who don't know anything about graphic design but want their web services to look eatable. No classes, no layouts. Just design plain and simple web pages compliant with HTML5 and they will look OK. Tacit's goal is to be super simple and always with the same look-and-feel. If you want...
    Downloads: 0 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • 3
  • 4
  • 5
  • Next