Showing 31 open source projects for "penetration testing linux"

View related business solutions
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 1
    theHarvester

    theHarvester

    E-mails, subdomains and names

    theHarvester is a very simple to use, yet powerful and effective tool designed to be used in the early stages of a penetration test or red team engagement. Use it for open source intelligence (OSINT) gathering to help determine a company's external threat landscape on the internet. The tool gathers emails, names, subdomains, IPs and URLs using multiple public data sources.
    Downloads: 56 This Week
    Last Update:
    See Project
  • 2
    react-email

    react-email

    Build and send emails using React

    react-email is a modern library for building responsive email templates using React components, bringing familiar frontend development practices into email design. It allows developers to create emails using reusable components, making it easier to maintain consistency across different templates and campaigns. The library supports rendering to HTML that is compatible with major email clients, addressing common challenges such as inconsistent styling and layout issues. It integrates...
    Downloads: 3 This Week
    Last Update:
    See Project
  • 3
    reg-factory

    reg-factory

    Google Mail registration

    reg-factory is an automation-oriented account registration pipeline aimed at research, testing, and controlled platform workflow experiments. It combines browser automation, environment-based configuration, and a local web control panel to run multi-step registration scripts. The project includes modules for email registration, platform sign-up flows, token handling, cookie export, and account workflow management. It uses local scripts and external tool integrations to coordinate browser...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4
    Proton Web Clients

    Proton Web Clients

    Monorepo hosting the proton web clients

    Proton Web Clients is a monorepo hosting the web applications for Proton’s suite of privacy-focused services, including the core Proton Mail webmail interface and related web apps like Proton Calendar, Proton Drive, Proton Account, Proton VPN, Proton Pass, and other connected tools. It consolidates all web client code, shared modules, dependencies, and development tooling into a single repository, enabling unified maintenance, consistency of design patterns, and efficient evolution of...
    Downloads: 1 This Week
    Last Update:
    See Project
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 5
    Bamboo

    Bamboo

    Testable, composable, and adapter based Elixir email library

    Bamboo is part of the thoughtbot Elixir family of projects. Flexible and easy-to-use email for Elixir. Built-in support for popular mail delivery services. Bamboo ships with adapters for several popular mail delivery services, including Mandrill, Mailgun, and SendGrid. It's also quite easy to write your own delivery adapter if your platform isn't yet supported. Deliver emails in the background. Most of the time you don't want or need to wait for the email to send. Bamboo makes it easy with...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    ZEG / Zero-Effort-Groupware

    ZEG / Zero-Effort-Groupware

    SOGo Zero-Effort-Groupware

    The ZEG (Zero Effort Groupware) edition of SOGo is intended to provide a complete out-of-the-box testing environment of SOGo, the Open Source messaging and calendaring software.
    Leader badge
    Downloads: 13 This Week
    Last Update:
    See Project
  • 7
    ICTFax

    ICTFax

    Open source Fax server software for inbound / outbound internet Faxing

    ...Installation Guide https://www.ictfax.org/ictfax-installation-guide/ Administration Guide https://www.ictfax.org/ictfax-admin-guide/ User Guide https://www.ictfax.org/ictfax-user-guide/ Commercial Support If you do not posses Linux / VoIP expertise to install and setup ICTFax or you are busy, We can help you in installation, configuration and testing to make sure ICTFax setup is functional and tested. Below are Installation package link for custom projects and development work. Please Installation support services.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 8
    MailHog

    MailHog

    Web and API based SMTP testing

    Inspired by MailCatcher, easier to install. Built with Go, MailHog runs without installation on multiple platforms. Run it from Docker Hub or using the provided Dockerfile. The SMTP server starts on port 1025, the HTTP server starts on port 8025, in-memory message storage. ESMTP server implementing RFC5321. Support for SMTP AUTH (RFC4954) and PIPELINING (RFC2920). Web interface to view messages (plain text, HTML or source). Supports RFC2047 encoded headers. Real-time updates using...
    Downloads: 49 This Week
    Last Update:
    See Project
  • 9
    GITST Free Email Sender

    GITST Free Email Sender

    GITST FREE EMAIL SENDER

    GITST Email Sender allows you to send multiple emails from multiple email accounts adding limits on each email account For example, you want to send 500 from gmail then switch to yandex and send 300 from yandex and so on that is all what it does sends unlimited emails from multiple different email accounts it is basics of anti-spam penetration system
    Downloads: 0 This Week
    Last Update:
    See Project
  • Earn up to 16% annual interest with Nexo. Icon
    Earn up to 16% annual interest with Nexo.

    Access competitive interest rates on your digital assets.

    Generate interest, borrow against your crypto, and trade a range of cryptocurrencies — all in one platform. Geographic restrictions, eligibility, and terms apply.
    Get started with Nexo.
  • 10

    Jnestor

    Jnestor is another majordomo in java

    Jnestor is a majordomo developed in java: it can reads an IMAP/POP3 folder (email folder), identifies the elements in it and process them, transforming them as Mantis issues. The software is still experimental, but it passed succesfully the last stages of testing and I hope I will release a stable version soon.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    GreenMail is an intuitive and easy-to-use test suite of email servers for testing purposes. Supports SMTP, POP3, IMAP with SSL socket support, and configurable user accounts and credentials. All in 100% Java. WE'VE MOVED TO GIT HUB: https://github.com/greenmail-mail-test/greenmail
    Downloads: 2 This Week
    Last Update:
    See Project
  • 12
    MailProbe
    E-Mail monitoring, benchmarking and load testing tool with integrated web UI.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    This is an internal testing project. Please ignore.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    A fake mail server that captures e-mails as files for acceptance testing. This avoids the excessive configuration of setting up a real mail server and trying to extract mail queue content. Sponsered by Wordtracker.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 15
    Mailster is a project aimed at testing software mail capabilities. It provides a mail server container to test emails sent by your apps without rewriting your application code.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 16
    Deva is a free and open source project for verifying all steps of driver behavior for Linux kernel, and reporting excellent in both pictures and literary compositions. In the other hand the complete modular testing rules can easily develop customize.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    An attempt to send a full flagged MIME based email using open relay mail servers (authentication not required). Written in Python3. Using smtplib and email liabraries TODO: Bruteforce the SMTP authentication. Support TLS.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    Cheescloth is a security script that is used to monitor and block email being brute force sent to your mail server by zombie machines in control by spammers and hackers. It also will catch and block hackers trying to hack your server via SSH connection
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    The Java Email Server (JES) plug-in is an embedded instance launcher of JES (email server) under Eclipse; it's intended to help developers viewing the layout of mails sent by their application to the clients (subscription mails, etc...) in local.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    xstress is a SMTP mail server stress testing tool. xstress creates multiple connections (using threads) to the (configured) mail server and sends mails with varying subject, body, attachment and TO/FROM addresses.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    Mstone is a mail performance measurement system. It can simultaneously test SMTP, POP, IMAP, and some HTML based systems. It measures transaction latency in multiple stages, and graphs the combined results from multiple clients.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    FakeSMTPServer is a solution for testing web-based products that require a "unique" email address. Instead of being a "real" smtp server, this server forwards all email to a single email address, or can output them to the console instead.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    Mock objects for JUnitTests for common network services: http(s), SMTP and POP3. The focus was to easily have the services return defined errors or predefined documents independent of application level security and sophisticated data-store.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    SMTPA is a penetration testing and email compliance tool. Want to know if a renamed, encrypted MS word document with a wrongly set content-type header fools your Content Security infrastructure? Check this out!
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    general purpose stress test tool. stressful instanciates Java classes which make stress on a target software.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • Next