Showing 44 open source projects for "php mvc framework"

View related business solutions
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • Build Securely on AWS with Proven Frameworks Icon
    Build Securely on AWS with Proven Frameworks

    Lay a foundation for success with Tested Reference Architectures developed by Fortinet’s experts. Learn more in this white paper.

    Moving to the cloud brings new challenges. How can you manage a larger attack surface while ensuring great network performance? Turn to Fortinet’s Tested Reference Architectures, blueprints for designing and securing cloud environments built by cybersecurity experts. Learn more and explore use cases in this white paper.
    Download Now
  • 1
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 1 This Week
    Last Update:
    See Project
  • 2
    TreeFrog Framework

    TreeFrog Framework

    TreeFrog Framework, High-speed C++ MVC Framework for Web Applications

    TreeFrog Framework is a high-speed and full-stack C++ framework for developing Web applications, which supports HTTP and WebSocket protocol. Web applications can run faster than that of scripting language because the server-side framework was written in C++/Qt. In application development, it provides an O/R mapping system and template systems on an MVC architecture, aims to achieve high productivity through the policy of convention over configuration. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3
    Framework Benchmarks

    Framework Benchmarks

    Source for the TechEmpower Framework Benchmarks project

    If you're new to the project, welcome! Please feel free to ask questions here. We encourage new frameworks and contributors to ask questions. We're here to help! This project provides representative performance measures across a wide field of web application frameworks. With much help from the community, coverage is quite broad and we are happy to broaden it further with contributions. The project presently includes frameworks on many languages including Go, Python, Java, Ruby, PHP, C#,...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4
    JWT

    JWT

    A simple library to work with JSON Web Token and JSON Web Signature

    lcobucci/jwt is a framework-agnostic PHP library that allows you to issue, parse, and validate JSON Web Tokens based on the RFC 7519. The package is available on Packagist, you can install it using Composer. A simple library to work with JSON Web Token and JSON Web Signature based on RFC 7519. Once the library has been installed, you are able to issue and parse JWTs.
    Downloads: 2 This Week
    Last Update:
    See Project
  • Ship Agents Faster Icon
    Ship Agents Faster

    Transform your applications and workflows into powerful agentic systems at global scale.

    Gemini Enterprise Agent Platform lets you rapidly build, scale, govern and optimize production-ready agents grounded in your organization's data. The platform enables developers to build custom or pre-built agents for virtually any use case. New customers get $300 in free credits.
    Start Free
  • 5
    Form Component

    Form Component

    Allows to easily create, process and reuse HTML forms

    Symfony Form is a component that simplifies form creation and management in PHP applications. It provides a robust framework for building and handling forms, including form validation, data binding, and rendering. Symfony Form is highly flexible and integrates seamlessly with other Symfony components, making it a go-to choice for creating dynamic, data-driven forms in web applications.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 6
    CssToInlineStyles class

    CssToInlineStyles class

    Enables you to convert HTML-pages/files into HTML-pages/files

    CssToInlineStyles is a class that enables you to convert HTML-pages/files into HTML-pages/files with inline styles. This is very usefull when you're sending emails. UTF-8 charset is not always detected correctly. Make sure you set the charset to UTF-8 using the correct meta-tag in the head. CssToInlineStyles class is used on each site based on Fork CMS. CssToInlineStyles class is used by Laravel Framework.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    Tailwindo

    Tailwindo

    Convert Bootstrap CSS code to Tailwind CSS code

    This tool can convert Your CSS framework (currently Bootstrap) classes in HTML/PHP (any of your choice) files to equivalent Tailwind CSS classes. Made to be easy to add more CSS frameworks in the future (currently Bootstrap). Can convert single files/code snippets/folders. Can extract changes to a separate CSS file as Tailwind components and keep old classes names.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    PHP JOSE Library

    PHP JOSE Library

    JSON Object Signing and Encryption Framework (JWT, JWS, JWE, JWA, JWK

    JSON Object Signing and Encryption Framework (JWT, JWS, JWE, JWA, JWK, JWKSet and more)
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    PurifyCSS

    PurifyCSS

    Remove unused CSS. Also works with single-page apps

    A function that takes content (HTML/JS/PHP/etc) and CSS, and returns only the used CSS. PurifyCSS does not modify the original CSS files. You can write to a new file, like minification. If your application is using a CSS framework, this is especially useful as many selectors are often unused. Statically analyzes your code to pick up which selectors are used. The CLI currently does not support file patterns.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Veeam Data Platform v13.1 Icon
    Veeam Data Platform v13.1

    Move workloads across hypervisors and clouds with no vendor lock-in. Try VDP free today.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try Now
  • 10
    Chunk, an HTML Template Engine for Java

    Chunk, an HTML Template Engine for Java

    Clean, powerful templates for Java

    A powerful Java Template Engine, great for building HTML or XML docs. Chunk can handle many other needs and situations as well. In-tag filters & default values, multiple snippets per file, layered themes, macros, conditional includes, localization & more.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    The Bee Framework is a PHP 5 DI/IoC application framework based on the popular Spring Framework, bringing - among other features - XML-configured declarative Dependency Injection and a powerful MVC framework to PHP.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    G-Framework Web3.0 ToolKit
    This is the most advanced and complete new generation tool for creating Web applications. You can create your own "Web Applications" once writing very few lines of code and make it simply accessible from anywhere in the world.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    Fat-Free Framework
    FAT-FREE is a powerful and lightweight PHP 5.3+ Web application framework designed to help you build dynamic and robust Web sites - fast! Unlike other PHP frameworks, Fat-Free aims to be usable - not usual.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14

    Interface Dialects Linker (XML)

    Write-Once, Deploy-Everywhere software framework

    The IDLX project aims to create a framework which leverages existing technologies and XML dialects to build user interfaces in a platform-independent way. The ultimate goal is a WODE (write once, deploy everywhere) framework which is flexible and powerful enough to support any development task long into the future.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    PHP View-Controller framework similar to Adobe Flex framework. It is component based, event driven framework. Components can be defined in XML with possibility of inline PHP binding expressions or directly in PHP as PHP class.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    The Bear is a front end to the powerful download manager aria2. Is a web-based download manager written by PHP and Yii framework.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    Mapix CMS
    Mapix is a CMS/framework designed to develop websites entirely (as far as possible) with the XML/XSL/XSD technology. The objective of Mapix is to become a complete gateway between the HTTP server and XML services.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    eGloo Framework (Moved to Github)
    https://github.com/egloo/eglooframework
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    Storm MVC is a php framework based on the model-view-controller design pattern featuring pretty URLs, site themes via inherited master pages, and easy forms processing. It is a mix of the best ideas from Rails, Django and ASP.NET MVC.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    jQuery MyDLO
    MyDLO - My Dynamically Linked Objects A SOAP-like feature for mapping server side objects to JavaScript and calling methods via AJAX. The project also contains a framework for JavaScript that supports easy loading and saving data on the server.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    MixDEM
    MixDEM a web based ETL tools meant for Web integration, Data transformation and Mashup edition. It include MixDEM ETL Engine created using ZEND Framework, and MixDEM GUI Editor an AJAX IDE that enable developers to quickly and easily create applications.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    Fydji WS is a Web Services creation framework allowing to build services mapped to database operations, Java methods or other sources. It produces a Web application for services publishing and Java/JavaScript/PHP client classes for their invocation.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    XMI Transform is a tool written in PHP to convert XMI file to source code or source code to XMI file. The purpose is to provides a simple access to source code generation, which is, in general, the first thing we need in a MDA approach.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    Sushee is an XML Office Management Framework: a set of application development tools designed to manage contents and activities (companies, institutions, associations, etc.) in a multi-language, multi-channel, multi-format and multi-project context.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    This is a simple framework in javascript / xml / php that allows you to manage the ajax pushing at server-side without the use of IFRAME or swf player!!. It has been tested (and works correctly) with FF2,FF3,IE6,IE7,IEMobile.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • Next