Showing 18 open source projects for "file system"

View related business solutions
  • Demo Series - Small Business Backup By Veeam Icon
    Demo Series - Small Business Backup By Veeam

    Learn how to protect your Microsoft 365 data, with simple, actionable tips today.

    Watch this on-demand demo series and learn how to protect your Microsoft 365 data with clear, simple, actionable steps that are easy to implement for businesses of all sizes.
    Watch Demo Series
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • 1
    Cloud Torrent

    Cloud Torrent

    Cloud Torrent, a self-hosted remote torrent client

    ...The provided set of core features requires large structural changes and therefore requires a complete rewrite for best results. This rewrite is in progress in the 0.9 branch though it will take quite some time. It will be capable of transfering files from and source file-system to any destination file-system. A torrent can be viewed a folder with files, just like your local disk, and Dropbox. As long as it has a concept of files and folders, it could potentially be a cloud-torrent file-system backend. During a file tranfer, one could apply different transforms against the byte stream for various effect.
    Downloads: 11 This Week
    Last Update:
    See Project
  • 2
    ownCloud Infinite Scale

    ownCloud Infinite Scale

    ownCloud Infinite Scale Stack

    ownCloud Infinite Scale (oCIS) is the modern, cloud-native evolution of ownCloud designed to deliver high performance and virtually unlimited scalability for enterprise file collaboration. Built with a microservices architecture in Go, it replaces the traditional monolithic server with a distributed system optimized for containerized and hybrid cloud environments. The platform focuses on providing a unified data access layer that can connect multiple storage backends while maintaining strong control over file sharing and governance. ...
    Downloads: 7 This Week
    Last Update:
    See Project
  • 3
    Rain

    Rain

    BitTorrent client and library in Go

    Rain is a fast, lightweight, and feature-rich BitTorrent client written in Go, designed to be used from the command line. It focuses on performance and simplicity, supporting both seeding and downloading operations with minimal system resource usage. Rain is ideal for automation, headless servers, and users who prefer terminal-based tools. It offers a clean API, making it easy to integrate into scripts and backend services that require torrent functionality. With its statically compiled...
    Downloads: 10 This Week
    Last Update:
    See Project
  • 4
    IPFS Kubo

    IPFS Kubo

    An IPFS implementation in Go

    Kubo was the first IPFS implementation and is the most widely used one today. Implementing the Interplanetary Filesystem - the Web3 standard for content-addressing, interoperable with HTTP. Thus powered by IPLD's data models and the libp2p for network communication. Kubo is written in Go. IPFS is a global, versioned, peer-to-peer filesystem. It combines good ideas from previous systems such as Git, BitTorrent, Kademlia, SFS, and the Web. It is like a single BitTorrent swarm, exchanging git...
    Downloads: 16 This Week
    Last Update:
    See Project
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 5
    DefraDB

    DefraDB

    DefraDB is a Peer-to-Peer Edge Database

    DefraDB is a Peer-to-Peer Edge Database. It's the core data storage system for the Source Network Ecosystem, built with IPFS/IPLD, LibP2P, CRDTs, and Semantic web3 properties. DefraDB is a user-centric database that prioritizes data ownership, personal privacy, and information security. Its data model, powered by the convergence of MerkleCRDTs and the content-addressability of IPLD, enables a multi-write-master architecture. It features DQL, a query language compatible with GraphQL but...
    Downloads: 11 This Week
    Last Update:
    See Project
  • 6
    Hyprspace

    Hyprspace

    A Lightweight VPN Built on top of IPFS + Libp2p

    A Lightweight VPN Built on top of IPFS & Libp2p. Libp2p is a networking library created by Protocol Labs that allows nodes to discover each other using a Distributed Hash Table. Paired with NAT hole punching this allows Hyprspace to create a direct encrypted tunnel between two nodes even if they're both behind firewalls. Moreover! Each node doesn't even need to know the other's ip address prior to starting up the connection. This makes Hyprspace perfect for devices that frequently migrate...
    Downloads: 6 This Week
    Last Update:
    See Project
  • 7
    Project Lotus

    Project Lotus

    Reference implementation of the Filecoin protocol, written in Go

    Lotus is the reference implementation for the Filecoin network. It is written in Go, and is maintained by the Protocol Labs team. This website contains all the information you need to spin up a Lotus node, become a Filecoin storage provider, or just tinker around with the Filecoin network! Filecoin is a network of computers that allows you to store your data online. But while online storage services aren't anything new, Filecoin is different. It doesn't use centralized servers to store your...
    Downloads: 4 This Week
    Last Update:
    See Project
  • 8
    HTserveFS

    HTserveFS

    Fast file system server with modern web UI and direct transfers

    Powerful HTTP file system server (HFS) designed for fast, direct file transfers without intermediaries. This modern file server solution features a responsive web interface for seamless file management, supporting unlimited file sizes with high-speed transfers. Built with advanced security including JWT authentication, role-based permissions, and TLS encryption.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 9
    transfer.sh

    transfer.sh

    Easy and fast file sharing from the command-line

    Easy and fast file sharing from the command-line. This code contains the server with everything you need to create your own instance. Transfer.sh currently supports the s3 (Amazon S3), gdrive (Google Drive), storj (Storj) providers, and local file system (local). For easy deployment, we've created a Docker container. For the usage with a AWS S3 Bucket, you just need to specify the following options, provider, aws-access-key, aws-secret-key, bucket, and s3-region. ...
    Downloads: 2 This Week
    Last Update:
    See Project
  • Host LLMs in Production With On-Demand GPUs Icon
    Host LLMs in Production With On-Demand GPUs

    NVIDIA L4 GPUs. 5-second cold starts. Scale to zero when idle.

    Deploy your model, get an endpoint, pay only for compute time. No GPU provisioning or infrastructure management required.
    Start Free
  • 10
    vocdoni-node

    vocdoni-node

    A set of libraries and tools for the Vocdoni decentralized backend

    This repository contains a set of libraries and tools for the Vocdoni decentralized backend infrastructure, as described in the documentation. Vocdoni is a universally verifiable, censorship-resistant, and anonymous self-sovereign governance system, designed with the scalability and ease-of-use to support either small/private and big/national elections. Our main aim is a trustless voting system, where anyone can speak their voice and where everything can be audited. We are engineering...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 11
    Superhighway84

    Superhighway84

    USENET-inspired, uncensorable, decentralized internet discussion

    Superhighway84 is an open-source, terminal-based, IPFS-powered, USENET-inspired, uncensorable, decentralized peer-to-peer internet discussion system with retro aesthetics.
    Downloads: 10 This Week
    Last Update:
    See Project
  • 12
    kiosk

    kiosk

    Multi-tenancy extension for Kubernetes

    kiosk is a multi-tenancy extension For Kubernetes. Secure cluster sharing & self-service namespace provisioning. Accounts & account users to separate tenants in a shared Kubernetes cluster. Self-service namespace provisioning for account users. Account limits to ensure quality of service and fairness when sharing a cluster. Namespace templates for secure tenant isolation and self-service namespace initialization. Multi-cluster tenant management for sharing a pool of clusters. Kubernetes is...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    Multiverse

    Multiverse

    Decentralized Version Control System

    The goal of the Multiverse project is to create a developer-centric network for code hosting, collaboration, and archival. One that is community-operated, privacy-respecting, and completely open source. Multiverse builds on top of the libp2p and IPFS projects to provide a decentralized code-hosting network. Decentralized networks shift the power from service providers to the users in the form of data ownership. Data ownership and data portability are the two core factors that will drive...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    MailHog

    MailHog

    Web and API based SMTP testing

    Inspired by MailCatcher, easier to install. Built with Go, MailHog runs without installation on multiple platforms. Run it from Docker Hub or using the provided Dockerfile. The SMTP server starts on port 1025, the HTTP server starts on port 8025, in-memory message storage. ESMTP server implementing RFC5321. Support for SMTP AUTH (RFC4954) and PIPELINING (RFC2920). Web interface to view messages (plain text, HTML or source). Supports RFC2047 encoded headers. Real-time updates using...
    Downloads: 37 This Week
    Last Update:
    See Project
  • 15
    slack-term

    slack-term

    Slack client for your terminal

    A Slack client for your terminal. Download a compatible binary for your system. For convenience, place slack-term in a directory where you can access it from the command line. Usually this is /usr/local/bin. If you want, you can also get slack-term via Go. You can also run it with docker, make sure you have a valid config file on your host system. In addition to running slack-term from the command line by using slack-term, you have some additional flags that you can use. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    Pydio Cells

    Pydio Cells

    Formerly AjaXplorer, file sharing platform for the enterprise

    Pydio Cells is the mature open source alternative to dropbox and box, for the enterprise. Why building your own box? You need to access your documents across multiple devices, and regularly share documents (weblinks) and folders with your contacts and teams. Still, using a consumer SaaS box or drive service is neither practical nor safe. And enterprise SaaS box or drive services are expensive and come with Disk Storage that you already have on your servers or private cloud. How to...
    Downloads: 7 This Week
    Last Update:
    See Project
  • 17
    go-ipfs-plugin-i2p-gateway

    go-ipfs-plugin-i2p-gateway

    A plugin for presenting an IPFS gateway over i2p

    ...It will make your IPFS gateway accessible via i2p clients, but it will not route communication between IPFS nodes over i2p(1). This means that it doesn't make your IPFS instance anonymous, it just makes it accssible to clients anonymously(2). It simply takes advantage of the plugin system to set up some hidden services when the IPFS plugin is initialized. It does this by reading the IPFS config file to find the ports that have been configured by the admin running IPFS, then using the SAM API to forward those ports to I2P. Once they are forwarded, a config file is generated containing the i2p configuration and it's base32 and base64 addresses. ...
    Downloads: 2 This Week
    Last Update:
    See Project
  • 18
    AEBL

    AEBL

    AEBL is a mobile media distribution system

    ...The AEBL blog is located here: http://aeblm2.blogspot.ca/ For those interested in trying it out, you will need a Raspberry Pi (should be the B series with 512MB) and a SD card (4GB or higher, recommend base 8GB but the larger, the better, for content storage). The current image is a ~680MB 7zip compressed file of it's original 2.7GB size, located on dropbox, here: https://www.dropbox.com/s/lj0r6yia4tsnz8w/140815-aeblpi.img.7z?dl=0
    Downloads: 0 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • Next