alpha

As of 2012-12-10, this project may now be found at https://github.com/Chris00/fftw-ocaml.

User Ratings

★★★★★
★★★★
★★★
★★
0
0
1
0
0
ease 1 of 5 2 of 5 3 of 5 4 of 5 5 of 5 3 / 5
features 1 of 5 2 of 5 3 of 5 4 of 5 5 of 5 3 / 5
design 1 of 5 2 of 5 3 of 5 4 of 5 5 of 5 3 / 5
support 1 of 5 2 of 5 3 of 5 4 of 5 5 of 5 3 / 5
Write a Review

User Reviews

  • musumn
    1 of 5 2 of 5 3 of 5 4 of 5 5 of 5

    hello, I tried to install the ocaml fftw in my ubuntu 12.04 LTS and in Mac IOS 10.6.8. However, in both cases, the installation failed with error message: wang@wang-OptiPlex-780:~/Downloads/fftw3-ocaml-0.6$ CPPFLAGS="-I/usr/local/include" LDFLAGS="-L/usr/local/lib" ./configure configuring fftw3-ocaml 0.6 checking for ocaml... /usr/bin/ocaml checking for ocamlc... /usr/bin/ocamlc ocaml version is 3.12.1 ocaml library path is /usr/lib/ocaml checking for ocamlopt... /usr/bin/ocamlopt checking ocamlopt version... ok checking for ocamlc.opt... no checking for ocamlopt.opt... no checking for ocamldep... /usr/bin/ocamldep checking for ocamldoc... /usr/bin/ocamldoc checking for ocamlfind... /usr/bin/ocamlfind checking for gcc... gcc checking whether the C compiler works... yes checking for C compiler default output file name... a.out checking for suffix of executables... checking whether we are cross compiling... no checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ISO C89... none needed checking for libfftw3 (double precision)... configure: error: Check for fftw3 (double precision) failed. I have installed the fftw-3.3.3. Files: /usr/local/lib/libfftw3.a /usr/local/lib/libfftw3.la /usr/local/include/fftw3.h are available. Why does the error message tell "check for libfftw3 failed"?

    Posted 07/03/2013