Looking for the latest version? Download mod_plua_0.54-src.tar.gz (34.9 kB)
Home
Name Modified Size Downloads / Week Status
Totals: 5 Items   1.9 kB 1
Source code 2012-07-13 1 weekly downloads
FreeBSD binaries 2012-01-26 2 weekly downloads
Linux binaries 2012-01-24 2 weekly downloads
Windows binaries 2012-01-24 1 weekly downloads
README.creole 2012-01-29 1.9 kB 11 weekly downloads

Download mod_pLua:

This page shows the various package solutions available for download.
The currently available options are:

Which version to choose

UNIX users

If you are running Linux or FreeBSD, you can download the compiled binaries - otherwise, download the source and run ./configure followed by make.

Windows

If you are running Windows, you can download a compiled package for either Lua or LuaJIT (recommended). You will need to copy the DLL files in your package into the Apache2 'bin' folder.

Other architectures

If you have access to other architectures than the ones listed, and you have sufficient knowledge to compile the binaries, do let me know, and I'll upload your copies of the binaries!

Requirements

Lua versions

The Lua versions require Lua 5.1 or 5.2 installed on your machine, depending on which package you download.

LuaJIT versions

The LuaJIT versions for Windows come bundled with the LuaJIT library (lua51.dll) for quick installation. For UNIX, you will have to install LuaJIT yourself using your local package manager.

Installing

To install mod_plua, simply copy the compiled .so file to your apache module folder, typically /usr/lib/apache2/modules. For configuration, please see the Setting up mod_plua wiki page.

Source: README.creole, updated 2012-01-29