GnuCash Icon

GnuCash

1 of 5 2 of 5 3 of 5 4 of 5 5 of 5 (82) Read Reviews | Last Updated
Windows BSD Mac Solaris Linux
Looking for the latest version? Download gnucash-2.6.2.tar.bz2 (10.8 MB)
Name Modified Size Downloads / Week Status
Parent folder
Totals: 6 Items   299.1 MB 6
Gnucash-PPC-2.3.17.dmg 2010-11-21 88.0 MB 11 weekly downloads
Gnucash-2.3.17-OSX-Readme.txt 2010-11-21 11.2 kB 11 weekly downloads
Gnucash-Intel-2.3.17.dmg 2010-11-21 93.5 MB 11 weekly downloads
gnucash-2.3.17-setup.exe 2010-11-21 95.5 MB 11 weekly downloads
gnucash-2.3.17.tar.bz2 2010-11-21 9.2 MB 11 weekly downloads
gnucash-2.3.17.tar.gz 2010-11-21 12.9 MB 11 weekly downloads
Contents * 1 Gnucash OSX for Intel o 1.1 Prerequisites: o 1.2 Installation: + 1.2.1 Installing Finance::Quote o 1.3 Documentation: o 1.4 Known Issues: o 1.5 There are no OSX-specific changes in 2.3.17 o 1.6 There are no OSX-specific changes in 2.3.16 o 1.7 OSX Changes in 2.3.15 o 1.8 OSX Changes in 2.3.14 o 1.9 OSX Changes in 2.3.13 o 1.10 OSX Changes in 2.3.12 o 1.11 OSX Changes in 2.3.11 o 1.12 OSX Fixes in 2.3.10.1 o 1.13 There are no OSX Changes in 2.3.10 o 1.14 OSX Changes in 2.3.9 o 1.15 OSX Changes in 2.3.8 o 1.16 License and Included Binaries: Gnucash OSX for Intel *WARNING WARNING WARNING* /*This is an unstable build. It is for testing, not production use. Make sure you make backups of any files used in testing versions of GnuCash in the 2.3.x series. Although the developers go to great lengths to ensure that no data will be lost we cannot guarantee that your data will not be affected if for some reason GnuCash crashes in testing these releases.*/ Prerequisites: This build for Intel X86-based Macs requires MacOSX 10.5 (Leopard) or MacOSX 10.6 (Snow Leopard). It will not work on 10.4 (Tiger) because some of the libraries on which it depends now use features introduced in 10.5. Installation: If you are upgrading from a version of Gnucash older than 2.3.9, please run the "Update Dirs" application in the dmg. This will convert your online banking setup to work with the new version of AqBanking and will copy your .gnucash directory to the more Mac-appropriate Library/Application Support/Gnucash. Simply drag Gnucash.app to the Applications folder (or anywhere else you like). When you first open GnuCash.app, it will create a link from the bundle Resources folder to /Library/Gnucash-2.3.x. It will do this automatically, and no authentication is required. Installing Finance::Quote You can easily install Finance::Quote by double-clicking the "FinanceQuote Update" applet in the dmg. You'll need to have Developer Tools (Tiger or Leopard) or XCode (Snow Leopard) installed. It's available as an optional install on your installation DVD. Documentation: Both the Gnucash Help system and the Gnucash Guide are provided in HTML format. They will open in your default browser when you select the appropriate item in the Help menu. Appropriate sections of help will be similarly opened when you click on a Help button in a dialog box. Known Issues: * Gnucash is not a native Mac application: It is a Gtk+ application which has been recompiled to run on OSX. Accordingly, some features to which Mac users are accustomed aren't supported. Some of these are non-menu-based keyboard shortcuts (key bindings; you can adjust them as you like in the gtkrc file), input methods, and Universal Access. * An instance of dbus is started by the application startup script, but dbus isn't designed to be run that way, so it doesn't shut down when you close the application. When Gnucash starts up again, it will kill any instances of dbus which are running from the same path, but if you move Gnucash.app or are switching between stable and development versions, you may wind up with more than one instance. You can clean out the running dbus-daemons by either issuing "killall dbus-daemon" at a command line or by telling it to quit from /Applications/Utilities/Activity Monitor. Note that if you want to delete Gnucash.app, you'll need to kill the running instance of dbus-daemon first or you'll get "file in use" errors from Finder. * The conversion of Macintosh default locale to Gtk+ is a bit primitive, and while the gnucash translation files are included, you may encounter messages from other libraries which aren't translated. * Some users have reported menus in the wrong language (usually Japanese). This is caused by gnucash not being able to retrieve the correct default language from OSX. It can be fixed by opening System Prefrences>International (or Language & Text on Snow Leopard) and changing something, then changing it back. It doesn't really matter what you change. A note on languages: Gnucash (all of Gtk, actually) uses Gnu gettext for retrieving translations. It doesn't do preferred languages, so it will get locale information from the formats tab in the International/Languages and Texts panel of System Preferences. * Note that Gnucash demands a few things that Finance::Quote doesn't in order to get quotes. Use the FinanceQuote Update applet included with Gnucash to make sure that your Finance::Quote installation is correct and current. * As of Gnucash 2.3.9, Gnucash's configuration files are in $HOME/Library/Application Support/Gnucash instead of $HOME/.gnucash so that they're visible with Finder. GConf and AQBanking still have their configuration files in $HOME/.gconf, $HOME/.gconfd, and $HOME/.aqbanking (Note that 2.3.8 and previous used an older version of aqbanking which kept its config files in $HOME/.banking) * The only libdbi module included is for SQLite. If you need either the MySQL or Postgresql modules, you will have to build them yourself and install them into Gnucash.app/Contents/Resources/lib/dbd. There are no OSX-specific changes in 2.3.17 There are no OSX-specific changes in 2.3.16 OSX Changes in 2.3.15 * Gnucash.app now uses Gtk+-2.20.1, which addresses many usability problems with earlier versions. In particular, mouse cursor placement in the register is much better. * AQBanking uses a new Qt4-based wizard which should be more stable than the ported Qt3 wizard of previous releases. *Gnucash-Intel-2.3.15.1* Corrects an aqbanking build problem that caused the Qt3 wizard to be used instead of the Qt4 Wizard. *Gnucash-Intel-2.3.15.2* Corrects a Gtk+ bug that caused menu accelerators to act very weird. *Gnucash-Intel-2.3.15.3* A better patch for the Gtk+ modifier key bug that gets key bindings (the ones that work on things that aren't menu items, like moving around in an edit cell) working, too. Also correct a typo in the accelerator map that caused Actions>Transfer in the Accounts tab menu (but not the Register tab menu) to have an unmodified "T" (as opposed to Command-T) as its accelerator. OSX Changes in 2.3.14 * Cut, Copy, and Paste now work in the register pages! * The untranslated strings in the Gnucash and Window menus have been mostly translated, though there are a couple of languages missing because Google Translation doesn't know them. If yours is one of them, by all means send me a translation (UTF-16, please) and I'll add it in. * The change to the new menu integration routines meant that the menu accelerators were no longer changed from using the control key to using the command key. This is corrected, so Mac users will find their familiar accelerators. *2.3.14.1* Fixed an editing error in Resources/etc/gnucash/environment: The last line should be commented out, like the rest. *2.3.14.2* Fixed a naming error in Resources/share/gnucash/glade/commodity.glade, at line 684: The id should be namespace_cbe, not namespace_cbe1. *2.3.14.3* Fixed a layout bug in aqbanking that caused the bank settings to not display when setting up or editing an account in the aqbanking setup. *2.3.14.4* Fixed a bug in the gtkselection implementation which caused a crash when after copying from one register page one closed that page and attempted to copy from another page. OSX Changes in 2.3.13 * The menu bugs have been fixed, but there are untranslated strings from the integration library. This will be corrected soon. * Help is fixed. OSX Changes in 2.3.12 * Printing works! * WebKit is upgraded to 1.1.15.4, the current psuedo-stable release. OSX Changes in 2.3.11 * Finder aliases have been replaced with Unix relative symbolic links in FinanceQuote Update.app and Update Dirs.app. This should correct problems with the full paths in the aliases not being correctly updated during moves, but it means that if you copy them out of the .dmg, they need to reside in the same folder as Gnucash.app. They will run from the .dmg, and there's really no reason to copy Update Dirs.app anyway; it needs to be run exactly once, and only if you're upgrading from 2.3.8 or 2.2.9. * WebKit is upgraded to its quasi-stable 1.1.15.4 revision. OSX Fixes in 2.3.10.1 * Fixed alias problem with Update Dirs.app * Fixed 2 quoting problems in the launcher-script which generated errors when Gnucash.app is in a path with spaces. * Provide for creating the "prefix" link with administrative privs when the user isn't an admin and therefore doesn't have write privs in /Library. There are no OSX Changes in 2.3.10 OSX Changes in 2.3.9 * Gnucash will now run from paths which include spaces. * The Gnucash configuration files are now stored in $HOME/Library/Application Support/Gnucash instead of $HOME/.gnucash. This allows them to be seen with Finder and edited with TextEdit. * AqBanking and Gwenhywfar are updated to far more recent versions from the ancient versions previously included. This requires updating any aqbanking configuration files. * These changes require running Update Dirs.app, located in the DMG, to migrate to this version from Gnucash 2.3.8 or Gnucash 2.2.9. * There is a convenient applet provided to install/update Finance::Quote. * Newer versions of Gtk+ libraries should provide slightly better OSX integration. OSX Changes in 2.3.8 * Gwenhywfar plugins are now in the bundle (Thanks to Frank Beslmeisl for pointing this out). * Hardcoded paths to perl libraries have been removed, so Finance::Quote installation will work even if you don't have the same perl version installed on your system that was used for the build system. * Updated versions of Gtk+ and dependencies are used, correcting display problems on some dialog boxes. License and Included Binaries: Gnucash is licensed under the Gnu General Public License Version 2, a copy of which can be found in the file LICENSE in this directory and in each bundle's Contents folder. There is also a file "Sources" which lists the several libraries included in the bundle upon which Gnucash depends along with their home webpages where you may find more licensing information and source downloads. A few of the libraries require patches to compile on OSX; all of those patches have been submitted as bugs to the respective libraries, but you'll find them at http://github.com/jralls/gnucash-on-osx/patches if you're really curious.
Source: Gnucash-2.3.17-OSX-Readme.txt, updated 2010-11-21