Looking for the latest version? Download gtk+-1.2.10-20.tar.bz2 (845.8 kB)
Name Modified Size Downloads / Week Status
Parent folder
Totals: 3 Items   5.4 MB 3
cygnome-apps-i18n_1.4b1-2.tar.bz2 2002-12-01 2.2 MB 11 weekly downloads
cygnome-apps-1.4b1-2.tar.bz2 2002-12-01 3.2 MB 11 weekly downloads
cygnome-apps_1.4b1-2.README 2002-12-01 3.9 kB 11 weekly downloads
Package cygnome-apps-1.4 is part of Cygwin GNOME project. Cygwin GNOME is aimed to port GNOME desktop to Microsoft Windows OS, using Cygwin as a porting tool and user environment. See http://cygnome.sourceforge.net for more info. What's This? ------------ This is a convenience package so that you can download all the GTK+/GNOME application ported to Cygwin at one click. This package contains some applications based on GTK+/GNOME. including: amcl-0.7.5 A MUD client for X. dillo-0.6.4 A light-weight GTK-based web browser ee-0.3.12 The Electric Eyes image viewer application. gedit-0.9.7 gEdit is a small but powerful text editor for GNOME. gnome-find-1.0.2 Graphical Version of the GNU find utility gnomeicu-0.96.1 An ICQ client. gnome-pim-1.2.0 GNOME personal productivity applications. gnotepad+-1.3.3 A small and simple but versatile text editor for X. gqview-0.8.1 An image viewer. gtkdiff-1.8.0 A graphical text comparison tool gtksee-0.5.0 An image viewer based on GTK+ resembling ACDSee gtktalog-1.0rc2 The Gnome disk catalog. gtop-1.0.13-4 A system monitor for GNOME. gxtar-0.1.0 GNOME/GTK+ front-end for common archive utilities. hypersrc-2.1.6 hypersrc is a GUI program for browsing source code pan-0.11.2 A GNOME/GTK+ news reader for X. sylpheed-0.8.6 A GTK+ based, lightweight, and fast email client. xchat-1.8.8 A GTK+ IRC (chat) client. You need the core libraries of Cygwin GNOME 1.4. They are in package cygnome-libs-1.4-b1. See /opt/gnome/doc/Cygwin/*.README for individual package dependency. Locale data and documentation of other language are stripped from this package. They are available in cygnome-apps-i18n package. Requirements ------------------ Refer RelaseNotes.txt for detailed info. Only package dependencies are talked about here. * Cygwin These packages are compiled under cygwin 1.3.12, XFree86-4.2.0, with gcc-2.95.3-5, binutils-20011002-1, gettext-0.11.5, libtool-20020705. Due to limitation of time and other resource, it is not tested on other configration. *** So it MAY or MAY not work on your system. You should be warned. **** * Cygwin GNOME core libraries You need the core libraries of Cygwin GNOME 1.4, including glib-1.2, gtk+-1.2, libgnome-1.4, libglade-0.17, imlib-1.9.13, etc. They are available from the convenience package cygnome-libs-1.4-b1. * Other packages And you need libdb3.1, libungif, libiconv\libiconv2, libintl2 at run-time. These packages are mentioned here just because these packages is included in the net-release in recent months. Installation ------------ The working is in progress to make it could be installed via Cygwin setup.exe. But at present, you had to install it by hand. I've prepared a shell script {installpkg.sh} here. Copy it to /usr/local/bin, and call it like this $ installpkg.sh cygnome-apps-1.4-b1.tar.bz You can install serveral packages at one time. It support tarball compressed by gzip or bzip2. In addition, it record the file list into /etc/setup/pkgname.gz, and then add an entry in the Cygwin package database /etc/setup/installed.db. That's to say, it is compliant with Cygwin Setup.exe and you can use setup.exe to perform uninstallation. Note: it couldn't handle package dependency and post-install stuff while setup.exe could. Known Issues ------------ * amcl: plugin feature is not available at present * xchat: plugin feature is not available at present Packager: Hansom Young <hyoung@operamail.com> News ------- Release 2: Add some packages which already existed in 1.4alpha release, including ee-0.3.12, gnomeicu-0.96, gnome-pim-1.2.0, gqview-0.8.1 and gtksee-0.5.0. They also work well in this release (gnome-libs' upgradeing from 1.2 to 1.4 caused some applications compiled in 1.4alpha could not work any more).
Source: cygnome-apps_1.4b1-2.README, updated 2002-12-01