Looking for the latest version? Download gtk+-1.2.10-20.tar.bz2 (845.8 kB)
Home / Internet Applications / gaim-0.59.8-static
Name Modified Size Downloads / Week Status
Parent folder
Totals: 3 Items   870.6 kB 3
gaim-0.59.8-1.tar.bz2 2003-03-11 862.1 kB 11 weekly downloads
gaim-0.59.8-cygwin-static.patch 2003-03-11 3.9 kB 11 weekly downloads
gaim-0.59.8-static.README 2003-03-11 4.6 kB 11 weekly downloads
NAME: gaim VERSION: 0.59.8 RELEASE: 1 SUMMARY: A GTK+ clone of the AOL Instant Messenger client. URL: http://gaim.sourceforge.net DISTRIBUTION: Cygwin GNOME 1.4 <http://cygnome.sourceforge.net> VENDOR: LICENSE: GPL PACKAGER: Hansom Young <glyoung@users.sourceforge.net> GROUP: Applications/Internet OS: Cygwin ARCH: i586 SOURCE: http://prdownloads.sourceforge.net/gaim/gaim-0.59.8.tar.gz DESCRIPTION: Gaim allows you to talk to anyone using a variety of messaging protocols, including AIM (Oscar and TOC), ICQ, IRC, Yahoo!, MSN Messenger, Jabber, Gadu-Gadu, Napster, and Zephyr. These protocols are implemented using a modular, easy to use design. To use a protocol, just load the plugin for it. Gaim supports many common features of other clients, as well as many unique features, such as perl scripting and C plugins. Gaim is NOT affiliated with or endorsed by AOL. About this Cygwin port ----------------------- Built on cygwin-1.3.20, with gcc-3.2-3, binutils-20021117 and esound-0.2.29, gtk-1.2.10, gdk-pixbuf-0.22(static modules), perl-5.6.1. Not yet tested on other configurations. This Cygwin port is a simple one: * It is not compiled as a GNOME panel applet. * All protocols are statically linked in. * Plugin interface is not disabled. This port is built with the following configuration: <<<<< $ CFLAGS=-O2 ./configure --prefix=/opt/gnome \ --disable-plugins --disable-panel --disable-gnome \ --with-static-prpls="oscar,toc,gg,icq,irc,jabber,msn,napster,yahoo,zephyr" ... Allow Multiple Connections.... : yes Build Protocol Plugins........ : no Protocols to link statically.. : oscar toc gg icq irc jabber msn napster yahoo zephyr UI Library.................... : GTK+ 1.2 Use GdkPixbuf................. : yes Build with Plugin support..... : no Build with Perl support....... : yes Use XScreenSaver Extension.... : no Build with ESD................ : yes Build with NAS................ : no Build with ArtsC.............. : no Print debugging messages...... : no Gaim will be installed in /opt/gnome/bin. >>>>>>>> Package dependencies ------- DEPENDS: esound gtk+ gdk-pixbuf perl-5.6.1 $ cygcheck `cygpath -w /opt/gnome/bin/gaim.exe` E:\cygwin\opt\gnome\bin\gaim.exe E:\cygwin\opt\gnome\bin\cygesd.dll E:\cygwin\opt\gnome\bin\cygaudiofile.dll E:\cygwin\bin\cygwin1.dll C:\WinNT\System32\KERNEL32.dll C:\WinNT\System32\NTDLL.DLL E:\cygwin\opt\gnome\bin\cyggdk.dll E:\cygwin\opt\gnome\bin\cygglib.dll E:\cygwin\usr\X11R6\bin\libX11.dll E:\cygwin\usr\X11R6\bin\libXext.dll E:\cygwin\opt\gnome\bin\cyggdk_pixbuf.dll E:\cygwin\opt\gnome\bin\cyggtk.dll E:\cygwin\opt\gnome\bin\cyggmodule.dll E:\cygwin\bin\cygintl-2.dll E:\cygwin\bin\cygiconv-2.dll E:\cygwin\bin\cygjpeg6b.dll E:\cygwin\bin\cygpng2.dll E:\cygwin\bin\cygz.dll E:\cygwin\bin\cygtiff3.dll E:\cygwin\bin\libperl5_6_1.dl Note ----- If you like gaim, you can download native Win32 version from its website: http://gaim.sourceforge.net or http://www.sourceforge.net/projects/gaim There is also a shared version available for Cygwin, in which most protocols could be loaded from DLL. Check http://cygnome.sourceforge.net/download/apps.html ChangeLog --------- Mar 06, 2002 0.59.8-1 Updated to 0.59.8 Jan 06, 2003 0.58-2 Linked in ALL protocols statically. Dec 17, 2002 0.58-1 Updated to 0.58. Nov 24, 2002 0.53-1 First Cygwin GNOME port. Only OSCAR and TOC protocol supported. To build gaim-0.59.8 for Cygwin (static protocols) ------------------------------------------- 1. In order to build gaim for Cygwin 1. Make sure you have glib-devel, gtk+-devel installed. If you have perl, esound, gdk-pixbuf, that would be nice. If you want to build with GNOME panel applet support, you should have gnome-libs, ORBit, gnome-core, gnome-applets. 2. - Unpack source tarball - Apply the patch $ patch -p1 -b < gaim-0.59.8-cygwin-static.patch - Perform configuration. $ CFLAGS=-O2 ./configure --prefix=/opt/gnome \ --disable-plugins --disable-panel --disable-gnome \ --with-static-prpls="oscar,toc,gg,icq,irc,jabber,msn,napster,yahoo,zephyr" If you want to compile gaim as a GNOME panel applet, you can omit --disable-panel and --disable-gnome option. (Note: if you want to enable the plugin interface and built protocals into DLLs, you need a different patch. It is only for 0.58 at present. ) 3. - make - make install
Source: gaim-0.59.8-static.README, updated 2003-03-11