Looking for the latest version? Download gtk+-1.2.10-20.tar.bz2 (845.8 kB)
Home / Internet Applications / gaim-0.58-shared
Name Modified Size Downloads / Week Status
Parent folder
Totals: 3 Items   951.4 kB 3
gaim-0.58-shared.README 2003-01-12 4.3 kB 11 weekly downloads
gaim-0.58-cygwin-shared.patch 2003-01-12 17.3 kB 11 weekly downloads
gaim-0.58-3-shared.tar.bz2 2003-01-12 929.7 kB 11 weekly downloads
NAME: gaim VERSION: 0.58 RELEASE: 3-shared SUMMARY: A GTK+ clone of the AOL Instant Messenger client. DISTRIBUTION: Cygwin GNOME 1.4 VENDOR: LICENSE: GPL PACKAGER: Hansom Young <glyoung@users.sourceforge.net> GROUP: Applications/Internet OS: Cygwin ARCH: i586 SOURCE: ftp://ftp.marko.net/pub/gaim/gaim-%{version}.tar.gz DESCRIPTION: Gaim allows you to talk to anyone using a variety of messaging protocols, including AIM (Oscar and TOC), ICQ, IRC, Yahoo!, MSN Messenger, Jabber, Gadu-Gadu, Napster, and Zephyr. These protocols are implemented using a modular, easy to use design. To use a protocol, just load the plugin for it. Gaim supports many common features of other clients, as well as many unique features, such as perl scripting and C plugins. Gaim is NOT affiliated with or endorsed by AOL. -------------------------------------------------------------------- This Cygwin port is not compiled as a GNOME panel applet, but with plugin support. This port is built with the following configuration: <<<<< $ CFLAGS=-O2 ./configure --prefix=/opt/gnome --disable-panel --disable-gnome Allow Multiple Connections.... : yes Build Protocol Plugins........ : yes Protocols to link statically.. : oscar toc UI Library.................... : GTK+ 1.2 Use GdkPixbuf................. : yes Build with Plugin support..... : yes Build with Perl support....... : yes Use XScreenSaver Extension.... : no Build with ESD................ : yes Build with NAS................ : no Build with ArtsC.............. : no Print debugging messages...... : no >>>>>>>> Package dependencies ------- DEPENDS: esound gtk+ gdk-pixbuf perl-5.6.1 $ cygcheck `cygpath -w /opt/gnome/bin/cyggaim.dll` E:\cygwin\opt\gnome\bin\cyggaim.dll E:\cygwin\opt\gnome\bin\cygesd.dll E:\cygwin\opt\gnome\bin\cygaudiofile.dll E:\cygwin\bin\cygwin1.dll C:\WinNT\System32\KERNEL32.dll C:\WinNT\System32\NTDLL.DLL E:\cygwin\opt\gnome\bin\cyggdk.dll E:\cygwin\opt\gnome\bin\cygglib.dll E:\cygwin\usr\X11R6\bin\libX11.dll E:\cygwin\usr\X11R6\bin\libXext.dll E:\cygwin\opt\gnome\bin\cyggdk_pixbuf.dll E:\cygwin\opt\gnome\bin\cyggmodule.dll E:\cygwin\opt\gnome\bin\cyggtk.dll E:\cygwin\bin\cygintl-2.dll E:\cygwin\bin\cygiconv-2.dll E:\cygwin\bin\libperl5_6_1.dl Note ----- If you like gaim, you can download native Win32 version from its homepage: http://gaim.sourceforge.net or http://www.sourceforge.net/projects/gaim There is another Cygwin port which is built without plugin interface. All protocals are linked in statically. I think it's more stable. ChangeLog --------- Nov 24, 2002 0.53-1 First Cygwin GNOME port. Only OSCAR and TOC protocol supported. Dec 17, 2002 0.58-1 Updated to 0.58. Jan 05, 2003 0.58-2 Linked in ALL protocols statically. Jan 06, 2003 0.58-2-shared Made plugin interface available. Jan 08, 2002 0.58-3-shared Fixed corrupted plugin DLL file: chatlist, iconaway, notify, spellchk ----------------------------------------------------------------------- To build Gaim for Cygwin GNOME with plugin support by yourself (Refer to gaim-0.58.README for instructs to build a static version.) Win32 doesn't allow undefined symbols in DLLs, you can't aceess symbols in EXE from plugins. So it needs a special handling. 1. Make sure you have glib-devel, gtk+-devel installed. If you have perl, esound, gdk-pixbuf, that would be nice. If you want to build with GNOME panel applet support, you should have gnome-libs, ORBit, gnome-core, gnome-applets. 2. Apply the patch gaim_0.58-cygwin-shared.patch. Note that this patch is not complete yet: * Building gaim as a GNOME panel applet is not full supported You may need to get into protocols/*/Makefile.in modify -lgaim to -lgaim_applet * Make order problem is not handled. src/cyggaim.dll should compiled before protocols Type 'make cyggaim.dll' when get into src/ first. When it finished, then make the protocols. 3. Perform configuration. CFLAGS=-O2 ./configure --prefix=/opt/gnome --disable-panel --disable-gnome ( If you want to compile gaim as a GNOME panel applet, you can omit --disable-panel and --disable-gnome option. ) 4. Type make and pray. :-) Note the make order issue mentioned before.
Source: gaim-0.58-shared.README, updated 2003-01-12