SOLVED: Win7 x64, Apache, Skype

Help
2010-06-26
2012-09-25
  • FYI: I'm running Windows 7 Ultimate 64-bit & Z-WAMP 1.1.0, so some of these
    issues could be specific to this setup.

    Just two things to note that threw me for a loop & a few things
    learned/remembered as a result:

    1. Had to run zwamp.exe as Administrator, otherwise I got this error:

    An unhandled exception occurred at $00402908:

    Exception: Unknown Run-Time error: 1005

    $00402908

    $00402C67

    $74D76238

    $74D77298

    $74D77177

    $74D7942C

    $771100E6

    $74D7951E

    $74D7A619

    $00416600

    $0040343F

    Here are instructions on how to always run Z-WAMP as Administrator:
    http://www.vistaclues.com/always-run-an-application-as-an-
    administrator/

    1. Apache was not starting. I couldn't access any error logs through the Z-WAMP interface & forgot to check to see if any were generated, but I was able to see the error in action by opening up a command prompt as Administrator (http://www.blogsdna.com/2168/windows-7-how-to-open-elevated-command-prompt-with-administrator-privileges.htm) and calling apache directly:

      z:.sys\apache2\bin\httpd.exe

    .

    1. The error I got when trying to start apache indicated another application was already listening on port 80. In the command prompt, I used this commend

      netstat -ao

    to find the process ID (PID) of the application already listening & then
    opened up Windows Task Manager (Ctrl + Shift + Esc) to find the matching
    process. If there is no PID column, in the Task Manager menu bar, click "View"
    & then "Select Columns...". Check off PID, click OK, & find the offending app.

    1. For me, the app using port 80 was SKYPE! To correct this, click "Tools"->"Options..."->"Advanced"->"Connection"->uncheck "Use port 80 and 443 as alternatives for incoming connections"->"Save"->restart Skype.
     
  • momendo
    momendo
    2012-07-28

    The previous comment is correct that the desktop Skype client uses port 80 and
    443. Disable it inside the program and restart in order to free up the ports
    for Apache.