Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#134 S. Mario All-Stars/All-Stars+World ?Gfx? Bug

windows
open
nobody
Gfx Bug (63)
5
2006-02-26
2005-02-15
No

I've noticed a little bug with graphics on both Super
Mario All-Stars/Super Mario All-Stars+World ROMs. It
occurs in all versions I've tested, so I suppose it's not a
problem with the dump. (I've used NSRT to verify it...)

They can only be seen in some stages. In water-stages
there's some sort of 'dark line' which crosses the right
border of the window, but only in water-background
(screenshot attached). And there's another 'black line'
crossing the right border of the window in some linear-
stages with water below the platforms (screenshot
attached too).

They can be tested on World 3 Stage 1, World 4 Stage
2 and World 4 Stage 4.

On the other hand, it seems that they aren't displayed if
you turn OFF the 'New Gfx Engine' in the Options Menu...

This is the NSRT 'loginfo':
---------------------Internal ROM Info-----------------
File: Super Mario All-Stars + Super Mario World
(U).SWC
Name: ALL_STARS + WORLD Company: Nintendo
Header: SWC Bank: LoROM
Interleaved: No SRAM: 64 Kb
Type: Normal + Batt ROM: 20 Mb
Country: USA Video: NTSC
ROM Speed: 200ns (SlowROM) Revision: 1.0
Checksum: Good 0x60D8 CRC32: F84305B1

I'm using Win32-ZSNES v1.42 in Windows XP, but it also
happens in versions 1.41 and 1.40.

Discussion

1 2 > >> (Page 1 of 2)
  • Logged In: YES
    user_id=626841

    I almost forgot to mention that the problem is only with Super
    Mario Bros 3 as far as I know... :-P

     
  • Chris Sheehan
    Chris Sheehan
    2005-02-22

    • status: open --> pending
     
  • Logged In: YES
    user_id=1312539

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 365 days (the time period specified by
    the administrator of this Tracker).

     
    • status: pending --> closed
     
    • status: closed --> pending
     
    • summary: S. Mario All-Stars/All-Stars+World żGfx? Bug --> S. Mario All-Stars/All-Stars+World ?Gfx? Bug
     
1 2 > >> (Page 1 of 2)