Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#18 can't compile anything (win2k,ti83)

open
nobody
None
5
2004-03-19
2004-03-19
crackwitz
No

Hi,

I have copied all the windows binaries into c:\z88dk and
subfolders, modified PATH and set the variables. in any
cmd line "zcc" gives me a proper answer.

but on trying "zcc +Ti83 -lm -ltigray83
C:\z88dk\examples\ticalc\world.c" it just doesn't
compile. i haven't been able to compile anything yet.
the attached file contains attempts of compiling two of
the examples on my win2000 machine.

what can i do to make it compile?
thx

Discussion

  • Dominic Morris
    Dominic Morris
    2004-03-19

    Logged In: YES
    user_id=15738

    It looks like you attached the wrong file! Can you try again?

     
  • crackwitz
    crackwitz
    2004-03-21

    cmd line dump of the errors (new)

     
    Attachments
  • Dominic Morris
    Dominic Morris
    2004-03-24

    Logged In: YES
    user_id=15738

    Maybe that was me timing it badly. Anyway, had a look at the
    file and it's a tad strange, it's failing at the assembly
    stage. Can you run with the -notemp option and email me the
    files and I'll try to figure out what's happening.

    cheers

     
  • crackwitz
    crackwitz
    2004-03-24

    Logged In: YES
    user_id=1002158

    The email is out. I've posted the temp files here so everyone
    can take a look.

    thx

     
  • crackwitz
    crackwitz
    2004-03-24

    attempt to compile world.c

     
    Attachments
  • Dominic Morris
    Dominic Morris
    2004-03-25

    Logged In: YES
    user_id=15738

    Okay, I understand that problem now - the module name was
    being set to be the full pathname which includes some
    unfriendly characters. Can you try with new binaries
    downloaded from http://www.algonet.se/~dennisgr/z88dk.htm
    - hopefully these will contain a fix for it.

     
  • crackwitz
    crackwitz
    2004-03-25

    Logged In: YES
    user_id=1002158

    Thanks. I owe this project so much.

    I downloaded the new files and extracted the bins. I had to
    rename the new "cpp.exe" to "zcpp.exe" (the old version)
    though.
    ***** It compiled!! *****
    I used devpac83 to convert the bin and
    ***** It worked!! *****
    ion listed "Hello World" and on execution for 0.3 secs "Hello
    World" flashed on the screen!

    The old files that did not work on my computer (z88dk-win32-
    1.5.zip) were from sourceforge.net/project/showfiles.php?
    group_id=2917

    BTW: I'm working on a computer algebra system (CAS) for TI
    83 nonplus. The first versions are gonna be algo tests under
    PHP. Using ASM for this would drive me insane.

     
  • Logged In: NO

    This error can be fixed by adding the following lines to
    "lib\z80rules.1":

    MODULE%1

    ; MODULE%1

    Make sure there's an empty line between the previous last
    line of the file, and that the new lines are followed by an
    empty line.
    I found that the problem was that at some point, z88dk put
    "MODULE <sourcefile>.c" in one of the assembly files.