#3 Compiling with fltk 1.3/gcc 4.6

closed
None
5
2012-01-02
2012-01-02
Jeremy Jongepier
No

Hi all,
I've recently tried to compile yoshi with fltk 1.3 and gcc 4.6 since this is what my distro is offering at the moment.
This failed due to some classes defined without code content and without initialization leading to ld complaining about many undefined references.

I thought I post a patch here in case now or in the future somebody runs into the same problems. This is only dirty hack straying in some noops where needed, and I think there are better ways to solve this in fltk, but I don't know them. The good thing is that yoshimi compiled well this way and the fltk1.3 rendering seems much better.

Otherwise just put it to the archives

Hope some momentum will gather in the future around this project after Cal's no more, good to see that Will is keeping heads up

All the best
Frank

Discussion

  • 0.060.11 has been released and includes this patch.

    Jeremy

     
    • status: open --> closed