--- a/branches/2.5.4/cgi-bin/yabb2/Admin/Settings_Main.pm
+++ b/branches/2.5.4/cgi-bin/yabb2/Admin/Settings_Main.pm
@@ -15,7 +15,7 @@
 use CGI::Carp qw(fatalsToBrowser);
 our $VERSION = '2.5.4';
 
-our $settings_mainpmver = 'YaBB 2.5.4 $Revision: 1061 $';
+our $settings_mainpmver = 'YaBB 2.5.4 $Revision: 1075 $';
 if ($action eq 'detailedversion') { return 1; }
 
 # Language requirements
@@ -154,9 +154,9 @@
 $default_userpic = 'nn.gif' if $default_userpic eq '';
 
 
-# This is only for update, when comming from YaBB lower or equal version 2.2.3
+# This is only for update, when coming from YaBB lower or equal version 2.2.3
 # I think it can be deleted around version 2.4.0 without causing mayor issues (deti).
-if ($enable_notifications eq '') { $enable_notifications = $enable_notification ? 3 : 0; }
+if ($enable_notifications eq q{}) { $enable_notifications = $enable_notification ? 3 : 0; }
 # End update workaround
 
 require Admin::ManageBoards; # needed for avatar upload settings
@@ -567,6 +567,7 @@
 			input_html => qq~<input type="text" size="5" name="tllastmodtime" id="tllastmodtime" value="$tllastmodtime" />~,
 			name => 'tllastmodtime',
 			validate => 'number',
+			depends_on => ['tllastmodflag'],
 		},
 		{
 			header => $cutts{'8'},