Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#57 Last post not showing in Admin -> View full forum stats.

1 Gold - SP 1.3.1
closed-fixed
nobody
5
2003-07-23
2003-07-09
Anonymous
No

When accessing the 'View Full Forum statistics' in the
admin center, the 'Last post' is always blank. This was
first reported by a user in the forums, and later
tested by me on 3 different 1.3.1 forums, one of them a
clean install. This error does not occur under SP 1.2.

The differnce in code that causes this is as follows:

SP 1.2 - Recent.pl:
sub LastPost {
fopen(FILE, "$vardir/cat.txt");
@categories = <FILE>;
fclose(FILE);

SP 1.3/1.3.1 - Recent.pl:
sub LastPost {
if( ! $yyCatsLoaded) {
fopen(FILE, "$vardir/cat.txt");
@categories = <FILE>;
fclose(FILE);
}

I haven't dug deeper into the code, but it is obvious
that this IF-statement does not work as intended.
Removing the if statement and thus effectively
reverting the code to the one used in SP 1.2 makes this
feature work properly again.

Discussion

  • Torsten Mrotz
    Torsten Mrotz
    2003-07-09

    • status: open --> open-accepted
     
  • Shoeb Omar
    Shoeb Omar
    2003-07-23

    Logged In: YES
    user_id=569410

    Fixed in SP2.

     
  • Torsten Mrotz
    Torsten Mrotz
    2003-07-23

    • status: open-accepted --> closed-accepted
     
  • Torsten Mrotz
    Torsten Mrotz
    2003-07-23

    • status: closed-accepted --> closed-fixed