Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#4 Compling failed

closed
None
5
2007-07-20
2007-06-24
netcelli_gentoo
No

I cant compile xvidcap on my Gentoo Box; I tried the pkg from portage tree and the one from SourceForge.
I made an attachment of the error hopping some1 can help me

Thk ;)

Discussion

  • Log error

     
    Attachments
  • Logged In: YES
    user_id=782084
    Originator: NO

    Any particular reason you are not using the latest version?

     
  • Logged In: YES
    user_id=782084
    Originator: NO

    Also, you don't have liblame/liblame-dev which, I think, was required in that version though configure didn't abort without it.

     
  • Logged In: YES
    user_id=1628981
    Originator: NO

    netcelli_gentoo, please, report this kind of bugs on http://bugs.gentoo.org/. If the problem is from Gentoo side, we'll solve it and won't annoy the author of the app. If the problem is from the app's author we'll either report a bug here or give some hint in Gentoo's bug.

    In this case, I think the problem is from Gentoo, not having set a dependency on lame. So, please, report it to bugs.gentoo.org. Thanks.

    charly4711: 1.1.4_rc1 is the latest stable xvidcap version. 1.1.6 is already on testing.

     
  • Logged In: YES
    user_id=1628981
    Originator: NO

    I just fixed it. You can workaround this doing
    $ emerge lame xvidcap

    Note that xvidcap-1.1.6 will go stable soon.

     
    • assigned_to: nobody --> charly4711
    • status: open --> closed
     
  • Logged In: YES
    user_id=782084
    Originator: NO

    Alright then, I'll close this as half a bug being fixed in a more recent version (configure not bailing out without lame which was needed in that version) and the other half being on the Gentoo side (missing dependency). And the workaround should also be clear now.