Compiling error/depends?

  • I ran out of depends to install, so not sure what to do.

    I have tried compiling a few different -

    ./configure  --with-gtk2 --with-forced-embedded-ffmpeg –enable-dependency-tracking

    This is the last bit that ./configure gives me -

    ,-Bstatic -lavformat -Wl,-Bdynamic -Wl,-Bstatic -lavcodec -Wl,-Bdynamic -Wl,-Bstatic -lavutil -Wl,-Bdynamic -lm -lXmu
    make[2]: Leaving directory `/home/distro/xvidcap/xvidcap-1.1.4rc1/src'
    Making all in po
    make[2]: Entering directory `/home/distro/xvidcap/xvidcap-1.1.4rc1/po'
    make[2]: Nothing to be done for `all'.
    make[2]: Leaving directory `/home/distro/xvidcap/xvidcap-1.1.4rc1/po'
    Making all in man
    make[2]: Entering directory `/home/distro/xvidcap/xvidcap-1.1.4rc1/man'
    make[2]: Nothing to be done for `all'.
    make[2]: Leaving directory `/home/distro/xvidcap/xvidcap-1.1.4rc1/man'
    make[2]: Entering directory `/home/distro/xvidcap/xvidcap-1.1.4rc1'
    make[2]: Leaving directory `/home/distro/xvidcap/xvidcap-1.1.4rc1'
    make[1]: Leaving directory `/home/distro/xvidcap/xvidcap-1.1.4rc1'

    Could someone please tell me what I might be missing?


    • xvidcap-1.1.4rc1.tar.gz

      If it's any help.

      ./configure --with-gtk2 --libdir=/usr/lib

      checking for av_rescale in -lavutil... (static?) ... yes
      checking for img_convert in -lavcodec... (static?) ... yes
      checking for av_write_header in -lavformat... (static?) ... yes
      checking for avcodec_decode_audio in -lavcodec... (static?) ... yes
      checking for lame_init in -lmp3lame... yes
      checking for pthread_mutex_init in -lpthread... yes
      checking for ANSI C header files... (cached) yes
      checking fcntl.h usability... yes
      checking fcntl.h presence... yes
      checking for fcntl.h... yes
      checking limits.h usability... yes
      checking limits.h presence... yes
      checking for limits.h... yes
      checking for stdlib.h... (cached) yes
      checking for string.h... (cached) yes
      checking sys/ioctl.h usability... yes
      checking sys/ioctl.h presence... yes
      checking for sys/ioctl.h... yes
      checking sys/time.h usability... yes
      checking sys/time.h presence... yes
      checking for sys/time.h... yes
      checking for unistd.h... (cached) yes
      checking for stdint.h... (cached) yes
      checking ctype.h usability... yes
      checking ctype.h presence... yes
      checking for ctype.h... yes
      checking stat.h usability... no
      checking stat.h presence... no
      checking for stat.h... no
      checking errno.h usability... yes
      checking errno.h presence... yes
      checking for errno.h... yes
      checking for an ANSI C-conforming const... yes
      checking whether time.h and sys/time.h may both be included... yes
      checking whether gcc needs -traditional... no
      checking for stdlib.h... (cached) yes
      checking for GNU libc compatible malloc... yes
      checking for stdlib.h... (cached) yes
      checking for unistd.h... (cached) yes
      checking for getpagesize... yes
      checking for working mmap... yes
      checking for stdlib.h... (cached) yes
      checking for GNU libc compatible realloc... yes
      checking for fdatasync... yes
      checking for gettimeofday... yes
      checking for memmove... yes
      checking for memset... yes
      checking for munmap... yes
      checking for strcasecmp... yes
      checking for strchr... yes
      checking for strdup... yes
      checking for strstr... yes
      checking for getopt_long... yes
      configure: creating ./config.status
      config.status: creating Makefile
      config.status: creating src/Makefile
      config.status: creating po/
      config.status: creating man/Makefile
      config.status: creating config.h
      config.status: executing intltool commands
      config.status: executing depfiles commands
      config.status: executing default-1 commands
      config.status: executing po/stamp-it commands

    • Well I got it working, but it is very unstable. Ill post a debug later if I can.
      Hopefully someone can tell me what I should do, to get it working as it should.

    • I got a problem with, is using xvidcap in fullscreen.
      However if I am careful, I can do it, but mostly xvidcap will crash, when I try running it with fullscreen.

      ubuntu dapper

      I compiled with -
      ./configure LDFLAGS="-lm" --with-gtk2 --with-forced-embedded-ffmpeg

      I still get the error during “make” as I referred to in the first post. But decided to try an install.

      As I understood it, I should run with  --sync

      (gdb) run --sync
      Starting program: /usr/local/bin/xvidcap --sync
      (no debugging symbols found)
      (no debugging symbols found)
      (no debugging symbols found)
      [Thread debugging using libthread_db enabled]
      [New Thread -1225320768 (LWP 6526)]

      Program received signal SIGSEGV, Segmentation fault.
      [Switching to Thread -1225320768 (LWP 6526)]
      0xb736584d in _getopt_internal_r () from /lib/tls/i686/cmov/
      (gdb) backtrace
      #0  0xb736584d in _getopt_internal_r () from /lib/tls/i686/cmov/
      #1  0xb73668c1 in _getopt_internal () from /lib/tls/i686/cmov/
      #2  0xb736697f in getopt_long () from /lib/tls/i686/cmov/
      #3  0x0806f039 in parse_cli_options ()
      #4  0x0806fc6a in main ()

    • Alright then,
      1) this looks absolutely ok, if you used make before and have all the right things compiled already.

      2) since you're on dapper, you might just install the deb which I created on dapper

      3) If you absolutely want to build from source, you should do:
      - remove the complete directory wher you extracted the tarball
      - unpack the tarball again
      - cd xvidcap-1.1.4rc1
      - type "sudo rules/debian binary" (without the double quotes)
      - dpkg -i ../xvidcap*deb

      - remove the complete directory wher you extracted the tarball
      - unpack the tarball again
      - cd xvidcap-1.1.4rc1
      - type "./configure" (without the double quotes)
      - make && make install

      then, if it crashes, it would be helpful to get the complete command line you're using EXACTLY as you typed it .... because the backtrace you provided suggests a segmentation fault happening while parsing command line options.


    • Thank you for your help.

      As said, I have xgl/compiz installed.
      So I just tested in a gdm session and xvidcap is working perfectly.
      I can't get it to crash, no matter how hard I try.
      I should have thought of it earlier.
      I am going to try to work with xvidcap from terminal in a xgl/compiz session, hopefully it's just the GUI that makes it crash. As said, if I am careful, with marking the screen, it works.

      However, this is how I compiled (just now) under xgl/compiz:

      remove the complete directory where you extracted the tarball
      unpack the tarball again

      sudo make && checkinstall


      “Select rectangular area to capture”

      Box in, fullscreen, xvidcap crashes, leaving error:

      The error was 'BadColor (invalid Colormap parameter)'.
      (Details: serial 4843 error_code 12 request_code 91 minor_code 0)
      (Note to programmers: normally, X errors are reported asynchronously;
      hat is, you will receive the error a while after causing it.
      To debug your program, run it with the --sync command line
      option to change this behavior. You can then get a meaningful
      backtrace from your debugger if you break on the gdk_x_error() function.)

      I get the same with xvidcap_1.1.4rc1_i386.deb, just as it works in a gnome session.

      Can I assume that xgl/compiz are to blame?
      If so, do you have any suggestion, how to go about it?

      I was somewhat fast, with my earlier posts and I see how they could be confusing.
      To my excuse I am not English, so I tend to make some errors. Hope I am a bit more clear this time.

    • Hmm,
      I'm on compiz/AIGLX right now and compiz/Xgl at home with compiz started through gandalfn's python script  from my gnome session on AIGLX and with a much simpler script from a gnome session on Xgl.

      Neither has any large side effects on stability.

      What compiz are you using?
      I'm with the latest quinn debs off


    • I have only been running xgl/compiz for about 4 weeks. I am still on that install. Though all seems fine, I have surly made a few errors alone the way, so no doubt this is my doing.

      However I am up to-date.
      I am using, that's about as much as I know.

      Could it be that I should downgrade something, I might have installed along the way?
      I know this will probably be hard to solve (for me) but I am hoping. 

    • I found a solution, that I am very happy with.
      ~./xvidcap –cap_geometry=1024x768
      I am very surprised how well, this is running, with my low specs.
      Thank you again, for your help and this great app.

      If anyone got 3 min too wast. :)

    • At some point in time after the release of 1.1.4 I'll need to do some real profiling. The funny thing I've noticed is that I can hardly do 800x600 capture @10fps on my 3Ghz P4 with 1GB RAM, but quite well on my Athlon XP2400+ (with 2GB RAM which shouldn't be relevant here).

      I'm puzzled, but will have to look into that later.