Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

1.1.3 : Error while opening codec for output

Help
2005-05-06
2013-04-24
  • 19809@buro:.../src$ ./xvidcap --audio yes --audio_in /dev/dsp -v --continue no --file=test.avi
    job.job_set_file(): Original dimensions: 192 * 144
    job.job_set_file(): Original dimensions: 192 * 144
    control.InitControl(): Original dimensions: 192 * 144
    Current settings:
      frames per second = 25.000000
      video encoding    = MPEG4
      file pattern      = test.avi
      verbose level     = 1
      frames to store   = 0
      time to capture   = 0.000000 sec
      autocontinue      = no
      compression level = 0
      quality (jpeg)    = 75
      input source      = shm (16)
      capture pointer   = white
      capture audio     = yes
       - input          = /dev/dsp
       - sample rate    = 8000
       - bit rate       = 8
       - channels       = 1
      animate command   = animate "%s" -delay %d &
      make video command= ppm2mpeg "%s" %d %d %d %d %f %d &
      edit frame command= display "%s" &
      help command      = x-terminal-emulator -e man xvidcap &
    Error while opening codec for output stream

     
    • What is wrong with this.  I get this only when
      starting with audio

       
    • What is wrong with this ?

       
    • Your audio params are wrong.
      I'd say they don't make a lot of sense ... at any rate ffmpeg can't handle them.

      Try smth. like:
      xvidcap --audio yes --audio_in /dev/dsp -v --continue --file /tmp/blub.avi --audio_rate 24000 --audio_bits 32000 --audio_channels 1

      Of course you could also set sample rate and bit rate parameters accordingly in the preferences dialog.

      HTH,

      Karl.