how to install xvidcap in CenOS?

Help
2007-05-03
2013-04-24
  • Hi all,

    I want to install this software for Linux CENOS, but I don't know how I can do.
    The archive which I download from this site have not configure file yet.
    where can i download full archive? That is the best software for screen capturing.

    [pvinh@cmau xvidcap-1.1.5]$ pwd
    /home/pvinh/data/software/xvidcap-1.1.5

    [pvinh@cmau xvidcap-1.1.5]$ ll
    total 220
    -rw-r--r--    1 pvinh set      61859 Apr 25 15:51 aclocal.m4
    -rw-r--r--    1 pvinh set      21566 Apr 25 16:31 ChangeLog
    -rw-r--r--    1 pvinh set       5624 Apr 25 16:03 config.h.in
    -rw-r--r--    1 pvinh set      18002 Dec  6 22:55 COPYING
    drwxr-xr-x    2 pvinh set        512 Apr 25 16:33 debian
    drwxr-xr-x    4 pvinh set        512 Apr 25 16:32 doc
    -rw-r--r--    1 pvinh set       9498 Dec  6 22:55 INSTALL
    -rw-r--r--    1 pvinh set      22493 Apr 24 22:15 intltool-extract.in
    -rw-r--r--    1 pvinh set      35219 Apr 24 22:15 intltool-merge.in
    -rw-r--r--    1 pvinh set      25684 Apr 25 15:51 Makefile.in
    -rw-r--r--    1 pvinh set          0 Apr 24 22:15 NEWS
    drwxr-xr-x    2 pvinh set        512 Apr 25 16:32 po
    -rw-r--r--    1 pvinh set        260 Apr 24 22:15 xvidcap.desktop
    -rw-r--r--    1 pvinh set       8340 Apr 24 22:15 xvidcap.png

    Thanks

     
    • Dunno where you got your tarball from. The one you can download here has:

      $ tar tvzf ~/Desktop/xvidcap-1.1.5.tar.gz
      drwxrwxrwx 88850/88850       0 2007-04-25 11:33 xvidcap-1.1.5/
      -rw-r--r-- 88850/88850       0 2007-04-24 17:15 xvidcap-1.1.5/NEWS
      drwxrwxrwx 88850/88850       0 2007-04-25 11:32 xvidcap-1.1.5/po/
      -rw-r--r-- 88850/88850       0 2007-04-24 17:15 xvidcap-1.1.5/po/ChangeLog
      -rw-r--r-- 88850/88850     215 2007-04-24 17:15 xvidcap-1.1.5/po/POTFILES.in
      -rw-r--r-- 88850/88850   75495 2007-04-25 11:32 xvidcap-1.1.5/po/de.po
      -rw-r--r-- 88850/88850   50253 2007-04-25 11:32 xvidcap-1.1.5/po/es.gmo
      -rw-r--r-- 88850/88850   70348 2007-04-25 11:32 xvidcap-1.1.5/po/en.po
      -rw-r--r-- 88850/88850    8140 2007-04-25 10:51 xvidcap-1.1.5/po/Makefile.in.in
      -rw-r--r-- 88850/88850   74030 2007-04-25 11:32 xvidcap-1.1.5/po/it.po
      -rw-r--r-- 88850/88850   75574 2007-04-25 11:32 xvidcap-1.1.5/po/es.po
      -rw-r--r-- 88850/88850   51901 2007-04-25 11:32 xvidcap-1.1.5/po/en.gmo
      -rw-r--r-- 88850/88850   56633 2007-04-25 11:32 xvidcap-1.1.5/po/de.gmo
      -rw-r--r-- 88850/88850   58015 2007-04-25 11:32 xvidcap-1.1.5/po/it.gmo
      -rw-r--r-- 88850/88850   45843 2007-04-25 11:32 xvidcap-1.1.5/po/xvidcap.pot
      -rw-r--r-- 88850/88850   25684 2007-04-25 10:51 xvidcap-1.1.5/Makefile.in
      -rw-r--r-- 88850/88850   22493 2007-04-24 17:15 xvidcap-1.1.5/intltool-extract.in
      -rw-r--r-- 88850/88850    9498 2006-12-06 16:55 xvidcap-1.1.5/INSTALL
      -rw-r--r-- 88850/88850     260 2007-04-24 17:15 xvidcap-1.1.5/xvidcap.desktop
      -rw-r--r-- 88850/88850   21566 2007-04-25 11:31 xvidcap-1.1.5/ChangeLog
      -rw-r--r-- 88850/88850    5624 2007-04-25 11:03 xvidcap-1.1.5/config.h.in
      ...
      -rwxr-xr-x 88850/88850   32560 2006-11-08 08:44 xvidcap-1.1.5/config.sub
      -rwxr-xr-x 88850/88850   15936 2006-12-06 16:55 xvidcap-1.1.5/depcomp
      -rwxr-xr-x 88850/88850  438274 2007-04-25 10:51 xvidcap-1.1.5/configure (!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!)
      -rwxr-xr-x 88850/88850    1988 2007-04-25 10:51 xvidcap-1.1.5/mkinstalldirs
      -rwxr-xr-x 88850/88850    9233 2006-12-06 16:55 xvidcap-1.1.5/install-sh
      -rwxr-xr-x 88850/88850   11014 2006-12-06 16:55 xvidcap-1.1.5/missing
      -rw-r--r-- 88850/88850   10046 2007-04-24 17:15 xvidcap-1.1.5/TODO.tasks
      -rw-r--r-- 88850/88850   28061 2007-04-24 17:15 xvidcap-1.1.5/intltool-update.in
      -rw-r--r-- 88850/88850   21785 2007-04-25 10:38 xvidcap-1.1.5/configure.in
      -rwxr-xr-x 88850/88850    4504 2007-04-24 17:15 xvidcap-1.1.5/autogen.sh
      -rw-r--r-- 88850/88850      78 2007-04-24 17:15 xvidcap-1.1.5/AUTHORS

       
    • Thank Charly4711,

      If i want to install xvidacap for KDE, how i can do?
      I think rpm package is good for install the software.
      Because my glib version < 2.4, the software can't install.
      Please help me!

      -----------------------------------------------------------
      ./configure
      ....
      ....

      checking pkg-config is at least version 0.9.0... yes
      checking for PACKAGE... Requested 'gtk+-2.0 >= 2.4.0' but version of GTK+ is 2.2.4
      configure: error: Package requirements (gtk+-2.0 >= 2.4.0 libglade-2.0 glib-2.0 gthread-2.0)
      were not met:
      Consider adjusting the PKG_CONFIG_PATH environment variable
      if you installed software in a non-standard prefix.
      Alternatively, you may set the environment variables PACKAGE_CFLAGS
      and PACKAGE_LIBS to avoid the need to call pkg-config.
      See the pkg-config man page for more details.
      -----------------------------------------------------------

      Thanks

       
    • No need to post this multiple times, and you will have to install a more recent version of gtk to use xvidcap.

       
    • I've got to the stage where I managed to update GTK so it installs.  First it complains that it can't find libpangocairo-1.0.so.0, so I install frysk.

      Now it says it can't find libglitz.so.1, of which I don't think there is a version for CentOS4.4.

      What does this do? Can I disable it?

      Any help appreciated.

      Cheers,
      Kristian

       
    • Kristian,
      I don't fully understand where the dependency issue arise, but I suppose while installing gtk (i.e. before even trying to build xvidcap, which fails due to the glib/gtk dependency).
      pango is gnome's font rendering system. cairo is a vector based graphics rendering library and used by gtk since 2.8, glitz is an OpenGL compositing library, which CAN be used as a backend to cairo.

      http://cairographics.org/
      http://en.wikipedia.org/wiki/Cairo_\(graphics)
      http://www.freedesktop.org/wiki/Software/glitz

      This completely depends on your distro and the GTK installation for it ... and I'm afraid I know nothing about CentOS.
      On my edgy system neither xvidcap, libgtk-x11-2.0.so, libpangocairo-1.0.so, nor libcairo.so depend on glitz.

      Karl.

       
    • On my CentOS 5 system, configure failed twice, but each time the error message gave the
      clue for how to fix the problem.

      The first time, it complained
      checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
      To fix this, I installed perl-libxml-perl

      THe second time it said it needed gtk+-2.0 and libglade-2.0, so I installed gtk+-devel and
      libglade2-devel (and accepted the corresponding dependencies).

      After that, all went well.