Segmentation fault 1.1.3 mdk 10.1

Help
2005-07-26
2013-04-24
  • Hi

    evrey time i got to run this application i always get Segmentation fault and im not too sure as to why, i installed xvidcap using mandrakes urpmi not matter what options i choose or if i try through cli i get the same problem and i don't know why

    Please help

    Drakx

     
    • After looking throught the man pages i saw the -v option so here is the out put of that

      gvidcap -v
      job.job_set_file(): Original dimensions: 192 * 144
      Output not a video file or no counter in filename
      Disabling autocontinue!
      job.job_set_file(): Original dimensions: 192 * 144
      control.InitControl(): Original dimensions: 192 * 144
      Current settings:
        frames per second = 30.000000
        video encoding    = MS_DIV2
        file pattern      = test.mpeg
        verbose level     = 1
        frames to store   = 0
        time to capture   = 0.000000 sec
        autocontinue      = yes
        compression level = 0
        quality (jpeg)    = 100
        input source      = shm (16)
        capture pointer   = black
        animate command   = animate "%s" -delay %d &
        make video command= ppm2mpeg "%s" %d %d %d %d %f %d &
        edit frame command= display "%s" &
        help command      = xterm -e man xvidcap &
      job.job_set_file(): Original dimensions: 192 * 144
      Original Selection geometry: 696x504+212+202
      color_table first entry: 0x00000000
      job.job_set_file(): Original dimensions: 696 * 504
      Segmentation fault

      once again thanks for any help you can provided and most of all (if i get this to work =)) thanks for a cool app bout time linux got a desktop capture app no more vnc to record =)

      Drakx

       
    • Hi,

      Do you get your segmentation fault when you click to start the recording?

      You are using gvidcap. Does it help if you select the default theme for gnome? If so your binary version still contains an old bug.

      Regards,

      Karl.

       
    • >> Do you get your segmentation fault when you click to start the recording?

      Hi Karl,

      Yes i do

      >> You are using gvidcap

      Yes used both gvidcap and xvidcap, i've only tryed this in kde will try gnome and let you know how i get on, i did try getting the new version but got an error about one of the deps (cannot remember which i will try and tell you)

      BTW thanks for the repliy

      Drakx

       
    • Hi Karl,

      OK i tryed using gnome and the same out put as the above happened, every time i press record i get the seg fault also i tryed to install xvidcap-1.1.3-2.i386 and get this error

      Some package requested cannot be installed:
      xvidcap-1.1.3-2.i386 (due to unsatisfied libpng.so.2)
      do you agree ?

      thanks

       
    • OK after i got round that dep problem now i get a new error that i've not seen before ?

      gvidcap -v
      job.job_set_file(): Original dimensions: 192 * 144
      Output not a video file or no counter in filename
      Disabling autocontinue!
      job.job_set_file(): Original dimensions: 192 * 144
      control.InitControl(): Original dimensions: 192 * 144
      Current settings:
        frames per second = 30.000000
        video encoding    = MS_DIV2
        file pattern      = test.mpeg
        verbose level     = 1
        frames to store   = 0
        time to capture   = 0.000000 sec
        autocontinue      = yes
        compression level = 0
        quality (jpeg)    = 100
        input source      = shm (16)
        capture pointer   = black
        capture audio     = no
         - input          = /dev/dsp
         - sample rate    = 22050
         - bit rate       = 32000
         - channels       = 1
        animate command   = animate "%s" -delay %d &
        make video command= ppm2mpeg "%s" %d %d %d %d %f %d &
        edit frame command= display "%s" &
        help command      = xterm -e man xvidcap &
      job.job_set_file(): Original dimensions: 192 * 144
      Original Selection geometry: 663x470+274+245
      Modified Selection geometry: 662x470+274+245
      color_table first entry: 0x00000000
      job.job_set_file(): Original dimensions: 662 * 470
      gvidcap: symbol lookup error: gvidcap: undefined symbol: __fixunsdfdi

      any ideas?

      Thanks

       
    • Do try using your gvidcap with a gnome theme that does not use pixmaps (like the theme called Default).

      It looks like you have an old version (1.1.3 without patches). There used to be a bug where the binary was linked against libpng v2 whereas gnome uses libpng v3. That causes a segfault when using a pixmap theme.

      If you feel up to it, try building 1.1.3 from source.
      Otherwise contact the package maintainer of your package and send him the FAQ entry:
      http://www.jarre-de-the.net/faq/index.php?aktion=artikel&rubrik=004&id=18&lang=en

      HTH,

      Karl.

       
    • Thank you =)

      i managed to compile the 1.1.3-p7 source and made an rpm for it on mandrak10.1 and all works well infact better

      Thank you so much

       
    • Any possibility of sharing your rpm?

      I have the exact same problem you had, but having problems compiling from source.