Configure script failed on pthread / SUSE 10.

Help
2006-09-22
2013-04-24
  • As there is no xvidcap-1.1.4rc1 rpm for SUSE.1, I tried to compile it from source.

    I have a problem with configure script in SUSE 10.1. I have all devel packgages (including glibc) in my system, so I can't understand where the problem is.

    fragment of configure error:
    ----------------
    checking for av_rescale in -lavutil... no
    checking for img_convert in -lavcodec... no
    checking for av_write_header in -lavformat... no
    checking for lame_init in -lmp3lame... no
    To use mp3 audio codecs you need liblame/liblame-dev
    checking for pthread_mutex_init in -lpthread... no
    xvidcap requires libpthread for recording. This machine doesn't have the libraries and/or header files installed.
    ----------------

    I though it's because the system variable $LIBS is not set in SUSE by default! When I set with:
    export LIBS=/usr/include
    I get another error:
    ----------------
    checking for C compiler default output file name... configure: error: C compiler cannot create executables
    See `config.log' for more details.
    ----------------

    Any advices?
    thx in advance

     
    • should be fixed in current svn trunk.
      Try configuring like this:
      LDFLAGS="-L/usr/X11R6/lib" ./configure

       
    • Thx very much. That works. I didn't believed that anybody would help with this.

       
      • you should be more optimistic ;)
        and welcome