Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Record .mov

Help
2006-08-23
2013-04-24
  • Hello to all

    I'm trying to record a movie from my screen using xvidcap, this is the command string I used:

    xvidcap --mf --source x11 --codec svq1 --format mov --audio no --file exec.mov --fps 7.5 --gui yes --cap_geometry 610x450+205+150

    when I press the rec button on the gui the program crashes,

    these are the only info I could retrieve
    Hope to be usefull.

    Can anyone help me?

    Thanks in advance, and thanks for the program, is very usefull

    Max
    Backtrace was generated from '/usr/bin/xvidcap'

    (no debugging symbols found)
    Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    [Thread debugging using libthread_db enabled]
    [New Thread -1225197888 (LWP 14144)]
    [New Thread -1241887824 (LWP 14147)]
    (no debugging symbols found)
    0xffffe410 in __kernel_vsyscall ()
    #0  0xffffe410 in __kernel_vsyscall ()
    #1  0xb739b8c4 in poll () from /lib/tls/i686/cmov/libc.so.6
    #2  0xb74fb7e8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
    #3  0xb74fbcb8 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
    #4  0xb7a72765 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
    #5  0x08061025 in xvc_ui_run ()
    #6  0x0806c929 in main ()

    Thread 2 (Thread -1241887824 (LWP 14147)):
    #0  0xffffe410 in __kernel_vsyscall ()
    No symbol table info available.
    #1  0xb74ce48b in __waitpid_nocancel () from /lib/tls/i686/cmov/libpthread.so.0
    No symbol table info available.
    #2  0xb7ee18e6 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
    No symbol table info available.
    #3  <signal handler called>
    No symbol table info available.
    #4  0x0806f2ed in XImageToFFMPEG ()
    No symbol table info available.
    #5  0x0805e4f2 in TCbCaptureX11 ()
    No symbol table info available.
    #6  0x08061733 in do_record_thread ()
    No symbol table info available.
    #7  0xb74c8341 in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
    No symbol table info available.
    #8  0xb73a54ee in clone () from /lib/tls/i686/cmov/libc.so.6
    No symbol table info available.

    Thread 1 (Thread -1225197888 (LWP 14144)):
    #0  0xffffe410 in __kernel_vsyscall ()
    No symbol table info available.
    #1  0xb739b8c4 in poll () from /lib/tls/i686/cmov/libc.so.6
    No symbol table info available.
    #2  0xb74fb7e8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
    No symbol table info available.
    #3  0xb74fbcb8 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
    No symbol table info available.
    #4  0xb7a72765 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
    No symbol table info available.
    #5  0x08061025 in xvc_ui_run ()
    No symbol table info available.
    #6  0x0806c929 in main ()
    No symbol table info available.
    #0  0xffffe410 in __kernel_vsyscall ()

     
    • can reproduce this with svn trunk ...
      seems to work with just changing codec to mpeg4

      would you mind filing this as a bug?
      Thanks,
      Karl.

       
    • HyperCiclope
      HyperCiclope
      2006-08-24

      Thank'you.
      I'have to study how to use the svn trunk.
      Max