Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

audio control in preferences gone

Help
2009-05-18
2013-04-24
  • woodworker12
    woodworker12
    2009-05-18

    Take a look at these two pics:

    This one is a screenshot from the helpfile of xvidcap:
    http://www.flickr.com/photos/11774983@N02/3542071927/

    The other one is a screenshot of xvidcap on my computer:
    http://www.flickr.com/photos/11774983@N02/3542071671/

    They are supposed to be the same. Why did the audio section of Xvidcap disappear on my system?

     
    • This is probably because something went wrong with your xvidcap build. You should closely watch the output of configure for errors, esp. around the ffmpeg compliation.
      If you've installed from a package, something's wrong with the way the package or the needed ffmpeg package is built.

      Karl.

       
    • woodworker12
      woodworker12
      2009-05-20

      I installed Xvidcap from the Ubuntu repository. That means that I had no control of the build.

      So this is what I did: I deinstalled Xvidcap and then reinstalled it from the command line. It gave no errors during install.

      And again, no audio controls. Thus no audio codec.

      Look at my previous post on this forum. Ubuntu uses libmp3lame and I think that Xvidcap uses liblame0. I cannot download liblame0 because it will disrupt files on my system.

      Since I am no computer whiz, I don't know what to do about this. I certainly cannot compile it myself. That is why I ask for help on this forum.

       
    • herman94
      herman94
      2009-07-13

      I'm a Newbee and no computer whiz too , having the same problem. Using Ubuntu 9.4
      So unfortunately I cannot have sound in captures.
      I'm using ASUS M4N78 Pro motherboard and AMD X2 7850+, 2x 2GB DDR2 800MHZ. NVidia 8300.
      Test in Terminal:
      ubuntu@ubuntu-desktop:~$ ls/proc/asound
      bash: ls/proc/asound: No such file or directory
      ubuntu@ubuntu-desktop:~$ ls /proc/asound
      card0  cards  devices  modules  NVidia  oss  pcm  seq  timers  version
      ubuntu@ubuntu-desktop:~$ ls -la /proc/asound
      total 0
      dr-xr-xr-x   5 root root 0 2009-07-13 00:14 .
      dr-xr-xr-x 147 root root 0 2009-07-12 23:41 ..
      dr-xr-xr-x   5 root root 0 2009-07-13 00:14 card0
      -r--r--r--   1 root root 0 2009-07-13 00:14 cards
      -r--r--r--   1 root root 0 2009-07-13 00:14 devices
      -r--r--r--   1 root root 0 2009-07-13 00:14 modules
      lrwxrwxrwx   1 root root 5 2009-07-13 00:14 NVidia -> card0
      dr-xr-xr-x   2 root root 0 2009-07-13 00:14 oss
      -r--r--r--   1 root root 0 2009-07-13 00:14 pcm
      dr-xr-xr-x   2 root root 0 2009-07-13 00:14 seq
      -r--r--r--   1 root root 0 2009-07-13 00:14 timers
      -r--r--r--   1 root root 0 2009-07-13 00:14 version
      ubuntu@ubuntu-desktop:~$ ls /proc/asound/NVidia
      codec#0  codec#3  id  oss_mixer  pcm0c  pcm0p  pcm3p
      ubuntu@ubuntu-desktop:~$ ls /proc/asound/NVidia/pcm0c
      info  oss  sub0  sub1
      ubuntu@ubuntu-desktop:~$ cat /proc/asound/NVidia/pcm0c/info
      card: 0
      device: 0
      subdevice: 0
      stream: CAPTURE
      id: VT1708S Analog
      name: VT1708S Analog
      subname: subdevice #0
      class: 0
      subclass: 0
      subdevices_count: 2
      subdevices_avail: 2
      ubuntu@ubuntu-desktop:~$

       
      • FYI: I'm in the process of creating a 9.04 deb WITH audio enabled. Will upload ASAP.

         
        • herman94
          herman94
          2009-07-13

          Dear Charley,

          Thank you very much...!
          Can't wait... Where will you upload this file? How long will it take? Is Skype included? That gave many problems too as you probably will know.

           
        • Can you create one for 64bit (amd64)? Love xvidcap, but I need sound badly. Is there any way to get Ubuntu 9.04 64Bit working with sound capture?

          Thanks in advance...a great program!
          Mike

           
          • Have you tried it? Don't know a whole lot about the amd64 platform, but it should be able to run 32bit binaries and it should allow you to install the libraries xvidcap depends as 32bit versions if required. ldd /usr/bin/xvidcap should show you which those would be.

            Karl.

             
            • herman94
              herman94
              2009-08-17

              Thank you Karl, I tried it, but still the only way to get sound in my capture is by using the microphone near the loudspeaker.... unfortunately a little childish!
              Something in the standard configuration of Ubuntu must be wrong. But I will keep trying...

              Another little problem is that Ubuntu asks me regualary to update xvidcap, but when I do so, I get the old problem back, no audiocontrol in preferences.
              So I have to stay extra alert updating Ubuntu.

               
              • yes, I was just referring to running the packaged binary on the amd64 platform.
                The audio capture from applications is normally a mixer config thing.

                To keep the ubuntu update from overwriting the sourceforge package, you can set the package to hold (install the package from SF, run aptitude, find xvidcap and press = )
                Karl.

                 
                • herman94
                  herman94
                  2009-08-17

                  Thanks Karl for your advice!

                   
    • It's there now!
      Look for the file in the 1.1.7 release called: xvidcap_1.1.7jaunty_i386.deb

      The only issue with Skype that I'm aware of is one I cannot really do anything about. Skype seems to use some kind of video acceleration. And (as with things like mplayer) unless you can turn that off, there is no way for xvidcap to capture the video, other than using smth. like VNC in between.

       
      • herman94
        herman94
        2009-07-14

        Thank you very much Charley for your work and postings.

        You say: it's THERE. Please tell me where that is. So where can I find your file? I'm new here, so don't know .

         
        • Click files and then download: xvidcap_1.1.7jaunty_i386.deb

           
    • Thank you charly. Was looking forward to it. Woodworker12

       
    • herman94
      herman94
      2009-07-14

      Thank you very much Charley. There is now indeed the possibility of sound. Also in the preferences of xvidcap.
      Though there is still the problem that the sound only can get saved by using the microphone plugged in the motherboard putting the microphone close to the loudspeaker. Without using the microphone unfortunately I cannot get sound in the file.
      I tried typing alsamixer in the terminal and adjusting there, or System ->Preferences-->Sound. Played there around but unfortunatey  I don't succeed getting the sound in the file without using the microphone or making a wire connection between headphone and microphone plug on the backside of the computer in the motherboard.

      In the preferences next to "enable audio" and "Input device" I see: /dev/dsp
      In the square with three dots "..." next to it I find a menu with all maps maps in Ubuntu 9.4
      Below: Audio Codec = Auto
      Below that: Sample rate 44100
      Below that: Bit Rate 64000
      Below the slider : moving Channels 1.0 <-->2.0 nothing happens.

      Any idea how to solve this more professionally?