Unable to use Xtheater

  • John

    Hi friends,

    On trying to play a VCD through Xtheater 1.0.0.-pre , I get the following error
    "Open of VCD failed, error was: Unable to load player smpeg: /usr/local/Xtheater/player/libsmpeg.so: cannot open shared object file: No such file or directory"

    I am using Redhat Linux 9

    I have used the following installation procedure
    1)SDL-1.2.5-3 and SDL-devel-1.2.5-3 was already installed on my machine
    2)Installed smpeg-0.4.4-1.i386.rpm and smpeg-devel-0.4.0-1.i386.rpm
    3)./configure --enable-qt=no --with-win32-path=/usr/local/Xtheater/win32  --enable-sdl
    Partial output on console after running this is

    loading cache ./config.cache
    checking for glib-config... (cached) /usr/bin/glib-config
    checking for GLIB - version >= 1.2.0... yes
    checking for gtk-config... (cached) /usr/bin/gtk-config
    checking for GTK - version >= 1.2.0... yes
    checking for sdl-config... (cached) /usr/bin/sdl-config
    checking for SDL - version >= 1.2.0... yes
    checking for smpeg-config... (cached) no
    checking for avifile-config... (cached) no
    checking how to run the C preprocessor... (cached) gcc -E
    checking for X11/extensions/dpms.h... (cached) yes
    checking for DPMSDisable in -lXext... (cached) yes
    checking for limits.h... (cached) yes
    checking for working const... (cached) yes
    checking return type of signal handlers... (cached) void
    creating ./config.status

    Can you please tell me what is wrong