How to diagnose xrdp blank or black screen?

xrdp
2011-12-13
2013-12-05
  • Dale E. Moore
    Dale E. Moore
    2011-12-13

    I've got 3 different Ubuntu machines I'd like to rdp into. Each of them appear to be setup correctly except that when I initiate an rdp session I get a blank or black screen. On each server there is ssh task activity, but; no matter how long I wait there's never any display.

    I apt-get install xrdp and apt-get install tightvncserver. (I install tightvncserver because some here report that fixed their blank screen problem.) But tightvncserver installation did nothing to help.

    Neither /var/log/xrdp-sesman.log nor /var/log/sesman.log show any activity.

    /etc/xrdp/sesman.ini include

    [Logging]
    LogFile=/var/log/xrdp-sesman.log
    LogLevel=DEBUG
    EnableSyslog=0
    SyslogLevel=DEBUG
    

    How do you diagnose xrdp and determine what piece is broken?
    DaleEMoore@gMail.Com

     
  • LawrenceK
    LawrenceK
    2011-12-14

    i) We have had issues with the bit depth of the client, try setting the rdp client to 16 bits before connecting.

    ii) try running xrdp manually
    i.e. sudo /etc/init.d/xrdp stop
    sudo xrdp
    you may need to enter a path for xrdp, cannot remember where installed by Ubuntu I suspect /sbin

     
  • Dale E. Moore
    Dale E. Moore
    2011-12-22

    Thanks Lawrence!

    256, 15-bit, 16-bit and 24-bit all go to black screen.

    root@Crackers:~# /etc/init.d/xrdp stop
    * Stopping RDP Session manager
       …done.
    root@Crackers:~# which xrdp
    /usr/sbin/xrdp
    root@Crackers:~# xrdp
    root@Crackers:~# cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=11.10
    DISTRIB_CODENAME=oneiric
    DISTRIB_DESCRIPTION="Ubuntu 11.10"
    still goes to black screen.

    top shows nothing happening.

    root@Crackers:/var/log# ll -tr

    -rw----- 1 root              root    4852 2011-12-21 22:43 xrdp-sesman.log
    -rw-r--- 1 syslog            adm    22890 2011-12-21 22:45 syslog
    -rw-r--- 1 syslog            adm   750662 2011-12-21 22:50 auth.log

    auth.log shows the ssh login and exit.
    syslog shows nothing recognizable

    root@Crackers:/var/log# tail xrdp-sesman.log

      listening…
      shutting down sesman 1

    Is there any way I can get more detail out of what's hanging and why? Can I expand the verbosity of the logging? Can I look in other log files?

    I appreciate your help,
    Dale

     
  • Dale E. Moore
    Dale E. Moore
    2012-01-06

    Does anyone have any suggestions about how to diagnose this problem?

     
  • david marron
    david marron
    2012-02-23

    I didn't write this, but changed it a bit-it worked for me

    at first boot, login as root
    aptitude install tightvncserver
    aptitude install xrdp
    reboot computer
    aptitude install xorg
    aptitude install nano
    reboot computer

    attempt remote login to desktop using the Windoze Remote Desktop & the remote computer's ip address (not the computer name)
    script for finding your ip address: ifconfig
    If you cannot login remotely at this point, then login locally.
    Again try the Remote Desktop. If you cannot get in remotely at this point-

    You might try editing the following:

    Editing of xrdp.ini (optional)

    sudo nano /etc/xrdp/xrdp.ini

    Edit xrdp.ini to read:

    bitmap_cache=yes
    bitmap_compression=yes
    port=3389
    crypt_level=low
    channel_code=1

    name=RDP_To_TightVNC
    lib=libvnc.so
    username=ask
    password=ask
    ip=127.0.0.1
    port=-1

    Reboot & try remote login again. If you still cannot login remotely, then do this:
    Create a new user on the machine. Make this user "auto login" so that the machine boots directly to his Desktop. Change his desktop settings so that he goes to screensaver in one minute.

    Reboot the machine.
    You should now be able to use another computer to access your desktop on this machine. If not, I do not know what is wrong.

    To setup for a headless operation:
    Create the xorg.conf in /etc/X11

    Create the xorg.conf file by in this manner:
    In Root Terminal
    sudo nano /etc/X11/Xwrapper.config
    Use "File/ Save As" and name the new file xorg.conf
    Delete all that is inside the new xorg.conf file.
    Copy & pasted the following into the empty xorg.conf file:

    Section "Device"
    Identifier "VNC Device"
    Driver "vesa"
    EndSection

    Section "Screen"
    Identifier "VNC Screen"
    Device "VNC Device"
    Monitor "VNC Monitor"
    SubSection "Display"
    Modes "1024x768"
    EndSubSection
    EndSection

    Section "Monitor"
    Identifier "VNC Monitor"
    HorizSync 30-70
    VertRefresh 50-75
    EndSection

    Save & Close.

    Ready to Reboot Headless & without a monitor!

     

  • Anonymous
    2012-05-29

    I had the same issue. For me it was because I was passing in the domain to logon to. Removing that fixed the issue!

     
  • hank roberts
    hank roberts
    2012-09-28

    >  it was because I was passing in the domain

    Thank you Josh, removing the Domain fixed the black screen for me also

     
  • Florian Wagner
    Florian Wagner
    2013-04-30

    Hey Josh,

    can you specify what you removed from which file?

    Thanks a lot!

     
  • Jackson
    Jackson
    2013-12-05

    Hi,

    Saving the domain in the form of "mydomain\username" in your client login details causes the black screen.
    If I don't save the domain portion and type it in to the username field manually, it works fine.

    My linux machines authenticate against our AD server, therefore I am required to enter the domain in the username field.

    Does anyone know a way of saving the credentials with the domain, without causing the black screen?

    Thanks!