#18 javancss-21.41 fails if Generics are used

open
None
7
2009-01-05
2009-01-05
Bert Kandert
No

XRADAR 1.0 uses javancss-21.41 and this version does not support Generics. The newer version javancss28.49 shall be used instead.

Discussion

  • Bert Kandert
    Bert Kandert
    2009-01-05

    • priority: 5 --> 7
    • assigned_to: nobody --> rpelisse
     
  • Romain PELISSE
    Romain PELISSE
    2009-01-05

    • labels: 1145763 -->
    • milestone: 879431 -->
    • assigned_to: rpelisse --> francois_ld
     
  • Romain PELISSE
    Romain PELISSE
    2009-01-05

    Would mind providing us a patch for this ? Have you test this ? Last time i check i failed to use the newer version of javancss with XRdar ?

    Note: that i switch this from bug to feature request... Using an old version of javancss is hardly a bug.

     
  • Bert Kandert
    Bert Kandert
    2009-01-09

    I already used javancss28.49 with XRADAR 1.0 and did not have any problems and I would assess this as a bug if XRADAR shall support Java 5.0. If XRADAR support only older version than it is a feature request.
    I allways used JDK 5.0 or JDK 6.0 only. By the way, the EOL transition for J2SE 5.0 ends on October 30th, 2009.

     
  • There is another request to update javancss (#2799872). I think this one is outdated :-).

    By the way does XRADAR support java 5.0 or not? If yes - than you should handle the old version of javancss as a bug.