Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#27 xqf-1.0.4/gtk+-2.8.x problems

closed-fixed
Ludwig Nussel
None
5
2006-06-18
2006-01-01
Anonymous
No

Hi,

I'd like to point you to a bug that was reported by
several gentoo-users @
http://bugs.gentoo.org/show_bug.cgi?id=114149
xqf-1.0.4 (didn't test earlier versions) seems to
sefault as soon as compiled with gtk+-2 support and
gtk+-2.8.x being installed...

Cheers
Polynomial-C

Discussion

  • Logged In: NO

    The older version also fails to start with same errors. I
    believe it worked fine before the switch to gcc-3.4.4 on
    Gentoo.

     
  • Ludwig Nussel
    Ludwig Nussel
    2006-01-02

    Logged In: YES
    user_id=333900

    looks like there is something broken with your xpm loader.
    Works fine with gtk2-2.8.3-4.3 on SUSE 10.

     
  • Logged In: NO

    Hi,

    I doubt this is a problem with gcc-3.4.4 as I had xqf
    working with gcc-3.4.4 until I upgraded gtk+ to a version
    between 2.8.6 to 2.8.8 (don't know the exact version). I
    currently have gtk+-2.8.9 installed which causes the same
    error with a gtk+-2 enabled xqf.
    If you need any more information I'd be glad to deliver
    them...

    Cheers
    Polynomial-C

     
  • Ludwig Nussel
    Ludwig Nussel
    2006-01-04

    • assigned_to: nobody --> l-n
     
  • Ludwig Nussel
    Ludwig Nussel
    2006-01-04

    Logged In: YES
    user_id=333900

    Could you please check whether the attached patch fixes
    the problem?

     
  • Ludwig Nussel
    Ludwig Nussel
    2006-01-04

    fix

     
    Attachments
  • Logged In: NO

    The attached patch fixes this for me. Thanks.

     
  • Ludwig Nussel
    Ludwig Nussel
    2006-06-18

    Logged In: YES
    user_id=333900

    fixed in cvs

     
  • Ludwig Nussel
    Ludwig Nussel
    2006-06-18

    • status: open --> closed-fixed